Recording times are off

Post Reply
frostillicus

Posts: 25
Joined: Sat Mar 05, 2016 9:33 pm
Location:

HTPC Specs: Show details

Recording times are off

#1

Post by frostillicus » Sat Mar 05, 2016 9:49 pm

I've been using WMC for a couple years and it's been pretty solid most of that time. Just recently (for about a week) I've been finding that recordings are suddenly starting too late or ending too early. I'm not talking about 2-3 minutes because of another show that needs the tuner. I mean a show that's supposed to start at 8pm doesn't start until 8:37pm. I'm not sure if this is a guide issue or something else. When I look at the guide or my scheduled recordings, they show the right times. Anybody else experiencing this? Any ideas of what I could check? I haven't done too much, but here is what I've tried so far: rebooting my computer, restarting my hdhomerun prime, deleting and redoing my scheduled recordings, and telling WMC to manually download the new guide info. The Windows time setting was 5 minutes off, but I've corrected that. That didn't make a difference as it still happened after that correction.

To clarify, it's not all of my recordings. I have several that continue to work just fine. So far I have only noticed this on The 100, The Walking Dead, Survivor, and The Bachelor. There may be others that I just haven't noticed yet, but certainly not every recording.

Space

Posts: 1894
Joined: Sun Jun 02, 2013 9:44 pm
Location:

HTPC Specs: Show details

#2

Post by Space » Sat Mar 05, 2016 10:27 pm

frostillicus wrote:I've been using WMC for a couple years and it's been pretty solid most of that time. Just recently (for about a week) I've been finding that recordings are suddenly starting too late or ending too early. I'm not talking about 2-3 minutes because of another show that needs the tuner. I mean a show that's supposed to start at 8pm doesn't start until 8:37pm. I'm not sure if this is a guide issue or something else. When I look at the guide or my scheduled recordings, they show the right times. Anybody else experiencing this? Any ideas of what I could check? I haven't done too much, but here is what I've tried so far: rebooting my computer, restarting my hdhomerun prime, deleting and redoing my scheduled recordings, and telling WMC to manually download the new guide info. The Windows time setting was 5 minutes off, but I've corrected that. That didn't make a difference as it still happened after that correction.

To clarify, it's not all of my recordings. I have several that continue to work just fine. So far I have only noticed this on The 100, The Walking Dead, Survivor, and The Bachelor. There may be others that I just haven't noticed yet, but certainly not every recording.
If your clock is off by 5 minutes then you may be having an issue with it. Do you put your PC to sleep when not in use? If so, it could be that the clock battery on your motherboard needs to be replaced.

You can test this by making sure your clock is correct and then putting the PC to sleep for a while. Then when you wake it up, check if the clock is off. If it is off then you most likely need to replace the clock battery on the motherboard.

If WMC is indicating that the recording started at 8:07, then it may not be a problem with the clock, but if it is saying it started at 8pm but is really starting at 8:07pm, then it is most likely the clock.

Normally your clock should not be off by that much because it syncs with a NTP time server, but I know there have been issues with using the standard method to do so. Here is how I have my system set up so that it syncs the time at least once every 12 hours (when the PC is not sleeping, if it is sleeping then it syncs as soon as it wakes up if it missed a 12 hour interval):

» Run taskschd.msc.
» Open the Task Scheduler folder: Task Scheduler Library\Microsoft\Windows\Time Synchronization
» Disable the SynchronizeTime task.
» Run regedit.exe.
» Open the HKEY_LOCAL_MACHINE\System\CurrentControlSet\services\W32Time\TimeProvider\NtpClient key.
» Set SpecialPollInterval to the desired update interval, in seconds (21600 = 6 hours)
- 604800 = 7 days
- 86400 = 24 hrs
- 43200 = 12 hrs *This is what I use
» Run services.msc.
» Select the Windows Time service.
» Set Startup Type to Automatic (delayed start).
» Start the service.

Also recommend using a better time server than time.windows.com:

1) Click on time in lower right corner of task bar.
2) Click on "Change date and time settings..."
3) Click on "Internet Time" tab.
4) Click on "Change settings..." button.
5) Change "Server:" to north-america.pool.ntp.org
6) Click "OK" button. Click "OK" button.

If you have a dying battery, you may want to have your time sync more often so that whenever it comes out of sleep it will sync. Once you have replaced your battery, you can set it back to a more reasonable time like every 12 or 24 hours. However, if while sleeping, your time is really going off by more than 5 minutes then you will still have a problem and you should then set our your PC so that it never goes to sleep until the battery is replaced.

frostillicus

Posts: 25
Joined: Sat Mar 05, 2016 9:33 pm
Location:

HTPC Specs: Show details

#3

Post by frostillicus » Sat Mar 05, 2016 11:40 pm

Thanks for the response. The problem recordings actually do show stamped with the true time that they started...which happens to be incorrect, but is accurate. For example, if it started at 8:37 when it was supposed to start at 8:00, it actually does show 8:37 as the start on the playback. I did have the internet server setting set to time.windows.com. The option that you're referring to isn't a selection on my menu, but I changed it to time.nist.gov. We'll see if that makes a difference. In the Power settings, I already have the "put computer to sleep" set to never. I haven't done anything with a custom schedule yet, but I'll keep an eye on how far off it gets and try that if the gap gets above a couple minutes again.

User avatar
DavidinCT

Posts: 1461
Joined: Mon Feb 13, 2012 3:45 pm
Location:

HTPC Specs: Show details

#4

Post by DavidinCT » Mon Mar 07, 2016 4:02 pm

I normally test the internet time to make sure it works, then I run a Scheduled task for every other day to run this command "echo y|net time /set"

This will force a re-sync of the time. Even the best montherboard's time will drift a little, my step assures me that I never see that issue.
-Dave
Twitter @TheCoolDave

Windows Media Center certified and WMC MVP 2010 - 2012

Space

Posts: 1894
Joined: Sun Jun 02, 2013 9:44 pm
Location:

HTPC Specs: Show details

#5

Post by Space » Mon Mar 07, 2016 4:30 pm

If the recordings indicate the actual time it started instead of indicating the correct time for the show start but really starting late, then it is probably not an issue with the clock.

Look in WMC history to see if there are any messages about why it may be starting late.

frostillicus

Posts: 25
Joined: Sat Mar 05, 2016 9:33 pm
Location:

HTPC Specs: Show details

#6

Post by frostillicus » Tue Mar 08, 2016 12:47 am

When you say WMC history, is there an option for that within Windows Media Center that I'm not seeing or are you just referring to the Windows System/Application Event logs?

frostillicus

Posts: 25
Joined: Sat Mar 05, 2016 9:33 pm
Location:

HTPC Specs: Show details

#7

Post by frostillicus » Tue Mar 08, 2016 1:22 am

I just witnessed this happening again tonight. I have 2 shows scheduled to record at 7:00pm (Central). I happened to notice that it was 5 minutes after as I was browsing around, so went to check the status in WMC under Scheduled Recordings. It showed the 2 programs as expected that were supposed to start recording at 7. Neither showed the red ball indicator that they had started recording. I then went to play Gotham (one of the 2) and it immediately started recording it and the other scheduled recording. It shows the start and end time of 7:00-8 (or 7-9 for my other), but the actual slider doesn't begin until 7:05 when I forced it to start playback. I don't think it's the time setting because my computer time is exactly correct. Unless there are better suggestions, I'm probably going to reload WMC completely. Seems like something may have gotten corrupted with a recent power outtage...which is when this started.

frostillicus

Posts: 25
Joined: Sat Mar 05, 2016 9:33 pm
Location:

HTPC Specs: Show details

#8

Post by frostillicus » Tue Mar 08, 2016 1:24 am

I'm pretty confident that if I had checked it 20 minutes into the program rather than 5, that's when the recording would have begun because that's exactly what happened when I went to watch the start of Once Upon a Time last night. It was like 25 minutes in and that's when it started recording.

Space

Posts: 1894
Joined: Sun Jun 02, 2013 9:44 pm
Location:

HTPC Specs: Show details

#9

Post by Space » Tue Mar 08, 2016 4:01 am

frostillicus wrote:When you say WMC history, is there an option for that within Windows Media Center that I'm not seeing or are you just referring to the Windows System/Application Event logs?
History is in WMC: view scheduled -> History

You can also look in the Event Viewer outside of WMC.

Space

Posts: 1894
Joined: Sun Jun 02, 2013 9:44 pm
Location:

HTPC Specs: Show details

#10

Post by Space » Tue Mar 08, 2016 4:19 am

frostillicus wrote:I just witnessed this happening again tonight. I have 2 shows scheduled to record at 7:00pm (Central). I happened to notice that it was 5 minutes after as I was browsing around, so went to check the status in WMC under Scheduled Recordings. It showed the 2 programs as expected that were supposed to start recording at 7. Neither showed the red ball indicator that they had started recording. I then went to play Gotham (one of the 2) and it immediately started recording it and the other scheduled recording. It shows the start and end time of 7:00-8 (or 7-9 for my other), but the actual slider doesn't begin until 7:05 when I forced it to start playback. I don't think it's the time setting because my computer time is exactly correct. Unless there are better suggestions, I'm probably going to reload WMC completely. Seems like something may have gotten corrupted with a recent power outtage...which is when this started.
There may be a problem with the Task in Task Scheduler that is supposed to start the recording.

Open "Task Scheduler" and go to Task Scheduler Library -> Microsoft -> Windows - > Media Center

Look for a task called "StartRecording". It should be scheduled to execute about 5 minutes before your next scheduled recording (for instance if the next show that is scheduled to record is tomorrow at 7pm, it should be set to execute at 6:55pm (6:54pm if you have 1 minute pre-padding) on 3/8/2016.)

If Task Scheduler indicates that you have any corrupted entries, then that may be your problem.

You can remove corrupt Task Scheduler entries by following the directions in this post: http://www.thegreenbutton.tv/forums/vie ... 01#p102301

Note that in that post it is a different task, but just look for the StartRecording one and delete it.
WMC should recreate the task after you delete it and restart WMC.

frostillicus

Posts: 25
Joined: Sat Mar 05, 2016 9:33 pm
Location:

HTPC Specs: Show details

#11

Post by frostillicus » Tue Mar 08, 2016 2:04 pm

Space, thanks for the help. I'm surprised I never noticed that history option after accessing that same screen in WMC so many thousands of times. Guess I just never needed to look there. It did have entries that showed the (incorrect) times of the recordings, but no acknowledgement by WMC that this was a problem.

I did check the StartRecording task and it showed that the service was set to start at 7:53am. Based on the fact that I have my Recorder setting defaulting to 2 minutes of padding, the 7 minutes early seems to be correct. I had randomly chosen 3 shows from the guide and told them to record at 8 to see if it would work and they all started on time. I suspect this may be due to some additional steps I took this morning.

I removed WMC through the Control Panel - Programs & Features area, then killed the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule\TaskCache\Tree\Microsoft\Windows\Media Center key in Regedit, then reinstalled WMC which rebuilt the registry key. I did not, however, delete the C:\ProgramData\Microsoft\ehome folder as I saw suggested in some other articles. While it seems ok based on my 8am test, I'm going to see how it does tonight on scheduled series recordings and I'll post back. Thanks again for the posts. I really appreciated it.

frostillicus

Posts: 25
Joined: Sat Mar 05, 2016 9:33 pm
Location:

HTPC Specs: Show details

#12

Post by frostillicus » Wed Mar 09, 2016 2:05 am

In case anyone is checking on this or referencing in the future, the steps I mentioned in the previous post seemed to work. I had 2 recordings correctly start at 7pm and 3 more correctly start at 8pm, so I think I'm good. I'll come back one final time after I see how it does through Sunday. If they all work fine between now and Sunday, I'll be fully confident that it's resolved. Thanks again for pointing me in the right direction.

frostillicus

Posts: 25
Joined: Sat Mar 05, 2016 9:33 pm
Location:

HTPC Specs: Show details

#13

Post by frostillicus » Mon Mar 14, 2016 11:59 am

Reporting back to close the loop on this one. This is officially resolved by the steps noted in post #11 of this thread. 100% of my recordings have started at the correct time since Tuesday.

Post Reply