Rollup broke Media Center Again

Post Reply
The Mac

Posts: 94
Joined: Wed Jun 05, 2013 6:09 pm
Location:

HTPC Specs: Show details

Rollup broke Media Center Again

#1

Post by The Mac » Wed Jul 13, 2022 1:54 pm

The latest windows 8.1 rollup KB5015874 broke media center again.

Anyone figure out what happened this time?

jlmdxtv

Posts: 1
Joined: Mon Mar 28, 2016 2:25 pm
Location:

HTPC Specs: Show details

#2

Post by jlmdxtv » Wed Jul 13, 2022 3:47 pm

I've uninstalled this month's update (July/2022) and got WMC working again after some effort getting the guide back and setting up my recording schedules.

I'm opting out of future Windows 8.1 updates instead of waiting until Jan of 2023 for Microsoft to do that for me.

The Mac

Posts: 94
Joined: Wed Jun 05, 2013 6:09 pm
Location:

HTPC Specs: Show details

#3

Post by The Mac » Wed Jul 13, 2022 4:15 pm

i just rolled back system restore to right before the update installed and it put everything back the way it was.

It pays to have system restore active.

Personally, i don't like updates sitting out there and would prefer to get them working properly.

ajse123

Posts: 3
Joined: Wed Mar 09, 2022 6:48 pm
Location:

HTPC Specs: Show details

#4

Post by ajse123 » Wed Jul 13, 2022 7:06 pm

The latest Win 8.1 pro system update (12 July 2022) has wrecked my Windows Media Center - that is twice in the last four months or so that system updates have caused problems to WMC.

I begin to wonder whether this is deliberate tactic by Microsoft with only 6 months to go before it stops supporting this operating system. Luckily, I managed to restore my system from a backup.

In future, I think I will wait a week or two following the release of Microsoft's monthly updates and check this forum, before I install any future system updates !!!

User avatar
IT Troll

Posts: 1039
Joined: Sun Nov 27, 2011 9:42 am
Location: Edinburgh, UK

HTPC Specs: Show details

#5

Post by IT Troll » Wed Jul 13, 2022 7:29 pm

Eek! What are the symptoms this time?
Are you a Recorded TV HD user or want to give it a try? Check out the new community-made update; Recorded TV HD v2.1.1

dougpowers1965

Posts: 6
Joined: Thu Apr 21, 2016 3:49 am
Location:

HTPC Specs: Show details

#6

Post by dougpowers1965 » Wed Jul 13, 2022 10:01 pm

This is the first time it broke mine. It wiped my guide data. I re-ran EPG123 (only the part to re-populate the guide), worked but my recording schedule was gone and the transfer tool was empty. I then went to reset the recordings one-by-one which worked only after causing WMC to error out and auto restart at the last step of setting the recording. So, as others have I used System Restore to go back a few days and reinstalled the updates less the "Quality" Rollup and WMC still working normally.

Burger23

Posts: 53
Joined: Mon Nov 23, 2015 7:04 pm
Location:

HTPC Specs: Show details

#7

Post by Burger23 » Wed Jul 13, 2022 10:06 pm

1. I went into Updates and found that the update ending in 768 was installed pending a reboot
2. I had no choice; I could not uninstall since it was not installed yet. I rebooted.
3. Went to LIVE in WMC- got video error
4. Uninstalled the 768 update and rebooted.
5. After opening Updates, 768 showed up again- and I installed it again.

This time the LIVE view in WMC worked. And, almost immediately, I got this blue screen! http://www.gradygroup.com/misc/abluesceen.jpg. I selected "remind me again after the end of support date"

Since the “Install Complete Pending Restart” messages on 2 computers, and deleted the 768 update, and got WMC to work on both computers, I am wondering if there might have actually been 2 versions of this update. The first, done automatically- and the second done a few hours later. The first had no warning screen about Windows 8 expiring in 2023- and the second did.

Very odd indeed. I am surprised we are not hearing from more people. Perhaps ajse123 below guessed right when he said “deliberate tactic by Microsoft with only 6 months to go before it stops supporting this operating system!!”

The Mac

Posts: 94
Joined: Wed Jun 05, 2013 6:09 pm
Location:

HTPC Specs: Show details

#8

Post by The Mac » Wed Jul 13, 2022 10:24 pm

There was also a "servcing Stack Update" which i believe is where that screen came from.

I dont think that one is a problem.

edit: after messing around on a 3rd machine, it looks like the rollup isnt the issue. I installedit fine and everything worked. After i installed the servicing stack update, thats when it broke.

KB5016264

On 2 machines it blew away the tuners (set up live tv required) and on the 3rd it kept the tuners and running EPG123 restored the guide and re-indexed the upcoming series recordings

weird.

all 3 are windows 8.1 pro with media pack installed separately.

Edit 2: well, it just blew away the tuners on the 3rd machine. Delayed reaction perhaps. system restore here i come.
Last edited by The Mac on Wed Jul 13, 2022 10:56 pm, edited 6 times in total.

Burger23

Posts: 53
Joined: Mon Nov 23, 2015 7:04 pm
Location:

HTPC Specs: Show details

#9

Post by Burger23 » Wed Jul 13, 2022 10:31 pm

Thanks foir clearing the Blue Screen message.
Also I had no issues with Guide or Scheduled Recordings on either machine after getting Live View to work with second reinstall of 768.

Edited afer The Mac's edit: And I had no issues after Service Stacking KB5016264 automatic installs on my 2 Windows 8.1 Pro computers. Go figure.
Last edited by Burger23 on Wed Jul 13, 2022 11:02 pm, edited 1 time in total.

The Mac

Posts: 94
Joined: Wed Jun 05, 2013 6:09 pm
Location:

HTPC Specs: Show details

#10

Post by The Mac » Wed Jul 13, 2022 10:50 pm

Maybe we are the only people left.

lol

The Mac

Posts: 94
Joined: Wed Jun 05, 2013 6:09 pm
Location:

HTPC Specs: Show details

#11

Post by The Mac » Thu Jul 14, 2022 12:24 am

i restored the 3rd machine but the servicing stack update didnt come back only the rollup.

It must be one of those updates thats comes up after you install the rollup.

the .net update and the malicious programs update appear safe.

Bertmace

Posts: 34
Joined: Wed Jul 13, 2022 9:15 pm
Location:

HTPC Specs: Show details

#12

Post by Bertmace » Thu Jul 14, 2022 1:19 am

ehTrace.dll, version: 6.3.9600.20473, is the cause of it the old one was 179 kb and new one is 189 kb had to use ms dart to fix it copy old one back to ehome folder

The Mac

Posts: 94
Joined: Wed Jun 05, 2013 6:09 pm
Location:

HTPC Specs: Show details

#13

Post by The Mac » Thu Jul 14, 2022 1:35 am

why would they change any of the ehome files?

thats implies they made changed recompiled it for some reason.

User avatar
Jacoats

Posts: 60
Joined: Thu Mar 16, 2017 7:57 pm
Location:

HTPC Specs: Show details

#14

Post by Jacoats » Thu Jul 14, 2022 2:00 am

Hmmm I updated and restarted 8.1 twice today. I did see the end of support message but no other issues AFAIK


Sent from my iPhone using Tapatalk

The Mac

Posts: 94
Joined: Wed Jun 05, 2013 6:09 pm
Location:

HTPC Specs: Show details

#15

Post by The Mac » Thu Jul 14, 2022 2:29 am

are KB5015874 and KB5016264 listed as installed in your windows update history?

Bertmace

Posts: 34
Joined: Wed Jul 13, 2022 9:15 pm
Location:

HTPC Specs: Show details

#16

Post by Bertmace » Thu Jul 14, 2022 3:20 am

amd64_microsoft-windows-ehome-reg-inf_31bf3856ad364e35_6.3.9600.20332_none_e6a84a7cafdd2c0d.manifest it is in Windows8.1-KB5015874

Burger23

Posts: 53
Joined: Mon Nov 23, 2015 7:04 pm
Location:

HTPC Specs: Show details

#17

Post by Burger23 » Thu Jul 14, 2022 6:50 am

My apologies for refer to a post below made to an apparently nonexistent Update. My references to an Update ending in 768 should be Update KB5015874.

Also interesting below is a screen shot I took Wednesday morning. Note that it shows 2 installations of KB5015874- one on July 12 and one on July13.
http://www.gradygroup.com/misc/Capture.jpg

And my Windows Updates History now just shows the July 13th update
http://www.gradygroup.com/misc/KB5015874.jpg

Strange to me- but my Windows 8.1 WMC computers are running fine now- so I am happy
Last edited by Burger23 on Thu Jul 14, 2022 7:07 pm, edited 1 time in total.

User avatar
IT Troll

Posts: 1039
Joined: Sun Nov 27, 2011 9:42 am
Location: Edinburgh, UK

HTPC Specs: Show details

#18

Post by IT Troll » Thu Jul 14, 2022 6:39 pm

I've turned off automatic updates (just in time) until the situation is clearer.
Are you a Recorded TV HD user or want to give it a try? Check out the new community-made update; Recorded TV HD v2.1.1

Jason-R

Posts: 33
Joined: Tue Feb 09, 2016 9:47 am
Location:

HTPC Specs: Show details

#19

Post by Jason-R » Thu Jul 14, 2022 7:29 pm

Same problem. After KB5015874 and KB5016264 installed, I got a message that WMC had corrected a problem with recording data and will download the guide again. The guide had been wiped, but did reload by running EPG123. That didn't fix it, and after two failed recording attempts it returned the error message again, this time wiping out both the guide and all my channels. I'm now back to the live tv setup' screen.

Not sure whether a restore of my saved MCE/EPG123 data will just send me around the same loop again...

Bertmace

Posts: 34
Joined: Wed Jul 13, 2022 9:15 pm
Location:

HTPC Specs: Show details

#20

Post by Bertmace » Thu Jul 14, 2022 8:08 pm

I replace the bad ehTrace .dll and everything is running fine and have both KB5015874 and KB5016264 installed to go back to 6.3.9600.16384 11/21/2014 ehTrace.dll, version: 6.3.9600.20473, is the cause of it it is in ehome folder

Post Reply