Updates stopped working again

An evolving, supported alternative to Rovi
Forum rules
★ Download the latest EPG123 here: https://garyan2.github.io/ <> Setup guide here: https://garyan2.github.io/install.html
oldschoolbob

Posts: 53
Joined: Tue Aug 25, 2020 9:56 pm
Location:

HTPC Specs: Show details

Updates stopped working again

#1

Post by oldschoolbob » Sat Nov 18, 2023 10:08 am

I've had problems before after I updated my Subscription. Then mysteriously it started working again. Now after a few months it stopped working again. I haven’t changed anything on my end. I shouldn’t need to renew again for 6 months.
What is going on?
Thanks
Bob

oldschoolbob

Posts: 53
Joined: Tue Aug 25, 2020 9:56 pm
Location:

HTPC Specs: Show details

#2

Post by oldschoolbob » Sat Nov 18, 2023 10:11 am

please delete second posting.

User avatar
garyan2

Posts: 7414
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#3

Post by garyan2 » Sat Nov 18, 2023 5:44 pm

Please check you log file.
- Gary
Keeping WMC alive beyond January 2020. https://garyan2.github.io

oldschoolbob

Posts: 53
Joined: Tue Aug 25, 2020 9:56 pm
Location:

HTPC Specs: Show details

#4

Post by oldschoolbob » Sun Nov 19, 2023 12:52 am

[11/18/2023 4:16:14 PM] [ INFO] Starting EPG123 Server service ...
[11/18/2023 4:16:14 PM] [ INFO] BaseApi: https://json.schedulesdirect.org/20141201/ , BaseArtwork: https://json.schedulesdirect.org/20141201/ , Debug: False
[11/18/2023 4:16:15 PM] [ INFO] HTTP request exception thrown. Message: One or more errors occurred. An error occurred while sending the request. The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. The remote certificate is invalid according to the validation procedure.
[11/18/2023 4:16:15 PM] [ERROR] Did not receive a response from Schedules Direct for a token request.
[11/18/2023 4:16:15 PM] [ INFO] UDP Server initialized.
[11/18/2023 4:16:15 PM] [ INFO] File server initialized with 4 worker threads.
[11/18/2023 4:16:15 PM] [ INFO] Image server initialized with 12 worker threads.
[11/18/2023 4:16:15 PM] [ INFO] EPG123 Server service completed initializations.
[11/18/2023 5:00:01 PM] [ INFO] HTTP request exception thrown. Message: One or more errors occurred. An error occurred while sending the request. The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. The remote certificate is invalid according to the validation procedure.
[11/18/2023 5:00:01 PM] [ERROR] Did not receive a response from Schedules Direct for a token request.

oldschoolbob

Posts: 53
Joined: Tue Aug 25, 2020 9:56 pm
Location:

HTPC Specs: Show details

#5

Post by oldschoolbob » Sun Nov 19, 2023 1:04 am

[11/18/2023 4:16:14 PM] [ INFO] Starting EPG123 Server service ...
[11/18/2023 4:16:14 PM] [ INFO] BaseApi: https://json.schedulesdirect.org/20141201/ , BaseArtwork: https://json.schedulesdirect.org/20141201/ , Debug: False
[11/18/2023 4:16:15 PM] [ INFO] HTTP request exception thrown. Message: One or more errors occurred. An error occurred while sending the request. The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. The remote certificate is invalid according to the validation procedure.
[11/18/2023 4:16:15 PM] [ERROR] Did not receive a response from Schedules Direct for a token request.
[11/18/2023 4:16:15 PM] [ INFO] UDP Server initialized.
[11/18/2023 4:16:15 PM] [ INFO] File server initialized with 4 worker threads.
[11/18/2023 4:16:15 PM] [ INFO] Image server initialized with 12 worker threads.
[11/18/2023 4:16:15 PM] [ INFO] EPG123 Server service completed initializations.
[11/18/2023 5:00:01 PM] [ INFO] HTTP request exception thrown. Message: One or more errors occurred. An error occurred while sending the request. The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. The remote certificate is invalid according to the validation procedure.
[11/18/2023 5:00:01 PM] [ERROR] Did not receive a response from Schedules Direct for a token request.

User avatar
garyan2

Posts: 7414
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#6

Post by garyan2 » Sun Nov 19, 2023 1:55 am

What version of EPG123 are you running?
- Gary
Keeping WMC alive beyond January 2020. https://garyan2.github.io

oldschoolbob

Posts: 53
Joined: Tue Aug 25, 2020 9:56 pm
Location:

HTPC Specs: Show details

#7

Post by oldschoolbob » Sun Nov 19, 2023 2:36 am

Client guide tool v1.8.2.2

User avatar
garyan2

Posts: 7414
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#8

Post by garyan2 » Sun Nov 19, 2023 2:51 am

You can try the newly released 1.8.2.6, but I'm not seeing any TLS/SSL certificate problems with Schedules Direct. I changed the TLS/SSL setting in epg123, but if you weren't having a problem before, you shouldn't have it now.
- Gary
Keeping WMC alive beyond January 2020. https://garyan2.github.io

oldschoolbob

Posts: 53
Joined: Tue Aug 25, 2020 9:56 pm
Location:

HTPC Specs: Show details

#9

Post by oldschoolbob » Sun Nov 19, 2023 8:54 am

What is a token request and how do I get one?

User avatar
garyan2

Posts: 7414
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#10

Post by garyan2 » Sun Nov 19, 2023 6:16 pm

The token is what allows you to download guide data from Schedules Direct and is issued by Schedules Direct when epg123 requests it using your username and password hash; good for 24 hours. You are having problems setting up a secure link with Schedules Direct to get the token.
- Gary
Keeping WMC alive beyond January 2020. https://garyan2.github.io

oldschoolbob

Posts: 53
Joined: Tue Aug 25, 2020 9:56 pm
Location:

HTPC Specs: Show details

#11

Post by oldschoolbob » Mon Nov 20, 2023 6:49 am

Thanks
I contacted Schedules Direct.
Hope they get it fixed.

oldschoolbob

Posts: 53
Joined: Tue Aug 25, 2020 9:56 pm
Location:

HTPC Specs: Show details

#12

Post by oldschoolbob » Tue Nov 21, 2023 12:09 am

I contacted Schedules Direct and got this response:
“Everything looks normal here. I don't see a password reset before renewing (a common problem). Last download was on 11/4.
Maybe if you let your account expire, EPG123 wants your password again?”

I went to EPG123 and I don’t see any place to logon or input my password.
How do I give them my password again?

User avatar
garyan2

Posts: 7414
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#13

Post by garyan2 » Wed Nov 22, 2023 12:10 am

This has nothing to do with your username/password. This has to do with your computer/network not being able to validate the Schedules Direct security license for SSL/TLS connections. Since no one else is reporting a problem validating their license then it has to be local to your machine and network.

Have you tried to update EPG123 to 1.8.2.6 (soon to be 1.8.2.7)? I made a change that may or may not help with whatever changed on your system back on 11/4-11/5.
- Gary
Keeping WMC alive beyond January 2020. https://garyan2.github.io

oldschoolbob

Posts: 53
Joined: Tue Aug 25, 2020 9:56 pm
Location:

HTPC Specs: Show details

#14

Post by oldschoolbob » Wed Nov 22, 2023 8:55 am

First I restored my computer back to 10/29/23. Then I downloaded and ran the EPG123 1.8.2.6. Now I don’t see EPG123 listed on my programs list.
Should this be so complicated?

User avatar
garyan2

Posts: 7414
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#15

Post by garyan2 » Wed Nov 22, 2023 2:03 pm

Your antivirus probably swallowed up 1.8.2.6 because it wasn't signed. Try 1.8.2.7 that I released yesterday which is signed.
- Gary
Keeping WMC alive beyond January 2020. https://garyan2.github.io

oldschoolbob

Posts: 53
Joined: Tue Aug 25, 2020 9:56 pm
Location:

HTPC Specs: Show details

#16

Post by oldschoolbob » Thu Nov 23, 2023 12:06 am

I think what I tried yesterday was 1.8.2.7.
But I downloaded it again today. When I run the install I get this:
“setup has detected that EPG123 is currently running.”
“please close all instances of it now, then click OK to continue or cancel to exit”

How can it be running if it’s not installed?
I get this message even after a fresh bootup.
Image
Attachments
Capture 2.JPG

User avatar
garyan2

Posts: 7414
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#17

Post by garyan2 » Thu Nov 23, 2023 2:29 am

The installer will give that error if the epg123 configuration GUI (epg123.exe) or the epg123 client (epg123Client.exe) is running. You have epg123 installed and one of those executables are running... either trying to download and create the mxf file, or trying to import an mxf file. You will have to close them before installing the latest version.
- Gary
Keeping WMC alive beyond January 2020. https://garyan2.github.io

oldschoolbob

Posts: 53
Joined: Tue Aug 25, 2020 9:56 pm
Location:

HTPC Specs: Show details

#18

Post by oldschoolbob » Thu Nov 23, 2023 5:02 am

How can I close them if I can't find them?
After the computer booted I went straight to the installation.

User avatar
garyan2

Posts: 7414
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#19

Post by garyan2 » Thu Nov 23, 2023 5:17 am

https://visihow.com/transcriber/videos/ ... ws%207.mp4

The video shows how to close applications and processes. Once you open task manager, click the 'Processes' tab and find any/all epg123.exe and epg123client.exe and close them using the End Process button.
- Gary
Keeping WMC alive beyond January 2020. https://garyan2.github.io

oldschoolbob

Posts: 53
Joined: Tue Aug 25, 2020 9:56 pm
Location:

HTPC Specs: Show details

#20

Post by oldschoolbob » Thu Nov 23, 2023 5:51 am

The only thing I found was epgTray.
I closed it and still get the same error message.
Image
Attachments
Capture 3.JPG
Capture 3.JPG

Post Reply