Intel 770 graphics with 8.9.1 WMC full screen issue

Discussion of getting WMC to work on Windows 10 (unsupported)
purpleb

Posts: 48
Joined: Mon Jan 28, 2019 6:52 pm
Location:

HTPC Specs: Show details

Intel 770 graphics with 8.9.1 WMC full screen issue

#1

Post by purpleb » Sun Sep 24, 2023 9:52 pm

I got a newer 12th gen Intel system with 770 graphics.

After installing WMC on Win10 (my guess Win11 same), when I use full screen in WMC and when changing channels or doing other items in WMC, WMC locks up and hangs. Sometimes the screen is blank with the mouse working but that is it. I have to hit Cntrl-Alt-Del to get the system back and WMC works file full screen.

If I do not use full screen, but windowed screen, I do not have the issue. I have all options turned on in compatibility to run WMC with latest Win10 updates and latest Intel graphics driver software.

Is there a registry fix for this? I remember in the early stages of Win10 and WNC, it seemed like it was the same issue. I do not have an issue with the old Intel 630 graphics hardware.

Any ideas for a fix?

Thanks in advance,
purpleb

Kevin Chalet

Posts: 121
Joined: Mon Oct 08, 2018 12:00 pm
Location:

HTPC Specs: Show details

#2

Post by Kevin Chalet » Mon Sep 25, 2023 4:50 pm

Sadly, it's a well-known issue that is now documented by Intel: https://www.intel.com/content/www/us/en ... phics.html (as I guess they received a lot of complaints from buyers of recent Intel NUC models and had to document it publicly :lol:)
TL;DR: given that they see WMC as obsolete software, they consider it incompatible with their new platforms and won't even bother working on a fix (and AFAIK, nobody with a 12th+ generation CPU has found a fix/workaround).

You say it works fine in windowed mode... maybe you should give The Maxifier (that used to be developed by Gary Smith) a try and see how it goes? :)

purpleb

Posts: 48
Joined: Mon Jan 28, 2019 6:52 pm
Location:

HTPC Specs: Show details

#3

Post by purpleb » Tue Sep 26, 2023 4:42 pm

Thanks for the note. I read something on the web on it but not officially. Yes, if not supported, they all like to bail quick compared to fixing a customer issue to help sell more systems. With NUC going away from Intel, that does not help. I use a mini PC which is similar.

I tried The Maxifier 1.12 and that had the same issue. I could not download a newer version to test. Send me a link if you have one for 1.15 which was released.

I use WMC and use the old Kodi integration app info WMC for a solution only using the WMC remote. Now coming back from Kodi into WMC, it goes full screen so I have to use a mouse to change WMC back to windowed for no hangs.

Thanks again,
PurpleB

Kevin Chalet

Posts: 121
Joined: Mon Oct 08, 2018 12:00 pm
Location:

HTPC Specs: Show details

#4

Post by Kevin Chalet » Thu Sep 28, 2023 7:26 pm

I found the 1.5b2 installer on one of my machines and posted it on Mega: https://mega.nz/file/SXYnyByT#j_O3lfQub ... ngdzgY-69I

If it still doesn't work, you can give ExpandWnd a try: download the archive from https://github.com/urbans0ft/ExpandWnd/ ... s/tag/v1.0, extract the .exe, start WMC using the /nochrome option (type C:\Windows\ehome\ehshell.exe /nochrome in a terminal) and use ExpandWnd to resize the window (type expandwnd.exe "Windows Media Center" with the quotes in a terminal)

Let us know how it goes :D

purpleb

Posts: 48
Joined: Mon Jan 28, 2019 6:52 pm
Location:

HTPC Specs: Show details

#5

Post by purpleb » Sun Oct 29, 2023 3:08 pm

thanks for the note. I have been traveling and now back at home.

I will try both items this week and give a status on them.

PurpleB

Kevin Chalet

Posts: 121
Joined: Mon Oct 08, 2018 12:00 pm
Location:

HTPC Specs: Show details

#6

Post by Kevin Chalet » Thu Nov 30, 2023 11:49 am

I just bought an Intel NUC 10 and despite reports from other users here indicating that this generation was not affected, I encountered issues that were very similar to the ones you described in your OP... issues I definitely don't have with my Intel NUC 8 machines.

I didn't want to send my NUC 10 back so I decided to investigate and found a way to disable the fullscreen exclusive mode by patching ehshell.dll. Unlike the other options discussed in this thread, this approach doesn't require resizing the WMC window using an external utility and is a real WMC fullscreen mode, with all the appropriate minimize/close buttons in the top right corner still active.

Disabling the fullscreen exclusive mode is also very helpful on 4K/8K machines where you frequently switch between fullscreen and windowed, as the delay usually seen with the exclusive mode is completely eliminated with the patch applied.

My current patched version has a downside, tho': if you closed WMC when in fullscreen, it will not go fullscreen when re-launching it. I found a way to prevent that by forcing the fullscreen mode permanently (my NUCs always run WMC fullscreen so it's not a big deal for me), but I'm trying to find a better fix.

I'm very curious to know if the same patch would fix the issues you guys see on Intel NUC 11/12 or on machines equipped with a recent Intel iGPU or discrete Intel Xe GPU. If anyone has a sacrificial machine that is affected by these issues, please reach out!

technodevotee

Posts: 959
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#7

Post by technodevotee » Wed Dec 06, 2023 7:20 am

That is very odd. I have a NUC 10 and it works fine in WMC running full screen.

Kevin Chalet

Posts: 121
Joined: Mon Oct 08, 2018 12:00 pm
Location:

HTPC Specs: Show details

#8

Post by Kevin Chalet » Wed Dec 06, 2023 9:00 am

technodevotee wrote: Wed Dec 06, 2023 7:20 am That is very odd. I have a NUC 10 and it works fine in WMC running full screen.
Yeah, it's weird. I tried with both the default iGPU drivers and the latest ones and it was unusable in both cases.

Maybe it's because mine runs on Windows 10 IoT Enterprise 2019... I ordered a different NUC 10 model and plan to install Windows 10 22H2 on it. I'll see if I can reproduce the issue :mrgreen:

Kevin Chalet

Posts: 121
Joined: Mon Oct 08, 2018 12:00 pm
Location:

HTPC Specs: Show details

#9

Post by Kevin Chalet » Tue Dec 12, 2023 9:44 pm

Kevin Chalet wrote: Wed Dec 06, 2023 9:00 am I ordered a different NUC 10 model and plan to install Windows 10 22H2 on it. I'll see if I can reproduce the issue :mrgreen:
The plot thickens: I can't reproduce the issue on the second NUC 10 I received (a NUC10I5FNK, while the first one is a NUC10I3FNH).
I tried with both the default iGPU driver installed via Windows Update (2020) and the latest version (2023) and it worked flawlessly in both cases.

I suspect an OS-related issue, as both the i3 and i5 versions are supposed to use the same iGPU (a HD Graphics 620) :crazy:

technodevotee

Posts: 959
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#10

Post by technodevotee » Mon Dec 18, 2023 10:52 pm

ah.

probably should have mentioned that mine is a Model BXnuc10i7fnk2 with Intel i7 10710 @ 1.9GHz,

Peter167

Posts: 23
Joined: Sat Jul 23, 2016 3:31 pm
Location:

HTPC Specs: Show details

#11

Post by Peter167 » Fri Jan 12, 2024 4:46 pm

This is a crazy situation. My system (Geekom IT11 with the dreaded Itis Graphics) works okay until a play a TV ptog, then the interface becomes very slow. What's going on and why would a graphics card/driver slow the eHome.exe?

Kevin Chalet

Posts: 121
Joined: Mon Oct 08, 2018 12:00 pm
Location:

HTPC Specs: Show details

#12

Post by Kevin Chalet » Fri Jan 12, 2024 5:45 pm

Peter167 wrote: Fri Jan 12, 2024 4:46 pm What's going on and why would a graphics card/driver slow the eHome.exe?
WMC's fullscreen mode is a DirectX 9 "fullscreen exclusive" mode, which is very different from a classical "windowed app" and defers most of the processing directly to the GPU and its driver (e.g all the DWM composition is bypassed). As for what's causing the bug exactly, no one - except maybe Intel - knows. But the new Intel iGPUs/ARC discrete GPUs are sadly notoriously known for having such issues with "old" programs (not just WMC, but tons of old games too).

Peter167

Posts: 23
Joined: Sat Jul 23, 2016 3:31 pm
Location:

HTPC Specs: Show details

#13

Post by Peter167 » Sun Jan 14, 2024 3:23 pm

Kevin thanks for your reply. I've run Spy++ on the main window of WMC and the message flow doesn't change when the fault occurs. What is the patch to eHome.dll? I haven't tried ExpandWnd because the fault still occurs if I drop out of full screen. I wonder if running in a virtual machine will fix the issue, but that is likely to cause additional problems.

Kevin Chalet

Posts: 121
Joined: Mon Oct 08, 2018 12:00 pm
Location:

HTPC Specs: Show details

#14

Post by Kevin Chalet » Sun Jan 14, 2024 8:11 pm

Peter167 wrote: Sun Jan 14, 2024 3:23 pm Kevin thanks for your reply. I've run Spy++ on the main window of WMC and the message flow doesn't change when the fault occurs. What is the patch to eHome.dll? I have tried ExpandWnd because the fault still occurs if I drop out of full screen. I wonder if running in a virtual machine will fix the issue, but that is likely to cause additional problems.
The approach consists in disabling the "fullscreen optimizations" (another name for the fullscreen exclusive mode) immediately after creating the main form, in PageBasedUCPService.OnRendererConnected(). You can easily make it conditional using a registry key, like so:

Code: Select all

this._form = new PageBasedUCPForm(this, this._session, this._fStandardWindowAdornment, flag);
var key = Registry.LocalMachine.OpenSubKey("SOFTWARE\\Microsoft\\Windows\\CurrentVersion\\Media Center\\Settings\\DisplayService");
if (UCPUtility.CheckBoolRegVal(key, "DisableFullscreenOptimizations"))
{
    this._form.OptimizeFullscreenMode = false;
}
If you're not familiar with patching .NET assemblies, I attached a patched ehshell.dll I just created with this unique change: uninstall WMC, unzip the WMC 8.8.5 package and replace the ehshell.dll version it includes by the patched version before launching the installer. Finally, configure the value in the registry to disable the fullscreen optimizations:

Code: Select all

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Media Center\Settings\DisplayService]
"DisableFullscreenOptimizations"=dword:00000001
Let me know how it goes :mrgreen:
Attachments
ehshell.zip
(2.13 MiB) Downloaded 42 times

Peter167

Posts: 23
Joined: Sat Jul 23, 2016 3:31 pm
Location:

HTPC Specs: Show details

#15

Post by Peter167 » Mon Jan 15, 2024 3:56 pm

Kevin

Thanks for the new dll and instructions. However, although I can see that the screen mode has changed because the window controls have moved away from the top, the behaviour is the same. My problem had previously occurred even if I ran in a window rather than maximised. The system doesn't freeze, but the controls are very slow and unusable Is there anything else I can try?

Kevin Chalet

Posts: 121
Joined: Mon Oct 08, 2018 12:00 pm
Location:

HTPC Specs: Show details

#16

Post by Kevin Chalet » Mon Jan 15, 2024 5:10 pm

Sorry to hear it's not working, Peter.
Peter167 wrote: Mon Jan 15, 2024 3:56 pm However, although I can see that the screen mode has changed because the window controls have moved away from the top, the behaviour is the same.
Do you mean the classical Windows minimize/maximize/close buttons or the WMC-specific controls? In both cases, they should behave exactly as before with the patch applied so it's weird. Any chance you can attach a screenshot?
Peter167 wrote: Mon Jan 15, 2024 3:56 pm My problem had previously occurred even if I ran in a window rather than maximised. The system doesn't freeze, but the controls are very slow and unusable Is there anything else I can try?
Sorry, I'm out of ideas. I saw similar symptoms on my Intel NUC 10 with Windows 10 IoT Enterprise 2019 but it only affected fullscreen and the patch was enough to work around it (i.e it worked fine in windowed mode). It's certainly possible the root cause is different... :crazy:

Kevin Chalet

Posts: 121
Joined: Mon Oct 08, 2018 12:00 pm
Location:

HTPC Specs: Show details

#17

Post by Kevin Chalet » Mon Jan 15, 2024 5:22 pm

Peter167 wrote: Mon Jan 15, 2024 3:56 pm Is there anything else I can try?
It won't solve your problem, but to determine whether it's a DirectX-related issue, you can try to run WMC in GDI-mode by entering "C:\Windows\ehome\ehshell.exe /gdi" in a terminal.

Peter167

Posts: 23
Joined: Sat Jul 23, 2016 3:31 pm
Location:

HTPC Specs: Show details

#18

Post by Peter167 » Mon Jan 15, 2024 6:39 pm

Kevin

Both the top right hand buttons and the WMC buttons top left are shifter down. WMC runs with the /gdi option but recorded TV won't play. Is that any help?

Kevin Chalet

Posts: 121
Joined: Mon Oct 08, 2018 12:00 pm
Location:

HTPC Specs: Show details

#19

Post by Kevin Chalet » Mon Jan 15, 2024 7:18 pm

Peter167 wrote: Mon Jan 15, 2024 6:39 pm Both the top right hand buttons and the WMC buttons top left are shifter down.
A screenshot would be nice better than a thousand words :mrgreen:
Peter167 wrote: Mon Jan 15, 2024 6:39 pm WMC runs with the /gdi option but recorded TV won't play. Is that any help?
Yeah, not being able to watch TV (live or recorded) is expected when running in the GDI mode. Sadly, this confirms it's very likely a DirectX issue.
I don't have any solution to offer, except switching to different hardware (e.g an AMD CPU+iGPU).

Peter167

Posts: 23
Joined: Sat Jul 23, 2016 3:31 pm
Location:

HTPC Specs: Show details

#20

Post by Peter167 » Mon Jan 15, 2024 7:48 pm

This the image showing the WMC window with the controls moved down from the top. I couldn't do a screenshot as the controls disappeared when I touched the Alt key.

Image

Hope that works

Looks like it didn't work.

https://ibb.co/SnP1htW

Post Reply