Win 7 Clean Install Creating Echo problem

Talk with fellow members about Ceton's Media Center Extender.
Forum rules
Ceton no longer participate in this forum. Official support may still be handled via the Ceton Ticket system.
Post Reply

Posts: 2
Joined: Wed Dec 10, 2014 11:21 pm

HTPC Specs: Show details

Win 7 Clean Install Creating Echo problem


Post by cwilson01 » Thu Nov 22, 2018 1:34 pm

I just recently purchased an SSD and attempted to clone my existing hard drive, this worked for a while but things started going a bit wonky, check disk running all the time, slow response times, etc. etc. This drove me to do start all over again and do a clean install of windows 7. I've done this several times in the past, no problems. This time I did everything including loading all of the updates (took about 24 hours for everything to load, including SP1) and when I went to add my extenders (I have 3 echo's and one Xbox) all of the echo's connect and then go to the Windows Media Center Logo start screen (with the audio) and then immediately go to a blank screen. I can hit the buttons on the remote and hear audio but I cannot see anything but a blank screen on the TV.

I had a previous problem a few years ago with a window's update that caused all kind of problems and had to uninstall the update to get things to work, but I thought that was corrected by microsoft.

I am stumped, I have removed WMC and reinstalled it via the windows features window, I have removed and reinstalled the echo plug-ins and the ceton infinitv software and I get no joy. I can watch TV through windows media center on my PC but I can't get it to cast to my TVs. Strange, I must be missing something simple here. Anyone out there that can help?

User avatar

Posts: 4
Joined: Fri Sep 08, 2017 10:27 pm

HTPC Specs: Show details


Post by bedrat2 » Tue Jan 08, 2019 8:14 am

Well I have a few question:

What InfiniTV Firmware Version are you running?

What InfiniTV Hardware Version are you running?

What Driver Package Version are you running?

What Firmware Version are you running on your Echo?

Do you have Ceton InfiniTV Network Tuners installed?

Does your XBox 360 work with it Windows Media Center?

Have you tried changing the setting for your Echo on your PC through the Echo plug-in?

You can see if you are running the Beta updates and check to make sure you have the right region and resolution.

Make sure to do them one at a time with the others unplugged from the network and power and I also believe you can reset your Echo from the plug-in.

Post Reply