Running Windows Media Center @ 2160p/4K !!!!!

User avatar
DavidinCT

Posts: 1391
Joined: Mon Feb 13, 2012 3:45 pm
Location:

HTPC Specs: Show details
5+ Yrs TGB Veteran Microsoft MVP

Running Windows Media Center @ 2160p/4K !!!!!

#1

Post by DavidinCT » Wed Jan 07, 2015 4:11 pm

Hey all,

I just got a new TV, finally dumped my 2004 65" RPG 1080i TV that was failing. My wife got me a brand new LG 65" 4k TV and it's awesome(isn't she awesome ?).

I have some 4K videos (downloaded off some websites and the limited content I can find on Torrent sites, mostly demos and music videos) and been running it off a USB drive and OMG wow, I tried to put this content on my MC, and it will only show at 1080p @60hz (due to what MC was set at).

So, over the last week, I have been trying to get Window 7 (32bit) WMC running at 4K. My system is a Intel CORE2QUAD at 2.5ghz, 3gb of ram and the new video card, a GTX750ti superclocked (EVGA). This video card will support 2160p @ 60hz over HDMI 1.4a.

I got MC running at 2160p @ 30hz (due to the limits of my A/V receiver) and as it works, MC performance is sluggish and even 4k videos will break up.

I connected it directly to the TV, set windows to run at 2160p @60hz, and did the same in WMC. And I am blown away, MC is silky smooth, Recorded TV looks better, better color, better detail. 4K videos are perfectly smooth and look as they should. Even 1080p movies running at 4K look better than they did when MCE was running at 1080p.

The only problem I have seen is when you first run MC at 4K, there will be a message that comes up "Media center is running a very high res, please lower" but, this can be addressed by a registry change and goes away.

From MS...
This message is controlled by the following entry in the registry:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Media Center\Display Settings

REG_SZ Value: DisableHighCheck
Data: 1024x768

Change this data to the native res that 4K is running and reboot the computer and that message will go away.

Anyone else doing this and what is your results ? So far I am impressed.....Wish we had native support for 4K (Netflix, etc) but, at least it's something...
-Dave
Twitter @TheCoolDave

Windows Media Center certified and WMC MVP 2010 - 2012

User avatar
apbms1

Posts: 29
Joined: Fri Jul 12, 2013 3:01 pm
Location:

HTPC Specs: Show details

#2

Post by apbms1 » Thu Jan 08, 2015 8:47 pm

How does the 10 foot interface look at that res? Is it scaled to fit. Or is it much smaller like you can see 4 or 5 main mc items at once ( eg.. tv , music, extras, movies)

sskevinm

Posts: 11
Joined: Tue Jan 01, 2013 3:13 pm
Location:

HTPC Specs: Show details

#3

Post by sskevinm » Sun Jan 11, 2015 1:46 pm

Nice job! I was wondering how to disable that message.

Though running Media Center at 3840x2160p did not seem to "improve" much vs running it 1920x1080p.

User avatar
DavidinCT

Posts: 1391
Joined: Mon Feb 13, 2012 3:45 pm
Location:

HTPC Specs: Show details
5+ Yrs TGB Veteran Microsoft MVP

#4

Post by DavidinCT » Wed Jan 14, 2015 2:24 am

sskevinm wrote:Nice job! I was wondering how to disable that message.

Though running Media Center at 3840x2160p did not seem to "improve" much vs running it 1920x1080p.
Maybe it's my TV but, videos and movies seem to have much better color and detail running at 4K over 1080p....I am inpressed. Knowing that we will never get true 4K/2160p support from Microsoft for Media Center, this is nice work-around for now....till someone else actually makes a product that supports DRM on cablecards...
-Dave
Twitter @TheCoolDave

Windows Media Center certified and WMC MVP 2010 - 2012

User avatar
DavidinCT

Posts: 1391
Joined: Mon Feb 13, 2012 3:45 pm
Location:

HTPC Specs: Show details
5+ Yrs TGB Veteran Microsoft MVP

#5

Post by DavidinCT » Wed Jan 14, 2015 4:08 am

apbms1 wrote:How does the 10 foot interface look at that res? Is it scaled to fit. Or is it much smaller like you can see 4 or 5 main mc items at once ( eg.. tv , music, extras, movies)
Yes, it's scaled to fit, looks fine, looks just like MC but, with a more detail on the display. The MC interface looks just like it did at 1080p, so it did not shrink anything down, it looks fine...
-Dave
Twitter @TheCoolDave

Windows Media Center certified and WMC MVP 2010 - 2012

User avatar
Jimmersd

Posts: 130
Joined: Sun Jun 30, 2013 10:15 pm
Location:

HTPC Specs: Show details

#6

Post by Jimmersd » Thu Jan 15, 2015 10:43 pm

Something interesting here and the only reason I discovered it was because of this thread.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Media Center\Display Settings
REG_SZ Value: DisableBtDepthCheck
Data: 32

Since it is next to impossible to find a complete list of keys and adjustments with descriptions available for the Window/WMC registry, sometimes the only way to discover new things is to experiment. I saw this key and was curious what would happen if increased the value to 64. I saw an immediate change in the way that my Echo changed channels and the clarity of the picture. Channels changed faster, usually no pixallation but not eliminated. And better over all response to fast moving scenes.

I'm fairly certain that someone is going to say that all this setting does is to change the point where Windows will complain about the bit depth but I have found that increasing this to 64 and beyond has had a marked improvement on the performance of both of my extenders.

Discuss....

User avatar
Jimmersd

Posts: 130
Joined: Sun Jun 30, 2013 10:15 pm
Location:

HTPC Specs: Show details

#7

Post by Jimmersd » Fri Jan 16, 2015 2:54 am

Really? I thought that this point might be interesting to others who might not read this thread. But you deleted it anyway? Really?

cwinfield

Posts: 558
Joined: Tue Feb 12, 2013 1:14 am
Location: Monroe, NC

HTPC Specs: Show details

#8

Post by cwinfield » Fri Jan 16, 2015 3:03 am

That is interesting and I will probably try it, however I wonder what that data: # is and what it is actually doing.

User avatar
Jimmersd

Posts: 130
Joined: Sun Jun 30, 2013 10:15 pm
Location:

HTPC Specs: Show details

#9

Post by Jimmersd » Fri Jan 16, 2015 4:09 am

cwinfield wrote:That is interesting and I will probably try it, however I wonder what that data: # is and what it is actually doing.
:D :lol: :lol: :lol: :lol: :lol: :lol:

No I tried to open a new conversation on this topic. But the PTB decided that I was being redundant. The last post was out of context.

User avatar
DavidinCT

Posts: 1391
Joined: Mon Feb 13, 2012 3:45 pm
Location:

HTPC Specs: Show details
5+ Yrs TGB Veteran Microsoft MVP

#10

Post by DavidinCT » Fri Jan 16, 2015 1:56 pm

Jimmersd wrote:Something interesting here and the only reason I discovered it was because of this thread.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Media Center\Display Settings
REG_SZ Value: DisableBtDepthCheck
Data: 32

Since it is next to impossible to find a complete list of keys and adjustments with descriptions available for the Window/WMC registry, sometimes the only way to discover new things is to experiment. I saw this key and was curious what would happen if increased the value to 64. I saw an immediate change in the way that my Echo changed channels and the clarity of the picture. Channels changed faster, usually no pixallation but not eliminated. And better over all response to fast moving scenes.

I'm fairly certain that someone is going to say that all this setting does is to change the point where Windows will complain about the bit depth but I have found that increasing this to 64 and beyond has had a marked improvement on the performance of both of my extenders.

Discuss....
You said it helped on your Echo (Extender) but, how did it do on the desktop that your running MC on ? I'm going to say that 90% of the watching is done on the HTPC and the other 10% is extenders....

Interested in trying, maybe I'll make that change tonight and reboot it before watching anything.... could be a nice thing to add while running MCE at 2160p @60hz

By the way, the registry change I did on the first post, did not remove the message "too high" after a 2nd reboot the message came back but, the registry key is still set...

any idea ?
-Dave
Twitter @TheCoolDave

Windows Media Center certified and WMC MVP 2010 - 2012

User avatar
Jimmersd

Posts: 130
Joined: Sun Jun 30, 2013 10:15 pm
Location:

HTPC Specs: Show details

#11

Post by Jimmersd » Fri Jan 16, 2015 4:06 pm

Jimmersd wrote:You said it helped on your Echo (Extender) but, how did it do on the desktop that your running MC on ? I'm going to say that 90% of the watching is done on the HTPC and the other 10% is extenders....
Sorry to say that 100% of my watching is done on the extender. Wish I could help there.

sskevinm

Posts: 11
Joined: Tue Jan 01, 2013 3:13 pm
Location:

HTPC Specs: Show details

#12

Post by sskevinm » Fri Jan 16, 2015 4:20 pm

Sorry, I did not get a chance to post my results earlier on trying to modify the following entry in the registry.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Media Center\Display Settings

REG_SZ Value: DisableHighCheck
Data: 1024x768

I noticed that when I attempted to modify "Data:" to 3840x2160, upon a reboot or starting Windows Media Center, this value would be changed back to the main display resolution. Once I changed the main display resolution to 3480x2160@60Hz and rebooted the PC, the "Data:" value was changed to 3840x2160. I had to change the DPI(Use Windows XP style DPI scaling) to 200% in order to see the desktop icons and text. Then I changed the TV resolution in WMC to match the main screen resolution. With these settings, WMC was scaled to my likings and looked very much the same as it did at 1080p. Plus I did not receive the "too high" message anymore. The one problem I did run into is, when I used the WMC built-in Netflix app, the screen would turn black after watching a source for 10-30 minutes. I would have to press the stop button, which it returned to the Netflix app with no problems, and restart the movie. This cycle repeated every time and this was annoying. I did not have this problem with any other WMC options(Live TV, DVDs, Blu-Rays, Music, Pictures, etc...). The only fix for Netflix was to go back to 1080p and this made no sense to me.

I do have to say running WMC at 3840x2160 seemed to improve the sharpness of the image by about 10% or so. I have a Sony xbr55x850a that has been calibrated to Rec.709 standards. I realize Rec.709 is for HD and not UHD, so it might make a difference to calibrate to Rec. 2020 if my TV supports this.

bob_p

Posts: 268
Joined: Fri Jul 08, 2011 4:47 pm
Location:

HTPC Specs: Show details

#13

Post by bob_p » Fri Jan 16, 2015 6:03 pm

Last month, I hooked up a new 4K AVR and received the warning - and immediately changed the resolution of WMC back to 1080p - because I assumed that the UHDTV would do a better job of scaling from 1080p to 4K.

HOWEVER, cable TV programs are NOT broadcast in 1080p. They are broadcast in 720p or 1080i. So WMC is already scaling those images to 1080p - and then the TV is scaling them to 2160p - two conversions.

After following this thread, now I'm wondering if it might be better to have the PC upscale to 2160p - so that only one scaling pass is being done.

Though the TV appears to have considerably more control over the video processing than the NVidia software on the PC.

While the AVR could also do video processing, that would seem to be the worst place to do the scaling - with even less control than on the PC or the TV.

For others with 4K TVs - how many people have tried both 1080p and 2160p to the TV? And which resolution looks best for you?

User avatar
DavidinCT

Posts: 1391
Joined: Mon Feb 13, 2012 3:45 pm
Location:

HTPC Specs: Show details
5+ Yrs TGB Veteran Microsoft MVP

#14

Post by DavidinCT » Fri Jan 16, 2015 8:53 pm

bob_p wrote:Last month, I hooked up a new 4K AVR and received the warning - and immediately changed the resolution of WMC back to 1080p - because I assumed that the UHDTV would do a better job of scaling from 1080p to 4K.

HOWEVER, cable TV programs are NOT broadcast in 1080p. They are broadcast in 720p or 1080i. So WMC is already scaling those images to 1080p - and then the TV is scaling them to 2160p - two conversions.

After following this thread, now I'm wondering if it might be better to have the PC upscale to 2160p - so that only one scaling pass is being done.

Though the TV appears to have considerably more control over the video processing than the NVidia software on the PC.

While the AVR could also do video processing, that would seem to be the worst place to do the scaling - with even less control than on the PC or the TV.

For others with 4K TVs - how many people have tried both 1080p and 2160p to the TV? And which resolution looks best for you?
Your 4K AVR changed it back, because there was a different EDID (telling what the device supports, all HDMI devices have this).

I still feel 2160p @ 60hz blows away 1080p @60hz,....
-Dave
Twitter @TheCoolDave

Windows Media Center certified and WMC MVP 2010 - 2012

bob_p

Posts: 268
Joined: Fri Jul 08, 2011 4:47 pm
Location:

HTPC Specs: Show details

#15

Post by bob_p » Fri Jan 15, 2016 1:30 pm

Unless you have other applications running in 4K on your PC, you are probably better off reducing the resolution of your PC to 1080p and letting another device (UHDTV?) do the upscaling.

By default, Windows will try to set display resolution to the native resolution of the monitor, when first connected. I had the same issue with my UHDTV when I first connected it to WMC - and after experimenting briefly with running 4K from the PC to the TV, concluded there wasn't any benefit for doing that. Our Samsung UHDTV does a great job with the upscaling - and we don't have to worry about running 4K from the PC through the AVR to the TV.

If/when we start getting 4K programs from Comcast, then we'll have to change this - but by then, we may not be using WMC anyway...

User avatar
DavidinCT

Posts: 1391
Joined: Mon Feb 13, 2012 3:45 pm
Location:

HTPC Specs: Show details
5+ Yrs TGB Veteran Microsoft MVP

#16

Post by DavidinCT » Sun Jan 17, 2016 6:39 pm

Yea, it does not work, If you change it, next time WMC starts, it resets the key....

I have a batch script that runs with a reg file to change it before WMC starts... so for the first time it does not appear but, If I re-connect (AVR switch), it resyncs HDMI and appears...

Wish there was a way to disable this for good...
-Dave
Twitter @TheCoolDave

Windows Media Center certified and WMC MVP 2010 - 2012

User avatar
DavidinCT

Posts: 1391
Joined: Mon Feb 13, 2012 3:45 pm
Location:

HTPC Specs: Show details
5+ Yrs TGB Veteran Microsoft MVP

#17

Post by DavidinCT » Mon Jan 18, 2016 12:54 am

I think I fixed this error !!! I will post what I did after I try it for a day or 2....
-Dave
Twitter @TheCoolDave

Windows Media Center certified and WMC MVP 2010 - 2012

User avatar
DavidinCT

Posts: 1391
Joined: Mon Feb 13, 2012 3:45 pm
Location:

HTPC Specs: Show details
5+ Yrs TGB Veteran Microsoft MVP

#18

Post by DavidinCT » Mon Jan 18, 2016 9:08 pm

Hey all,

I fixed this issue once and for all. I have disabled this message so rebooting or re-opening Windows Media Center will No longer show this message !!!! FINALLY !!!! After a day or testing on 8.1 and rebooting to Windows 7 (I dual booth on my HTPC), I applied this fix and it removed it, so it works on 7 and 8.1....

So, so background on this issue and the problem. When WMC starts it checks this key to make sure WMC is running in the recommend resolution, if this key is modified, it will change it back to the default. I have proven if you add this key with 3840x2160 before WMC starts, this message will not show but, the next time you run it, it will. So what I attempted was to no longer allow Windows Media Center to CHANGE THIS KEY. By giving "system" ONLY permission to "read" this key and no longer change, the key never goes back to the default and this message will NEVER appear again. :)

In the registry...

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Media Center\Display Settings

Change "DisableHighCheck" to "3840x2160"

After that, Right click on "Display Settings" go to permissions. What you need to do is make the user you log in as the "owner" (it used to be "system"), Make sure your logon account has "full control" put "System" to "read only" and Administrators "read only".

So, at this point
<user logon account> Full control
System - Read ONLY
Administrators - Read only

This does work, tested on 8.1 and 7...
-Dave
Twitter @TheCoolDave

Windows Media Center certified and WMC MVP 2010 - 2012

Xiola69

Posts: 2
Joined: Mon Jan 25, 2016 3:08 pm
Location:

HTPC Specs: Show details

#19

Post by Xiola69 » Mon Jan 25, 2016 4:45 pm

Great Thread!

I would like to see a 4K section on the Green Button

Anyway, I have some of my own feedback and questions on my 4k experience.

I bought an RCA Model# PRK65A65RQ 65" 4K TV. My media Center was based on an older Q6600 with 8GB and HD7700.

I was able to configure this card for 2160op @ 30 Hz and found although the picture was very clear, however noticeably choppy even with the WMC menus. Moreover when running some 4K videos, the processor would be maxed, and the video was also choppy. The processors never had an issue with 1080p so this was a bit of a surprise that i needed so much more processor power.

I ended up replacing the motherboard with a i7 2600K and found the processor usage was much better, but still a little choppy with the menu's.

After some research i discovered most of affordable cards don't have HDMI 2.0, and can only output 2160p@60Hhz out of the display port, and HDMI 1.2/3 was limited to 30Hz.

We'll Displayport to HDMI 2.0 cables simply don't exist, so then discovered I needed to also upgrade the video card with something that can do HDMI 2.0.

So I purchased a GTX 970 for $250, and wow, what a difference. Came up as 2160P@60Hz, and the Media center menus and 4K playback are super smooth.

Some of the problems I have found
- Sometimes sound does not work via the HDMI, and have to turn the TV off and back (HDMI goes into the TV, and output from the TV via Coaxial digital the the receiver.
- Sometimes there is a color ghosting, and slightly distorts everything. Issue can be see easiest when looking at text in File Explorer, and to power off TV and back on to fix.

Small but annoying issue I get with Live TV using 2X HDHomerun Prime adapters with Cable cards
- For some reason when I watch TV the channel number does not display to the left near the station ID when changing channels, tried different dpi settings with no success. 1080p displays fine.

Other things i have noticed with 4K
- I have seen with my (an other 4K TV's) that 1080P inputs appear much darker and does not look nearly as good as native 1080p screens. For instance my TV has a ROKU adapter, and also with my bluray player does not look nearly as good.
I think the up-convert is poor, and found in my history of computer experiencing is that LCD's always look best at their native resolution. For this reason, I don't recommend 4K to most people. My ultimate goal is to get a 4K video camera.

cwinfield

Posts: 558
Joined: Tue Feb 12, 2013 1:14 am
Location: Monroe, NC

HTPC Specs: Show details

#20

Post by cwinfield » Mon Jan 25, 2016 5:01 pm

Displayport to HDMI 2 adapters are available now http://www.anandtech.com/show/9867/club ... 20-adapter This will not solve needing HDCP 2.2 and bottom line is you don't want a 4K TV without 4K@60hz HDMI 2 or HDCP 2.2

Post Reply