WMC reverting back

An evolving, supported alternative to Rovi
Forum rules
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf
Post Reply
KarterJK

Posts: 64
Joined: Sun May 18, 2014 7:20 pm
Location:

HTPC Specs: Show details

WMC reverting back

#1

Post by KarterJK » Mon Jan 11, 2021 1:32 am

okay I have complained about 'time to update data guide' message before
but
now I know what is triggering it.

My guide provider is somehow being reset from EPG123 to Microsoft default...in each instance I was using ver. 1.6
How is that possible? I did use taskbar update icon button.

I am baffled

User avatar
garyan2

Posts: 5945
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#2

Post by garyan2 » Mon Jan 11, 2021 1:41 am

Could you send me your log file (c:\programdata\garyan2\epg123\trace.log) to support@garyan2.net. If WMC is reverting back to MS as a guide source, then you would have to perform setup again every time. If running the epg123 update fixes things, then there is something with your scheduled task that is not working.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

User avatar
Gripweed

Posts: 109
Joined: Sun Feb 03, 2013 6:35 pm
Location: Scranton,PA_USA

HTPC Specs: Show details

#3

Post by Gripweed » Mon Jan 11, 2021 5:54 am

KarterJK wrote:
Mon Jan 11, 2021 1:32 am
I am baffled
Are you using any type of Windows cleaner programs? Such as CCleaner or BleachBit? If so, make sure they aren't doing any cleaning of WMC files or registry settings. I had an unrelated program acting up on me about once a week. I finally realized that BleachBit was cleaning out a vital file for the program when I ran the cleaner about once a week. I turned off the cleaning of the program and all was well thereafter.

KarterJK

Posts: 64
Joined: Sun May 18, 2014 7:20 pm
Location:

HTPC Specs: Show details

#4

Post by KarterJK » Mon Jan 11, 2021 1:19 pm

garyan2 wrote:
Mon Jan 11, 2021 1:41 am
Could you send me your log file (c:\programdata\garyan2\epg123\trace.log) to support@garyan2.net. If WMC is reverting back to MS as a guide source, then you would have to perform setup again every time. If running the epg123 update fixes things, then there is something with your scheduled task that is not working.
will do
update: they're sent
Last edited by KarterJK on Mon Jan 11, 2021 1:36 pm, edited 1 time in total.

KarterJK

Posts: 64
Joined: Sun May 18, 2014 7:20 pm
Location:

HTPC Specs: Show details

#5

Post by KarterJK » Mon Jan 11, 2021 1:30 pm

Gripweed wrote:
Mon Jan 11, 2021 5:54 am
KarterJK wrote:
Mon Jan 11, 2021 1:32 am
I am baffled
Are you using any type of Windows cleaner programs? Such as CCleaner or BleachBit? If so, make sure they aren't doing any cleaning of WMC files or registry settings. I had an unrelated program acting up on me about once a week. I finally realized that BleachBit was cleaning out a vital file for the program when I ran the cleaner about once a week. I turned off the cleaning of the program and all was well thereafter.
I do use CCleaner, just ran a test. No changes.

User avatar
garyan2

Posts: 5945
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#6

Post by garyan2 » Mon Jan 11, 2021 3:13 pm

Well, everything in your log file looks pretty good. Your task is running everyday, you have automatch enabled, no funny stuff and you've only had a couple warnings due to discontinuities which doesn't affect anything.

I did notice that yesterday you had a garbage cleanup run. If you had a WMC database crash/recovery, when you open WMC it will prompt that a recovery has occurred and you should check your scheduled recordings and when you click the guide it will tell you there is less than 3 days of guide available. Does this sound like what is happening?

Could you open file explorer and navigate to c:\programdata\microsoft\ehome and take a picture of that? I want to see when the recoveries are happening and if there is some correlation to anything.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

KarterJK

Posts: 64
Joined: Sun May 18, 2014 7:20 pm
Location:

HTPC Specs: Show details

#7

Post by KarterJK » Tue Jan 12, 2021 9:35 am

I can't remember exactly which machine it was. Happened on two of them, we have 12 machines running. I reverted back to v1.5 on those, everything else is v1.6.

Let me wait until it happens again. I will collect all the relative files, now that I know what to look for.

Post Reply