All of my guide listings disappeared suddenly

An evolving, supported alternative to Rovi
Forum rules
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf
Post Reply
billmich

Posts: 64
Joined: Fri Oct 02, 2015 2:52 pm
Location:

HTPC Specs: Show details

All of my guide listings disappeared suddenly

#1

Post by billmich » Sat Dec 19, 2020 5:53 pm

I am currently recording football games through manual recordings… But the guide recording I had later for tonight disappeared and I had to reset it manually.

I know I have to wait until tomorrow because I don’t want to fiddle with anything and ruin my recordings. But what went on that would cause all of my guide data to disappear without warning?

I also notice if I access the guide function in the my media center app the whole app crashes… So there’s a lot going on here now

User avatar
garyan2

Posts: 5832
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#2

Post by garyan2 » Sat Dec 19, 2020 6:16 pm

I haven't tested it out, but if the program(s) that your manual recording covers is changed during the import/verification it may cause it to disappear. Did the broadcaster change the event (i.e. different game or change from a generic/unknown game to a specific matchup)?

For MMC, try clearing the cache in MMC and see if that works. I've only had to do this to get MMC to refresh station logos, but it may help for this as well.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

billmich

Posts: 64
Joined: Fri Oct 02, 2015 2:52 pm
Location:

HTPC Specs: Show details

#3

Post by billmich » Sat Dec 19, 2020 6:46 pm

My two manual recordings were fine and dandy but the SEC championship game but I did off of the guide went away when all the guide data disappeared. My question is why did the guide data disappear within the last 12 hours?

User avatar
garyan2

Posts: 5832
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#4

Post by garyan2 » Sat Dec 19, 2020 7:00 pm

Oh, maybe your WMC database crashed and it did a recovery. When it does a recovery you will not have any guide data and I believe the program recording requests (manual/specific episode) don't get restored. You can do a manual import of the guide data or run the update task again to restore your guide listings.

Could you send me your trace.log file (c:\programdata\garyan2\epg123\trace.log) to support@garyan2.net and I will take a look if it crashed during a garbage collection or import.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

billmich

Posts: 64
Joined: Fri Oct 02, 2015 2:52 pm
Location:

HTPC Specs: Show details

#5

Post by billmich » Sat Dec 19, 2020 7:29 pm

I don’t wanna mess around with anything right now because I am doing recordings… It is something I will attend to tomorrow. And I will send you whatever log files you need. So what you’re saying is that something went wrong and because of the way EPG 123 Talks to Media Center, it will not automatically be restored it will stay this way until I manually fix it?

User avatar
garyan2

Posts: 5832
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#6

Post by garyan2 » Sat Dec 19, 2020 7:44 pm

That depends on what you are looking at right now. Does WMC have all your channels, just no guide listings? If so, you will get your guide listings back once you perform a manual import/update or your scheduled task runs again.

The database recovery is performed by WMC whenever it decides to. EPG123 has no way of knowing when that happens. In the old days, when WMC performed a recovery it would automatically request a guide update from MS servers. Since that can't happen anymore and WMC isn't aware of EPG123, the guide will be empty until the MXF is imported again.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

billmich

Posts: 64
Joined: Fri Oct 02, 2015 2:52 pm
Location:

HTPC Specs: Show details

#7

Post by billmich » Sat Dec 19, 2020 7:48 pm

Right now everything is empty… Channel 202 which is ESPN it’s just blank and then it says no data available… I can still tune into the channel but I can’t see any guide stinks

User avatar
garyan2

Posts: 5832
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#8

Post by garyan2 » Sat Dec 19, 2020 7:56 pm

If you are recording something right now, then I would hold off on importing the MXF file. If you are just watching live TV, then you can go ahead and do a manual import from the client to repopulate the guide if you want. You can opt to do nothing and your guide will be populated on your next scheduled update.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

billmich

Posts: 64
Joined: Fri Oct 02, 2015 2:52 pm
Location:

HTPC Specs: Show details

#9

Post by billmich » Sat Dec 19, 2020 8:05 pm

Yeah I do a lot of recording of college football games and they started at noon and run basically until midnight… Are you saying though that this should magically fix itself at the next update which should be tomorrow morning at one in the morning?

User avatar
garyan2

Posts: 5832
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#10

Post by garyan2 » Sat Dec 19, 2020 8:13 pm

As long as your scheduled update run is successful and imports the mxf file, yes. It will magically fix itself.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

billmich

Posts: 64
Joined: Fri Oct 02, 2015 2:52 pm
Location:

HTPC Specs: Show details

#11

Post by billmich » Sat Dec 19, 2020 8:20 pm

Thank you very much for this conversation… I appreciate it and will be reading it at more detail at a later time on a screen larger than my phone. I have never had this happen before but I’ve only had the EPG123 since January so I don’t know how often this happens

Or anything I can ever do about it

billmich

Posts: 64
Joined: Fri Oct 02, 2015 2:52 pm
Location:

HTPC Specs: Show details

#12

Post by billmich » Sun Dec 20, 2020 8:58 pm

garyan2 wrote:
Sat Dec 19, 2020 8:13 pm
As long as your scheduled update run is successful and imports the mxf file, yes. It will magically fix itself.
Nothing changed from yesterday - I guess I have to re-import everything.
I was hoping that this would have 'fixed itself'

how often does this happen?

User avatar
garyan2

Posts: 5832
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#13

Post by garyan2 » Sun Dec 20, 2020 9:18 pm

Not understanding what "this" is, I couldn't say. I need more information, like from your trace.log file. Also understanding if your scheduled task is setup and how it is setup.

If you open the configuration GUI (EPG123 shortcut) and click [Save & Execute], do you get guide listings once it's complete?
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

billmich

Posts: 64
Joined: Fri Oct 02, 2015 2:52 pm
Location:

HTPC Specs: Show details

#14

Post by billmich » Sun Dec 20, 2020 9:23 pm

All fixed

I had to clear the cache on the app

User avatar
garyan2

Posts: 5832
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#15

Post by garyan2 » Sun Dec 20, 2020 9:31 pm

Could you send me your trace.log file (c:\programdata\garyan2\epg123\trace.log) to support@garyan2.net? Clearing the cache works for when there is some bad data in the file, but would only be a coincidence for your original issue.

Doing a successful [Save & Execute] shows that your configuration is fine and your database is (now) fine. It does not ensure your scheduled task is setup correctly which it sounds like it wasn't successful this morning.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

mhoward21

Posts: 1
Joined: Mon Dec 21, 2020 12:53 am
Location:

HTPC Specs: Show details

#16

Post by mhoward21 » Mon Dec 21, 2020 1:03 am

I have been using configuration GUI to clear the cache because the app does not seem to be doing it automatically. (It used to and something changed.) I go in and clear the cache then run "Save & Execute" to have my program guide update. Is there something I did to cause the updating process to stop running?

Space

Posts: 2219
Joined: Sun Jun 02, 2013 9:44 pm
Location:

HTPC Specs: Show details

#17

Post by Space » Mon Dec 21, 2020 1:22 am

Did you send Gary your log? You won't get answers to your questions until you send the log.

billmich

Posts: 64
Joined: Fri Oct 02, 2015 2:52 pm
Location:

HTPC Specs: Show details

#18

Post by billmich » Mon Dec 21, 2020 1:32 am

I'll see if I can get to it tomorrow for you

Post Reply