EPG123 Bug Reports

An evolving, supported alternative to Rovi
Forum rules
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf
sbecker25

Posts: 5
Joined: Sat Feb 22, 2020 8:18 pm
Location:

HTPC Specs: Show details

Re: EPG123 Bug Reports

#1281

Post by sbecker25 » Sat Feb 29, 2020 3:20 am

Im missing them in information screen for every channel or program. I already contacted schedules direct , no error on their end.
Attachments
20200228_124021.jpg

User avatar
garyan2

Posts: 5511
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#1282

Post by garyan2 » Sat Feb 29, 2020 4:25 am

Disable your MMUI+ Theme and see if you can see the information using the standard WMC pages.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

Kick4U

Posts: 43
Joined: Mon Mar 05, 2012 7:36 am
Location:

HTPC Specs: Show details

#1283

Post by Kick4U » Mon Mar 02, 2020 3:00 am

I was trying to enable and disable multiple channels within EPG123 via 'spacebar' and the program crashed; I'm guessing that it is a memory leak issue since I have so many channels loaded. Can't determine what is causing the app to shutdown.

Not much in the log file but here's the the trace.log file.

Code: Select all

[3/1/2020 9:47:17 PM] ===============================================================================
[3/1/2020 9:47:17 PM]  Activating the epg123 client GUI. version 1.3.5.30
[3/1/2020 9:47:17 PM] ===============================================================================
[3/1/2020 9:47:17 PM] [ INFO] Successfully queried the Task Scheduler for status. No task is scheduled to run.
[3/1/2020 9:48:34 PM] [ERROR] Unhandled thread exception caught from epg123Client.exe. message: Unable to commit the StoredObject of id 1C0000003690D2 back to the ObjectStore. Initial revision = 0, previous revision = 0, current revision = 18

sbecker25

Posts: 5
Joined: Sat Feb 22, 2020 8:18 pm
Location:

HTPC Specs: Show details

#1284

Post by sbecker25 » Tue Mar 03, 2020 6:08 pm

[quote=garyan2 post_id=138621 time=1582950317 user_id=8445]
Disable your MMUI+ Theme and see if you can see the information using the standard WMC pages.
[/quote]
Hi, Gary , we disabled modern media and also rebuild the WMC database. Its now showing descriptions in synopsis. My question is there any way to determine what caused the issue
Thank You[*]

User avatar
garyan2

Posts: 5511
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#1285

Post by garyan2 » Wed Mar 04, 2020 1:23 am

Did you reenable MMUI+ and verify the information is still there? If so, I have no idea why it would have "disappeared" in the first place. The data was there... WMC just wasn't showing it.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

sbecker25

Posts: 5
Joined: Sat Feb 22, 2020 8:18 pm
Location:

HTPC Specs: Show details

#1286

Post by sbecker25 » Wed Mar 04, 2020 3:19 am

I haven't tried to re enable yet. But will leave it off for now. When i have a chance i will try to re-install
Thank you

dahef

Posts: 73
Joined: Mon Mar 14, 2016 7:11 pm
Location:

HTPC Specs: Show details

#1287

Post by dahef » Sat Mar 07, 2020 9:04 pm

I just did an upgrade to 1.3.5. After a save and execute I get the following warning

Program EP005455793239 is missing required content.
Did not cache program EP005455793239 due to missing Md5 hash.

I get the same warning for EP005455793238.
Does this warning look familiar? I don't really see a correlation for this number in the list of StationID's.

Space

Posts: 2095
Joined: Sun Jun 02, 2013 9:44 pm
Location:

HTPC Specs: Show details

#1288

Post by Space » Sun Mar 08, 2020 12:39 am

Seems to be an issue with certain programs coming from the Schedules Direct data.

viewtopic.php?p=138806#p138765

dahef

Posts: 73
Joined: Mon Mar 14, 2016 7:11 pm
Location:

HTPC Specs: Show details

#1289

Post by dahef » Wed Mar 11, 2020 8:04 pm

In the recorded movie library all the movie poster art disappeared overnight March 6. The art was there but suddenly was gone. Movies recorded beginning March 7 are showing the poster art. The movie guide for scheduled programming shows all the poster art.

Does anyone know -
A- why the art in the recorded movie library would suddenly go away and
B- if there anyway to recover this lost poster art.

Space

Posts: 2095
Joined: Sun Jun 02, 2013 9:44 pm
Location:

HTPC Specs: Show details

#1290

Post by Space » Thu Mar 12, 2020 2:52 am

I'm not sure, but I do know that the extended data server that Microsoft used to maintain went away recently (although it was before March 6th). This server did serve up alternate poster art for movies, however the guide also had/has it's own movie art (which often differed from the art the extended data server provided).

I thought that clearing out the DB is what caused the art to go away (when I moved from the Rovi data provider to EPG123 with Schedules Direct), but if you did not do that on March 6th, then I'm not sure what cleared out all the poster art for you. But once the art is gone, there is no more extended data server to get the art again, so no more art...

Note that I still have art for the few ripped DVDs I had made, so that might use a different server to get the art or was not cleared out when I started a new DB for some reason, not sure.

EDIT: I just thought of one thing that might have removed your movie art, and that is a database rebuild. If WMC determines that there is corruption in your DB, it will rebuild it. In this case I would think you would probably loose stuff like movie art which is not stored in the WTV files themselves.

robocallwall

Posts: 2
Joined: Tue Mar 24, 2020 10:42 pm
Location:

HTPC Specs: Show details

#1291

Post by robocallwall » Tue Mar 24, 2020 10:48 pm

Crashing on schedule update:
[3/24/2020 6:17:37 PM] ===============================================================================
[3/24/2020 6:17:37 PM] Beginning epg123 update execution. version 1.3.6.20
[3/24/2020 6:17:37 PM] ===============================================================================
[3/24/2020 6:17:38 PM] [ INFO] Beginning EPG123 update execution. 2020-03-24 22:17:38Z
[3/24/2020 6:17:38 PM] [ INFO] DaysToDownload: 14 , TheTVDBNumbers : True , PrefixEpisodeTitle: False , PrefixEpisodeDescription : False , AppendEpisodeDesc: False , OADOverride : True , TMDbCoverArt: True , IncludeSDLogos : True , AutoAddNew: True , CreateXmltv: True , ModernMediaUiPlusSupport: True
[3/24/2020 6:17:40 PM] [ INFO] Token request successful. serverID: 20141201.web.1
[3/24/2020 6:17:40 PM] [ INFO] Status request successful. account expires: 2021-01-05T19:20:47Z , lineups: 1/4 , lastDataUpdate: 2020-03-24T15:08:17Z
[3/24/2020 6:17:40 PM] [ INFO] system status: Online , message: No known issues.
[3/24/2020 6:17:41 PM] [ INFO] Successfully retrieved TMDb configurations.
[3/24/2020 6:17:41 PM] [ INFO] Successfully requested listing of client lineups from Schedules Direct.
[3/24/2020 6:17:41 PM] Entering buildLineupServices() for 1 lineups.
[3/24/2020 6:17:42 PM] [ INFO] Successfully retrieved the station mapping for lineup USA-FL09401-X.
[3/24/2020 6:17:47 PM] Exiting buildLineupServices(). SUCCESS.
[3/24/2020 6:17:47 PM] Entering getAllScheduleEntryMd5s() for 14 days on 303 stations.
[3/24/2020 6:17:57 PM] [ INFO] Successfully retrieved Md5s for 303 station's daily schedules. (0:00:00:10.1244178 / 451.705 KB)
[3/24/2020 6:21:17 PM] [ INFO] Successfully retrieved 118 station's daily schedules. (0:00:00:02.6048307 / 1.992 MB)
[3/24/2020 6:21:19 PM] [ INFO] Found 3904 cached daily schedules.
[3/24/2020 6:21:19 PM] [ INFO] Downloaded 338 daily schedules.
[3/24/2020 6:21:25 PM] [ INFO] Processed 4242 daily schedules for 303 stations.
[3/24/2020 6:21:25 PM] Exiting getAllScheduleEntryMd5s(). SUCCESS.
[3/24/2020 6:21:25 PM] Entering buildAllProgramEntries() for 32246 programs.
[3/24/2020 6:32:44 PM] [ERROR] Unhandled exception caught from epg123.exe. message: Unexpected character encountered while parsing value: �. Path '', line 0, position 0.
[3/24/2020 6:33:42 PM] ===============================================================================
[3/24/2020 6:33:42 PM] Beginning epg123 client execution. version 1.3.6.20
[3/24/2020 6:33:42 PM] ===============================================================================
[3/24/2020 6:33:42 PM] [ INFO] Beginning epg123 client execution. 2020-03-24 22:33:42Z
[3/24/2020 6:33:42 PM] [ INFO] Import: True , Match: True , NoLogo: False , Force: False , ShowProgress: False
[3/24/2020 6:33:44 PM] Entering importMxfFile() for file "c:\programdata\garyan2\epg123\output\epg123.mxf"

User avatar
garyan2

Posts: 5511
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#1292

Post by garyan2 » Tue Mar 24, 2020 11:00 pm

Was this your first run after upgrading to a v1.3.6.x version? It looks like it is failing while reading a cached program json entry into memory, and failing at line 0, position 0 would mean it was a zero length file.

Basically, if this is your first run of a v1.3.6.x version, I would recommend looking at your cache folder, sort by file size, and see if there are any zero length files and delete them. Then try again.

If that doesn't work, or it wasn't your first run, then I would recommend opening the configuration GUI, click the [Clear Cache] button and then the [Save & Execute] button.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

robocallwall

Posts: 2
Joined: Tue Mar 24, 2020 10:42 pm
Location:

HTPC Specs: Show details

#1293

Post by robocallwall » Wed Mar 25, 2020 2:40 am

Thank you!

I was running a slightly older version when the issue started, upgraded to the latest to see if that fixed it, and it did not.

No files in cache were 0 bytes, but there were over 10,000 files in there. Clear cache took a minute.

Clear cache and then Save and Execute did resolve the issue, Thanks again!

wilme2

Posts: 20
Joined: Mon Jul 08, 2013 6:33 pm
Location:

HTPC Specs: Show details

#1294

Post by wilme2 » Mon Apr 06, 2020 3:59 pm

My WMC had the red EPG the past few days, and this morning I got the warning that there was less than three days of guide data. I got into the EPG log and found the error below. I updated to 1.3.6 and then did a Save & Execute and the problem has gone away, but I wanted to post in case others run into this same problem.

Code: Select all

4/6/2020 4:04:19 AM] [ INFO] Processed 4888 movie poster links.
[4/6/2020 4:04:19 AM] Exiting getAllMoviePosters(). SUCCESS.
[4/6/2020 4:04:19 AM] Entering getAllSeriesImages() for 9983 series.
[4/6/2020 4:04:28 AM] [ERROR] Unhandled exception caught from epg123.exe. message: Input string was not in a correct format.
[4/6/2020 4:04:30 AM] ===============================================================================
[4/6/2020 4:04:30 AM]  Beginning epg123 client execution. version 1.3.2.30
[4/6/2020 4:04:30 AM] ===============================================================================
[4/6/2020 4:04:30 AM] [ INFO] Beginning epg123 client execution. 2020-04-06 09:04:30Z
[4/6/2020 4:04:30 AM] [ INFO] Import: True , Match: True , NoLogo: False , Force: False , ShowProgress: False
[4/6/2020 4:04:31 AM] Entering importMxfFile() for file "c:\programdata\garyan2\epg123\output\epg123.mxf"
[4/6/2020 4:07:53 AM] [ INFO] Successfully imported .mxf file into Media Center database. Exit code: 0
[4/6/2020 4:07:53 AM] Exiting importMxfFile(). SUCCESS.
[4/6/2020 4:08:01 AM] [ INFO] Skipped matching WFAA to channel 8 due to channel already having an assigned listing.
[4/6/2020 4:08:01 AM] [ INFO] Completed the automatch of lineup stations to tuner channels.
[4/6/2020 4:08:01 AM] [ INFO] Completed lineup refresh.
[4/6/2020 4:08:01 AM] Entering runWmcTask(ReindexSearchRoot)
[4/6/2020 4:08:01 AM] [ INFO] SUCCESS: Attempted to run the scheduled task "Microsoft\Windows\Media Center\ReindexSearchRoot".
[4/6/2020 4:08:01 AM] [ INFO] Successfully started the ReindexSearchRoot task. Exit code: 0
[4/6/2020 4:08:01 AM] Exiting runWmcTask(ReindexSearchRoot). SUCCESS.
[4/6/2020 4:08:02 AM] [ INFO] Changed "Secrets of the Zoo" series recording request's 'anyLanguage' setting to TRUE.
[4/6/2020 4:08:02 AM] Entering runWmcTask(PvrScheduleTask)
[4/6/2020 4:08:02 AM] [ INFO] SUCCESS: Attempted to run the scheduled task "Microsoft\Windows\Media Center\PvrScheduleTask".
[4/6/2020 4:08:02 AM] [ INFO] Successfully started the PvrScheduleTask task. Exit code: 0
[4/6/2020 4:08:02 AM] Exiting runWmcTask(PvrScheduleTask). SUCCESS.
[4/6/2020 4:08:02 AM] [ERROR] The MXF file imported is 264.07 hours old.
[4/6/2020 4:08:02 AM] [ INFO] Completed EPG123 client execution.
[4/6/2020 4:08:02 AM] [ INFO] EPG123 client execution time was 00:03:31.6488592.
[

m509272reb

Posts: 1
Joined: Mon Apr 06, 2020 9:25 pm
Location:

HTPC Specs: Show details

#1295

Post by m509272reb » Tue Apr 07, 2020 2:31 am

FIOS is now using clear QAM numbers of 5 digits. E.g. 70.12345
Entering anything higher than .10000 results in 10000 being created e.g. 70.12345 creates 70.10000
I see a release note mentioning that EPG123 can take numbers higher than 999 but FIOS decided to go higher than 9999
Thanks!

User avatar
garyan2

Posts: 5511
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#1296

Post by garyan2 » Tue Apr 07, 2020 3:09 am

Well of course they did. I'll change EPG123 to max 99999 for subchannels, but that doesn't help you right now.

In the registry, change:

HKLM\SOFTWARE\Microsoft\Multimedia\TV\Tuning Spaces\ClearQAM
"MaxMinorChannel" to 99999.

I think you should be able to manually add it, or pick it up in a scan.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

User avatar
DavidinCT

Posts: 1527
Joined: Mon Feb 13, 2012 3:45 pm
Location:

HTPC Specs: Show details

#1297

Post by DavidinCT » Mon Apr 13, 2020 8:15 pm

Tried to EPG Client, it just closes...

In the tracelog...

Code: Select all

[4/13/2020 4:10:44 PM] ===============================================================================
[4/13/2020 4:10:44 PM]  Activating the epg123 configuration GUI. version 1.3.6.20
[4/13/2020 4:10:44 PM] ===============================================================================
[4/13/2020 4:13:08 PM] ===============================================================================
[4/13/2020 4:13:08 PM]  Activating the epg123 client GUI. version 1.3.6.20
[4/13/2020 4:13:08 PM] ===============================================================================
[4/13/2020 4:13:08 PM] [ INFO] Successfully queried the Task Scheduler for status. No task is scheduled to run.
[4/13/2020 4:13:08 PM] [ERROR] Unhandled thread exception caught from epg123Client.exe. message: Could not load file or assembly 'Microsoft.MediaCenter.UI, Version=6.1.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.
Any idea on this one ?
-Dave
Twitter @TheCoolDave

Windows Media Center certified and WMC MVP 2010 - 2012

User avatar
garyan2

Posts: 5511
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#1298

Post by garyan2 » Mon Apr 13, 2020 8:44 pm

Do you not have WMC installed?
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

User avatar
DavidinCT

Posts: 1527
Joined: Mon Feb 13, 2012 3:45 pm
Location:

HTPC Specs: Show details

#1299

Post by DavidinCT » Mon Apr 13, 2020 9:38 pm

garyan2 wrote:
Mon Apr 13, 2020 8:44 pm
Do you not have WMC installed?
Yes, I do... Been running on Windows Ultimate 7 x64 on this machine for years...

Media Center works fine...
-Dave
Twitter @TheCoolDave

Windows Media Center certified and WMC MVP 2010 - 2012

User avatar
garyan2

Posts: 5511
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#1300

Post by garyan2 » Tue Apr 14, 2020 12:07 am

Was this all of a sudden, working one day and not the next? Did you change anything? Have a new AV program or anything that may block EPG123? Apply any hacks to WMC?

The file it is trying to locate is part of WMC and is a reference library for the client to run. Without it, the client won't run as you can see.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

Post Reply