WMC and PlayReady

Post Reply

Posts: 11
Joined: Sat Jun 22, 2019 8:42 pm

HTPC Specs: Show details

WMC and PlayReady


Post by tired_runner » Mon Jun 24, 2019 2:47 pm


I've run into a peculiar, but maybe expected issue with my Windows Media Center. I want to help explain as concise, but as thorough as possible. I appreciate it in advance for reading the whole thing.

I run Windows 7 Ultimate 64-bit with Media Center on a Dell PC. I also pay for regular linear TV subscription via Verizon FiOS renting one CableCARD paired to Ceton InfiniTV ETH 6 multi-tuner.

Recently, I started getting this message on channels flagged copy-once:

The PlayReady update was Incomplete.You will not be able to watch or record protected content until the is successful.

I realize Microsoft is slowly pushing Windows Media Center's demise. But I've found no mention of End-Of-Life for PlayReady, so I suppose the DRM component is still supported for copyright-related items such as copy-once.

I already tried this trick: http://www.hydrous.net/weblog/2012/08/2 ... -playready

There's variants to these steps, but generally all involve stopping the WMC receiver service, deleting specific files and folders, and clicking through the error message. Once I do this, PlayReady error clears, but copy-once channels still don't work.

What happens for me is as follows:

1. I'll tune into a channel flagged copy-once. After brief pause, WMC shows error message stated above.
2. I'll try updating PlayReady, which fails with same error message. I'll get choice to retry or cancel.
3. I'll stop WMC receiver service while leaving WMC running in background.
4. I'll delete specific files and folders as outlined in steps while WMC is running in the background.
5. Then, I'll go back into WMC and click Retry, and then the PlayReady update progresses stating it was successful.
6. Clicking Live TV fails stating there are no tuners available. Only way to fix this is a reboot.
7. Rinse and repeat from step 1.

Thinking perhaps starting over from scratch would help, I reloaded this same Dell PC using Dell OEM DVD which loads Windows 7 Ultimate 64-bit. But there's no difference.

I'm I SOL? Any other tricks before I cancel my pay TV subscription and go with Sling?


Posts: 11
Joined: Sat Jun 22, 2019 8:42 pm

HTPC Specs: Show details


Post by tired_runner » Tue Jun 25, 2019 1:13 am

Just re-ran TV setup wizard. Same as before, kept getting error when updating PlayReady.

I power cycled the Ceton InfiniTV 6, then went straight to Update PlayReady menu option in WMC. For some reason update went through this time.

Now I have copy-once channels back. And as it turns out with Verizon FiOS in my area, only channel in Preferred HD package flagged copy-once is FXX. The rest are copy freely. Doh!

With cable operator in my area, ability to view copy-once channels is more necessary as they flag more channels this way. Verizon FiOS is less restrictive.

TV guide is still broken though. I think I'm making switch to EPG123 and move on with life.

So good news for now it appears. WMC still lives. For now.


Posts: 2412
Joined: Sun Jun 02, 2013 9:44 pm

HTPC Specs: Show details


Post by Space » Tue Jun 25, 2019 6:08 am

All of the Fox owned cable channels should be copy once on FiOS, not just FXX (FX, Fox Sports X, BTN X, Fox Business, Fox News, NatGeo, FXX, Fox Movie Channel). The only other copy once channels in the entire lineup (all packages) are the many HBO and Cinemax channels.

So, FiOS is pretty good with regard to limited copy once channels.


Posts: 162
Joined: Sun Dec 23, 2012 3:38 pm

HTPC Specs: Show details


Post by Dkeyguy1 » Wed Jun 26, 2019 2:19 am

The text file named Playready update failure sits on my repairs thumdrive.
This works every single time for me. If the problem you have is actually Playready update related, this should work.
- Ensure that you're logged in with admin rights, and that under Control Panel->Folder Options->View, you have "Show Hidden Files, Folders and drives" selected and "Hide protected operating system files" unchecked.

- From Control Panel->Programs and Features, uninstall "PlayReady PC Runtime" if present (x86 or x64 as appropriate)

net stop ehrecvr

cd %programdata%\Microsoft\PlayReady

del *.hds

rmdir /s Cache

cd %programdata%\Microsoft\ehome

del *.hds

rmdir /s Cache

- Go to C:\ProgramData\Microsoft\Windows\DRM and delete all files and folders underneath (don't delete the DRM directory itself)

net start ehrecvr

Run Windows Media Center. Update PlayReady by going through Tasks, Settings, TV, TV Signal, Update PlayReady.

This is from someone else, sorry I don't recall, I''ve gotten many up and running with it.
Good luck
I will say that I haven't had to uninstall PlayReady most of the time.


Posts: 11
Joined: Sat Jun 22, 2019 8:42 pm

HTPC Specs: Show details


Post by tired_runner » Wed Jun 26, 2019 12:25 pm

^ Yes, I tried those steps. Never worked for me this time, though it did in the past.

For some unexplainable reason, this is what fixed it for me this time:

1. Launch WMC and get to Update PlayReady menu.
2. Run the PlayReady update, wait for it to fail.
3. Once it fails it will ask to cancel or retry. Let it sit there and power cycle Ceton InfiniTV (my alternative to cable boxes and TiVO).
4. Once Ceton InfiniTV comes back, click Retry.
5. Update progresses and is success.
6. Done


Posts: 9
Joined: Wed Mar 12, 2014 2:36 am

HTPC Specs: Show details


Post by gkr321 » Wed Jun 26, 2019 7:35 pm

After having this problem a few times over the years, Ive found that power cycling router tuner and computer usually fixes it.

Post Reply