Output to XML vs XMLTV

An evolving, supported alternative to Rovi
Forum rules
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf
Post Reply
mshoward82

Posts: 2
Joined: Fri Apr 05, 2019 4:01 am
Location:

HTPC Specs: Show details

Output to XML vs XMLTV

#1

Post by mshoward82 » Fri Apr 05, 2019 4:05 am

Is there any setting to change the EPG output to XML vs the XMLTV?
I tried searching around but didn't fin anything.

Under the epg123task.xml I see that I change the working directory, but don't see anything about changing the actual filename.

User avatar
garyan2

Posts: 3491
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#2

Post by garyan2 » Fri Apr 05, 2019 4:30 am

I'm not sure I follow. Do you mean the filename extension? epg123.xml versus epg123.xmltv? That is all it is is the extension... the contents are xml in the xmltv schema.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

mshoward82

Posts: 2
Joined: Fri Apr 05, 2019 4:01 am
Location:

HTPC Specs: Show details

#3

Post by mshoward82 » Fri Apr 05, 2019 1:16 pm

Yeah. I was just curious if the extension could be changed to just .xml.
Thanks!

User avatar
garyan2

Posts: 3491
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#4

Post by garyan2 » Fri Apr 05, 2019 6:08 pm

There is nothing in place to do so. Is there a reason for it to be needed?
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

User avatar
aquadextrous

Posts: 64
Joined: Mon Jul 30, 2018 8:09 pm
Location: Bristol, UK

HTPC Specs: Show details

#5

Post by aquadextrous » Fri Apr 05, 2019 6:47 pm

Some versions of dvblogic won’t see files named *.xmltv but do see *.xml to import epg - I think maybe they only look for “TVGuide.xml” in a certain folder. Perhaps other programs do the same. I was considering asking about this when I first used epg123 and I was having trouble where epg123 kept losing the matched channels. But I resolved this by renaming all my channels to the short code form used by SD and haven’t had any issues since.

Also, while I’m here - on the WMC menu page sometimes the date with the epg123 logo is US and sometimes British (4/5/19 v 5/4/19 for today) I don’t think I’ve changed anything... wondering how I can keep it as British? Thanks :)

User avatar
garyan2

Posts: 3491
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#6

Post by garyan2 » Fri Apr 05, 2019 10:01 pm

aquadextrous wrote:
Fri Apr 05, 2019 6:47 pm
Also, while I’m here - on the WMC menu page sometimes the date with the epg123 logo is US and sometimes British (4/5/19 v 5/4/19 for today) I don’t think I’ve changed anything... wondering how I can keep it as British? Thanks :)
It shouldn't jump around like that. For that date stamp, I rely on the operating systems regional format settings... I don't manipulate it in any way.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

User avatar
aquadextrous

Posts: 64
Joined: Mon Jul 30, 2018 8:09 pm
Location: Bristol, UK

HTPC Specs: Show details

#7

Post by aquadextrous » Sat Apr 06, 2019 9:58 am

garyan2 wrote:
Fri Apr 05, 2019 10:01 pm
aquadextrous wrote:
Fri Apr 05, 2019 6:47 pm
Also, while I’m here - on the WMC menu page sometimes the date with the epg123 logo is US and sometimes British (4/5/19 v 5/4/19 for today) I don’t think I’ve changed anything... wondering how I can keep it as British? Thanks :)
It shouldn't jump around like that. For that date stamp, I rely on the operating systems regional format settings... I don't manipulate it in any way.
Ah. No idea why windows is doing that then. It’s no big deal. Thought maybe I was missing an option for it. I can live with incorrect date formats. Thanks!

User avatar
garyan2

Posts: 3491
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#8

Post by garyan2 » Sat Apr 06, 2019 3:05 pm

Is there possibly a pattern that it is in the correct format if someone is logged in to the system, but reverts to US format if it is woken to perform the update?
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

User avatar
aquadextrous

Posts: 64
Joined: Mon Jul 30, 2018 8:09 pm
Location: Bristol, UK

HTPC Specs: Show details

#9

Post by aquadextrous » Sat Apr 06, 2019 3:31 pm

I was playing around with MMUI the other day - I may have changed the rating to US - I’ll change it back tonight to see if it changes it at all.
Though I’ve so many customisation and things to keep WMC running on Windows 10 it could be anything 😂 if nobody else is experiencing it then it’s probably something on my machine. I’m not too worried tbh.

The PC never sleeps. It’s on 24/7 apart from a scheduled restart at night. This restart is well outside of the hours epg123 is doing anything.

User avatar
aquadextrous

Posts: 64
Joined: Mon Jul 30, 2018 8:09 pm
Location: Bristol, UK

HTPC Specs: Show details

#10

Post by aquadextrous » Sat Apr 06, 2019 3:31 pm

I was playing around with MMUI the other day - I may have changed the rating to US - I’ll change it back tonight to see if it changes it at all.
Though I’ve so many customisation and things to keep WMC running on Windows 10 it could be anything :lolno: if nobody else is experiencing it then it’s probably something on my machine. I’m not too worried tbh.

The PC never sleeps. It’s on 24/7 apart from a scheduled restart at night. This restart is well outside of the hours epg123 is doing anything.

Post Reply