v1.2.9 Release

An evolving, supported alternative to Rovi
Forum rules
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf
Post Reply
User avatar
garyan2

Posts: 3349
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

v1.2.9 Release

#1

Post by garyan2 » Sun Dec 30, 2018 8:50 pm

I actually released this early this morning, but forgot to let everyone know. This version is using v1.2.7 as the base and applying the fixes again... just a different way than what I did for v1.2.8.

http://epg123.garyan2.net
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

User avatar
IT Troll

Posts: 631
Joined: Sun Nov 27, 2011 9:42 am
Location: Edinburgh, UK

HTPC Specs: Show details
5+ Yrs TGB Veteran

#2

Post by IT Troll » Wed Jan 09, 2019 12:56 am

I am not seeing anything different with regards to ratings for TV programmes/episodes. Perhaps the feed for my channels doesn’t include this? Movies have a star rating but that is no different to previous versions.

Do you have to be running ModernMedia UI to see these?

User avatar
garyan2

Posts: 3349
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#3

Post by garyan2 » Wed Jan 09, 2019 5:09 pm

Certainly not as much as I had hoped. I will say that if there are any GBR/UK ratings available in the data, it will show in the guide. Same is true for Germany and France.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Joram

Posts: 60
Joined: Mon Sep 26, 2016 1:15 am
Location:

HTPC Specs: Show details

#4

Post by Joram » Wed Jan 30, 2019 9:22 pm

Do I need to install this newest version in order to keep the program guide updated? Our program data is down to 5 days (ending Feb. 4) even though I have the setting at 28 days.

User avatar
garyan2

Posts: 3349
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#5

Post by garyan2 » Thu Jan 31, 2019 12:41 am

No, there are probably some people out there still running v1.0.2. There is something else going on that is preventing an update from completing. What does the trace.log file show?
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Joram

Posts: 60
Joined: Mon Sep 26, 2016 1:15 am
Location:

HTPC Specs: Show details

#6

Post by Joram » Thu Jan 31, 2019 1:27 am

Thanks for getting back to us. Here are the last several lines of the trace.log file:

Code: Select all

[9/24/2018 7:48:23 PM]  Activating the epg123 configuration GUI.
[9/24/2018 7:48:23 PM] ===============================================================================
[9/24/2018 7:48:26 PM] [ INFO] epg123 is not up to date. Latest version is 1.2.5 and can be downloaded from http://epg123.garyan2.net.
[9/24/2018 7:48:29 PM] [ INFO] Token request successful. serverID: 20141201.web.X
[9/24/2018 7:48:29 PM] [ INFO] Status request successful. account expires: 2018-10-02T19:44:33Z , lineups: 1/4 , lastDataUpdate: 2018-09-24T20:58:16Z
[9/24/2018 7:48:29 PM] [ INFO] system status: Online , message: No known issues.
[9/24/2018 7:48:30 PM] [ INFO] Successfully requested listing of client lineups from Schedules Direct.
[9/24/2018 7:48:30 PM] [ INFO] Successfully retrieved the station mapping for lineup USA-PA66100-X.
[9/24/2018 7:48:31 PM] [ INFO] Successfully queried the Task Scheduler for status. status: Ready. Last Run 9/24/2018 4:00:00 AM; Exit: 0x00000000
[9/25/2018 12:25:33 AM] ====================== Beginning epg123 client execution. =====================
[9/25/2018 12:25:33 AM] [ INFO] Import=False , Match=False , NoLogo=False
[1/28/2019 11:31:09 PM] ===============================================================================
[1/28/2019 11:31:09 PM]  Activating the epg123 configuration GUI.
[1/28/2019 11:31:09 PM] ===============================================================================
[1/28/2019 11:31:13 PM] [ INFO] epg123 is not up to date. Latest version is 1.2.10 and can be downloaded from http://epg123.garyan2.net.
[1/28/2019 11:31:24 PM] [ INFO] Token request successful. serverID: 20141201.web.X
[1/28/2019 11:31:24 PM] [ INFO] Status request successful. account expires: 2019-10-02T19:44:33Z , lineups: 1/4 , lastDataUpdate: 2019-01-28T21:40:18Z
[1/28/2019 11:31:24 PM] [ INFO] system status: Online , message: No known issues.
[1/28/2019 11:31:24 PM] [ INFO] Successfully requested listing of client lineups from Schedules Direct.
[1/28/2019 11:31:24 PM] [ INFO] Successfully retrieved the station mapping for lineup USA-PA66100-X.
[1/28/2019 11:31:26 PM] [ INFO] Successfully queried the Task Scheduler for status. status: Ready. Last Run 1/28/2019 4:00:00 AM; Exit: 0x00000000
[1/30/2019 6:31:58 PM] ===============================================================================
[1/30/2019 6:31:58 PM]  Activating the epg123 configuration GUI.
[1/30/2019 6:31:58 PM] ===============================================================================
[1/30/2019 6:32:02 PM] [ INFO] epg123 is not up to date. Latest version is 1.2.10 and can be downloaded from http://epg123.garyan2.net.
FWIW, Windows Task Scheduler reports that the guide update was performed successfully at 4AM last night. (But obviously it wasn't, or at least it didn't stick.)

User avatar
garyan2

Posts: 3349
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#7

Post by garyan2 » Thu Jan 31, 2019 1:35 am

I think you might be looking at the wrong trace.log file. Your task must be pointing to a different location and running that one and I need to see the trace.log file from your active epg123 installation.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Joram

Posts: 60
Joined: Mon Sep 26, 2016 1:15 am
Location:

HTPC Specs: Show details

#8

Post by Joram » Thu Jan 31, 2019 1:40 am

Huh, I'll have to look around for a different trace.log file (not sure where). I did a Start Menu Search for "trace" and that's the only file it found.

User avatar
garyan2

Posts: 3349
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#9

Post by garyan2 » Thu Jan 31, 2019 1:43 am

Did you install using the setup executable, or did you use the portable download? If you used the setup executable, just use the shortcut from the start menu and click the [View Log] button.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Joram

Posts: 60
Joined: Mon Sep 26, 2016 1:15 am
Location:

HTPC Specs: Show details

#10

Post by Joram » Thu Jan 31, 2019 1:58 am

Yes, it was installed (the folder is in the Program Files (x86) subdirectory). But I don't see a "View Log" button in the GUI. Nor is there a "View Log" option under the EPG123 listing in the Start Menu.

In case it makes a difference, this is EPG123 version 1.0.2.

User avatar
garyan2

Posts: 3349
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#11

Post by garyan2 » Thu Jan 31, 2019 2:04 am

That button was relatively new (v1.2.4 - 11 August 2018) compared to v1.0.2 which was 25 September 2016. Though 1.0.2 was a good solid performer, there have been a lot of updates since. Does it sound right that you have not updated since late 2016 and early 2017?
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Joram

Posts: 60
Joined: Mon Sep 26, 2016 1:15 am
Location:

HTPC Specs: Show details

#12

Post by Joram » Thu Jan 31, 2019 2:11 am

Yes indeed, that does sound right. The program has worked so well, it doesn't even occur to me that upgrades might come out! :)

Should I just go ahead and install the newest version over the old one? According to our other conversation tonight (viewtopic.php?f=99&t=12068&p=129995#p129995), all that needs to be done is to install it over the old version and there is nothing further to do, the new version will simply pick up where the old one left off. Would that take care of the guide updating issue?

User avatar
garyan2

Posts: 3349
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#13

Post by garyan2 » Thu Jan 31, 2019 2:36 am

Well I'm totally confused as to why the trace.log file didn't show anything.

Unfortunately, not so fast on the update and nothing else comment. Since you're coming from v1.0.2 there are some other steps that will be necessary. Where exactly is your current installation (C:\Program Files (x86)\epg123) ?
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

User avatar
garyan2

Posts: 3349
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#14

Post by garyan2 » Thu Jan 31, 2019 2:49 am

Here is a step-by-step for you to upgrade from v1.0.2 to v1.2.10.

1) Download and install EPG123 v1.2.10 to C:\Program Files (x86)\epg123.
2) Open EPG123 to create new subfolders in the ProgramData folder and then close it.
3) Move your \cache, \logos, and \sdlogos folder from C:\Program Files (x86)\epg123 to C:\ProgramData\GaRyan2\epg123
4) Move your epg123.cfg, guideImages.xml, and trace*.log files from C:\Program Files (x86)\epg123 to C:\ProgramData\GaRyan2\epg123
5) Open EPG123 as Administrator
6) Delete your current scheduled task and create a new one
7) Click [Save & Execute] and wait for it to complete
8) Open EPG123 Client (this is new for you; it was introduced in v1.1.0)
9) Select any channel on the left side, press [Ctrl]+[A] to select all, right-click a selected channel and select 'Unsubscribe'
10) Select your lineup on the right-side pulldown (Verizon Fios Philadelphia - Digital (Philadelphia))
11) Click the Match by: [# Number] button on the left side above all the channels

Everything should be good.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Joram

Posts: 60
Joined: Mon Sep 26, 2016 1:15 am
Location:

HTPC Specs: Show details

#15

Post by Joram » Thu Jan 31, 2019 10:14 pm

Gary, thank you very much for the step-by-step instructions -- this is just what I need!

I went in this afternoon to carry them out, but before starting I discovered two things: one, that the scheduled recordings are now extending out to February 20; and two, that the drive where the recordings are saved was down to 58GB free. I wonder if this diminishing space had something to do with the grid and schedule cutting off on February 4. (My wife has been taping a ton of stuff lately.)

Curiously, although the recordings now went out to 2/20, the program grid still stopped at February 4. After closing and restarting WMC, now that, too, goes out to the 20th.

I'm now in the process of deleting old recordings or moving them to different drives to make room on the main one. Anyway, the crisis is past and I can carry out your instructions later on with less pressure.

Thanks again for jumping on this problem.

User avatar
garyan2

Posts: 3349
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#16

Post by garyan2 » Fri Feb 01, 2019 3:33 am

Do you leave WMC open all the time? I think this is one thing in WMC that I could never find a way to do was to actually "refresh" then guide end date if WMC was open when the update ran. Even though the guide in the database would extend out to the 21 days, the "end date" would never change until you closed and re-opened WMC.

I just thought of something ... there is a registry key with the guide end date that might be the key. It would only be referenced when WMC is opened. This will require some investigation.

Bottom line, it appears that your v1.0.2 was still ticking along without issue. You just found a WMC quirk that I haven't addressed yet.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Joram

Posts: 60
Joined: Mon Sep 26, 2016 1:15 am
Location:

HTPC Specs: Show details

#17

Post by Joram » Thu Feb 14, 2019 6:22 am

Whoa, I just realized that you replied to me a long time ago, sorry about that!

To answer your question: yes, we leave WMC on 24/7. Typically, when we're not watching TV we'll turn the TV off and leave WMC paused on some recording. It seems to behave better that way when we turn the TV back on, than if we leave a channel tuned while the set is off.

Again, thank you so much for jumping on our problem so quickly! Everything's been good again since then.

Post Reply