Running Windows Media Center @ 2160p/4K !!!!!

User avatar
DavidinCT

Posts: 1420
Joined: Mon Feb 13, 2012 3:45 pm
Location:

HTPC Specs: Show details

Re: Running Windows Media Center @ 2160p/4K !!!!!

#41

Post by DavidinCT » Wed Mar 29, 2017 1:06 am

werds wrote:
Putting a pin in this one here in order to figure out why it is not working for me (finally got around to trying this last night and spent way too much time fighting with greyed out permission boxes then finally after I removed inheritable permissions and tried with what was left it still kept resetting it back :(
Yep, it does, I think I posted that someplace in this thread. I battled with this for MONTHS(if not years), till I found an option that completely disables the message BUT, you will need to search for it, as don't have time to find it right now.

A quick way is to create a registry file and run a batch file to start WMC, on the first line, import the reg file and run WMC.... So when you reboot your computer, it will run the script and you wont see the message for that session. Although if you switch sources on a AVR or something, on return, it will show again.

The ONLY way I was able to FULLY get rid of it was by a HEX edit of one of the WMC files. If you have the exact version (on a updated WMC), and you can hex edit the file, then use the admin tool from the Windows 10 WMC installer, to replace the file on WMC. I got the details on how to do it one of the experts who helped on W10 WMC (or I think he did most of it) and he lists it in that thread that I replied to with the same user name (I am DavidinCT over there).

This fully removed this message as it disabled it at the system level. I also removed the Volume popup (when ever stopping video, the volume 50 in the corner would show up) we did a hex edit for that one too.

If you go this route and find the details, if you ever have to do a sfc /scannow it will replace the original files.

If your not very techy, I would avoid this one, as you put a wrong number in it you can damage WMC...

Edit: Depending on versions...this is Windows 7 only...

How to HEX
https://forums.mydigitallife.info/threa ... ost1204986

Then you need to check your ehshell.dll version...and this is only for x64

ehshell.dll version 6.1.7601.18968, x64
https://forums.mydigitallife.info/threa ... ost1205342

ehshell.dll 6.1.7601.19061 x64
https://forums.mydigitallife.info/threa ... ost1205623

You might need to register to that site to see the posts but, this is what I did....

and if you want the volume thing, let me know I can provide this too... I looked them up and saved to my favs, there is even away to do RDP video as well but, I think it breaks extenders.
-Dave
Twitter @TheCoolDave

Windows Media Center certified and WMC MVP 2010 - 2012

passinos

Posts: 15
Joined: Sat Mar 25, 2017 2:46 pm
Location:

HTPC Specs: Show details

#42

Post by passinos » Sun May 21, 2017 9:27 pm

did someone find a fix to the missing channel number in bottom right while at 4k at 200% DPI on WMC7 ??

poit57

Posts: 56
Joined: Mon May 05, 2014 7:02 pm
Location:

HTPC Specs: Show details

#43

Post by poit57 » Thu Nov 09, 2017 7:59 am

Based on the information in this thread, I was able to get the warning message about a high resolution to go away with a rather simple method, though I wish it looked a little cleaner. I created a batch file with the following command:

Code: Select all

reg add "HKLM\Software\Microsoft\Windows\CurrentVersion\Media Center\Display Settings" /v DisableHighCheck /d 3840x2160 /f
In the time I've spent trying to figure this out, I have observed that the DisableHighCheck registry entry reverts to "1920x1080" upon exiting WMC. My simple workaround was to create a scheduled task that runs my batch file every 5 minutes. Most of the time, that would be way more often than necessary, but should drastically reduce the amount of times I see this warning message in the future.

I'm not knowledgeable enough about the Task Scheduler and triggers to know if this is possible, but ideally, the batch file could be triggered any time I exit out of WMC. Is it possible to trigger a task in this manner without more advanced coding hinted at in DavidinCT's most recent post?

User avatar
DavidinCT

Posts: 1420
Joined: Mon Feb 13, 2012 3:45 pm
Location:

HTPC Specs: Show details

#44

Post by DavidinCT » Sun Nov 12, 2017 2:56 pm

poit57 wrote:Based on the information in this thread, I was able to get the warning message about a high resolution to go away with a rather simple method, though I wish it looked a little cleaner. I created a batch file with the following command:

Code: Select all

reg add "HKLM\Software\Microsoft\Windows\CurrentVersion\Media Center\Display Settings" /v DisableHighCheck /d 3840x2160 /f
In the time I've spent trying to figure this out, I have observed that the DisableHighCheck registry entry reverts to "1920x1080" upon exiting WMC. My simple workaround was to create a scheduled task that runs my batch file every 5 minutes. Most of the time, that would be way more often than necessary, but should drastically reduce the amount of times I see this warning message in the future.

I'm not knowledgeable enough about the Task Scheduler and triggers to know if this is possible, but ideally, the batch file could be triggered any time I exit out of WMC. Is it possible to trigger a task in this manner without more advanced coding hinted at in DavidinCT's most recent post?
This does work, just for the session. As the system will reset the registry key when WMC exits. This will also come back if you USE HDMI and shut off your TV and turn it back on as it re syncs the connection. As you can see, even setting this to repeat every 5 min, it might not help or even having a batch to run when you exit WMC. I played with this for about 3 months on an off. I know EXACTLY what you want to do but, it never fully works.

The ONLY way I found to get rid of this, that was a not a "temp" work around like you said was doing the hex edits I showed on the post above. It's not really that hard, do some reading, back up your system before doing so if all fails, you can revert back.

This is one thing that disables it for GOOD, WMC is not able to display that message after the hex edit.

As for looking cleaner, my WMC is based off batch files to keep it running smooth, as long as it's hidden in the background, I don't think looks messy !
-Dave
Twitter @TheCoolDave

Windows Media Center certified and WMC MVP 2010 - 2012

User avatar
DavidinCT

Posts: 1420
Joined: Mon Feb 13, 2012 3:45 pm
Location:

HTPC Specs: Show details

#45

Post by DavidinCT » Sun Nov 12, 2017 4:19 pm

Not sure how well this works at this point as I have not personally tried it.

This seems to offer an option to disable the high res check (it has an option for it)

https://windows10mediacenter.com/modernmedia/ui

Read more about the project here...
viewtopic.php?f=97&t=11330
-Dave
Twitter @TheCoolDave

Windows Media Center certified and WMC MVP 2010 - 2012

User avatar
Crash2009

Posts: 4356
Joined: Thu May 17, 2012 12:38 am
Location: Ann Arbor, Michigan

HTPC Specs: Show details

#46

Post by Crash2009 » Mon Nov 27, 2017 4:40 am

https://forums.mydigitallife.net/thread ... st-1392095

Somebody is looking for the HexEdit for the Version of WMC that we are using in Win10

6.3.9600.16384

User avatar
DavidinCT

Posts: 1420
Joined: Mon Feb 13, 2012 3:45 pm
Location:

HTPC Specs: Show details

#47

Post by DavidinCT » Mon Nov 27, 2017 8:23 pm

Crash2009 wrote:https://forums.mydigitallife.net/thread ... st-1392095

Somebody is looking for the HexEdit for the Version of WMC that we are using in Win10

6.3.9600.16384
Would like the HEX edit for that as well.... The ones have listed are for Windows 7 (WMC ver 6.1.xxxx) not for 8.1/10 WMC version 6.3.xxxx
-Dave
Twitter @TheCoolDave

Windows Media Center certified and WMC MVP 2010 - 2012

mt17

Posts: 2
Joined: Sat Jan 06, 2018 9:31 am
Location:

HTPC Specs: Show details

#48

Post by mt17 » Sat Jan 06, 2018 9:39 am

DavidinCT wrote:
werds wrote:
Putting a pin in this one here in order to figure out why it is not working for me (finally got around to trying this last night and spent way too much time fighting with greyed out permission boxes then finally after I removed inheritable permissions and tried with what was left it still kept resetting it back :(
Yep, it does, I think I posted that someplace in this thread. I battled with this for MONTHS(if not years), till I found an option that completely disables the message BUT, you will need to search for it, as don't have time to find it right now.

A quick way is to create a registry file and run a batch file to start WMC, on the first line, import the reg file and run WMC.... So when you reboot your computer, it will run the script and you wont see the message for that session. Although if you switch sources on a AVR or something, on return, it will show again.

The ONLY way I was able to FULLY get rid of it was by a HEX edit of one of the WMC files. If you have the exact version (on a updated WMC), and you can hex edit the file, then use the admin tool from the Windows 10 WMC installer, to replace the file on WMC. I got the details on how to do it one of the experts who helped on W10 WMC (or I think he did most of it) and he lists it in that thread that I replied to with the same user name (I am DavidinCT over there).

This fully removed this message as it disabled it at the system level. I also removed the Volume popup (when ever stopping video, the volume 50 in the corner would show up) we did a hex edit for that one too.

If you go this route and find the details, if you ever have to do a sfc /scannow it will replace the original files.

If your not very techy, I would avoid this one, as you put a wrong number in it you can damage WMC...

Edit: Depending on versions...this is Windows 7 only...

How to HEX
https://forums.mydigitallife.info/threa ... ost1204986

Then you need to check your ehshell.dll version...and this is only for x64

ehshell.dll version 6.1.7601.18968, x64
https://forums.mydigitallife.info/threa ... ost1205342

ehshell.dll 6.1.7601.19061 x64
https://forums.mydigitallife.info/threa ... ost1205623

You might need to register to that site to see the posts but, this is what I did....

and if you want the volume thing, let me know I can provide this too... I looked them up and saved to my favs, there is even away to do RDP video as well but, I think it breaks extenders.
Hi,

I´m quite new to this, maybe you can help:
I found out that I have a ehshell.dll Version 6.1.7601.23434 (Windows 7 X64)
Do you know how to patch this Version to get rid of the high resoution warning?

Thank you,

Martin

User avatar
DavidinCT

Posts: 1420
Joined: Mon Feb 13, 2012 3:45 pm
Location:

HTPC Specs: Show details

#49

Post by DavidinCT » Sat Jan 06, 2018 7:56 pm

mt17 wrote:

Hi,

I´m quite new to this, maybe you can help:
I found out that I have a ehshell.dll Version 6.1.7601.23434 (Windows 7 X64)
Do you know how to patch this Version to get rid of the high resoution warning?

Thank you,

Martin
Sorry, It's not something I figured out, I was only provided the HEX locations for the older versions of the file. I needed one for an earlier version and asked and was not able to do it.

The only options to get rid of this message is to roll back to a past version and apply these fixes or keep an eye on the modernUI app. The dev had a way to FIX this problem but, it didn't work but, it claims he has a fix for it coming soon (not sure till how long soon will be now)

viewtopic.php?f=9&t=11331

I rolled back to a past version to "test an app" and I got the message back, I tested his fix on 7 x64 and it didn't work. There is a registry setting that could stop this but, the permissions keep reverting causing the message to come back. I can get it to stop on first boot up but, every time you switch HDMI or turn the TV on and off, it resyncs HDMI and the message will come back.

Looks like that version was upgraded on MS16-059, and broke a lot of WMC apps because of a security flaw in WMC... There is always a possibility to roll back/ remove KB3150220 and that should get you back where you can use this. DO this with your own risk, I would backup your system before removing an update on WMC like this.

but, all in all, There is no perm fix for this message on that version of ehshell.dll at this point.

Hope this helped
-Dave
Twitter @TheCoolDave

Windows Media Center certified and WMC MVP 2010 - 2012

joelkirzner

Posts: 81
Joined: Wed May 22, 2013 3:18 pm
Location:

HTPC Specs: Show details

#50

Post by joelkirzner » Sun Apr 15, 2018 11:07 pm

From another poster on this thread about 4k and WMC:
"For some reason when I watch TV the channel number does not display to the left near the station ID when changing channels, tried different dpi settings with no success. 1080p displays fine."

This has been a little bug that drives me nuts on my 55" LG 4k oled.
It only happens when changing live tv channels. If you hit info, the channel number shows up fine.

No one has posted any solution.
Attachments
20180415_190948.jpg

User avatar
DavidinCT

Posts: 1420
Joined: Mon Feb 13, 2012 3:45 pm
Location:

HTPC Specs: Show details

#51

Post by DavidinCT » Mon Apr 16, 2018 6:42 pm

joelkirzner wrote:From another poster on this thread about 4k and WMC:
"For some reason when I watch TV the channel number does not display to the left near the station ID when changing channels, tried different dpi settings with no success. 1080p displays fine."

This has been a little bug that drives me nuts on my 55" LG 4k oled.
It only happens when changing live tv channels. If you hit info, the channel number shows up fine.

No one has posted any solution.
Never noticed that but, I'll check it out... Interesting.

Not sure if it's a deal killer but, a minor thing.
-Dave
Twitter @TheCoolDave

Windows Media Center certified and WMC MVP 2010 - 2012

QPH7qhNK49OzQtvXTil7

Posts: 5
Joined: Tue Mar 15, 2016 6:30 pm
Location:

HTPC Specs: Show details

#52

Post by QPH7qhNK49OzQtvXTil7 » Sat Aug 17, 2019 7:08 pm

DavidinCT wrote:
Mon Jan 18, 2016 9:08 pm
Hey all,

I fixed this issue once and for all. I have disabled this message so rebooting or re-opening Windows Media Center will No longer show this message !!!! FINALLY !!!! After a day or testing on 8.1 and rebooting to Windows 7 (I dual booth on my HTPC), I applied this fix and it removed it, so it works on 7 and 8.1....

So, so background on this issue and the problem. When WMC starts it checks this key to make sure WMC is running in the recommend resolution, if this key is modified, it will change it back to the default. I have proven if you add this key with 3840x2160 before WMC starts, this message will not show but, the next time you run it, it will. So what I attempted was to no longer allow Windows Media Center to CHANGE THIS KEY. By giving "system" ONLY permission to "read" this key and no longer change, the key never goes back to the default and this message will NEVER appear again. :)

In the registry...

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Media Center\Display Settings

Change "DisableHighCheck" to "3840x2160"

After that, Right click on "Display Settings" go to permissions. What you need to do is make the user you log in as the "owner" (it used to be "system"), Make sure your logon account has "full control" put "System" to "read only" and Administrators "read only".

So, at this point
<user logon account> Full control
System - Read ONLY
Administrators - Read only

This does work, tested on 8.1 and 7...
That wasn't enough, it still did not work for me. Then I discovered another setting I did need to change and it worked great. Thank you for your post.
I did not have to change the user or the Administrator permissions. I did have to change the registry folder’s Owner and change the registry folder’s permission for SYSTEM to READ ONLY as you described.
The additional setting I had to change was also in the same folder in the registry (Windows 10 for me):

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Media Center\Display Settings

Change "DisableComplexStretchesOnConsole" (REG_DWORD) from a value of 0 to a value of 1

I also found
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Media Center\Settings\DisplayService

had a set of variable for Physical and Logical screen width
LogicalHeight (REG_DWORD) - I set this to 2160 (decimal)
PhysicalHeight (REG_DWORD) - I set this to 2160 (decimal)
and
LogicalWidth (REG_DWORD) - I set this to 3840 (decimal)
PhysicalWidth (REG_DWORD) - I set this to 3840 (decimal)

I don't know if the change to the DisplayService variables was required, but they now match my display and it made sense to change them when I disabled the complex stretches on the console.

If you only use your Media Center for watching less than 4k TV, it is probably best to let the TV do the up converting as it probably has settings allowing you to customize how that works, for example one setting for high velocity scenes (sports for example) and another for slow velocity scenes such as drama. The IV is probably newer and has faster processors for handing that. I switched from that to having the PC set for 4k display so that I could better read text in my browser from the couch across the room and can stream 4k Netflix without changing the PC resolution. I have been happy with my decision, but notice the video is a bit jumpy now when I watch at 150% speed. Your hardware and tradeoffs may vary.
Hope no one was waiting since Mon Jan 18, 2016 9:08 pm for this information. ;)
Love the site and the ability to help one another!

Paul Anderegg

Posts: 106
Joined: Sat Apr 21, 2012 4:39 am
Location:

HTPC Specs: Show details

#53

Post by Paul Anderegg » Thu Aug 22, 2019 1:16 am

4K for me produced some poor upscaling resulting in marcoblocking being more readily visible as opposed to letting my TV upscale the native 1080 video. I also run my PC at video levels internally, spitting through HDMI full PC levels, with TV set to video levels, so in all, my desktop looks pretty bad, but my video is as good as it can get. :)

Paul

Post Reply