Page 48 of 52

Re: EPG123 Bug Reports

Posted: Fri Sep 06, 2019 12:19 am
by garyan2
Taking a look at the trace.log file would help, but my first guess would be to open the client and click the Match by [# Number] button to map the listings to the channels.

Re: EPG123 Bug Reports

Posted: Fri Sep 06, 2019 2:35 am
by middlfam
Reinstalled Win 7 and EPG123. Now there is no data in the programming guide. "NO DATA" for every channel. It looks like EPG123 executes correctly, exit of 0. Any ideas?

Re: EPG123 Bug Reports

Posted: Fri Sep 06, 2019 3:26 am
by garyan2
middlfam wrote:
Fri Sep 06, 2019 2:35 am
Reinstalled Win 7 and EPG123. Now there is no data in the programming guide. "NO DATA" for every channel. It looks like EPG123 executes correctly, exit of 0. Any ideas?
garyan2 wrote:
Fri Sep 06, 2019 12:19 am
Taking a look at the trace.log file would help, but my first guess would be to open the client and click the Match by [# Number] button to map the listings to the channels.
Did you look at the trace.log file and click the Match by: [# Number] button?

Re: EPG123 Bug Reports

Posted: Mon Sep 09, 2019 4:09 am
by Joram
Not sure if this is the right place for this, but here goes:

My wife noticed that recurring programs (such as the late-night and Sunday morning shows) are getting only generic descriptions in the program guide, as opposed to the usual specific info on topics and guests. We use Schedules Direct via EPG123.

Has anybody else noticed this, and what can we do about it?

Re: EPG123 Bug Reports

Posted: Mon Sep 09, 2019 4:36 am
by garyan2
Joram wrote:
Mon Sep 09, 2019 4:09 am
Not sure if this is the right place for this, but here goes:

My wife noticed that recurring programs (such as the late-night and Sunday morning shows) are getting only generic descriptions in the program guide, as opposed to the usual specific info on topics and guests. We use Schedules Direct via EPG123.

Has anybody else noticed this, and what can we do about it?
I would need some examples to say whether it is an issue or not, but for the late-night shows... you will typically only get the next few or maybe a week's worth of episode information. Basically the networks are mostly sure at that point on who the guests or what the topics will be for the near future. Going beyond a week for those types of shows is a gamble and the guide will typically be generic.

Same probably goes for your Sunday morning programs.

Re: EPG123 Bug Reports

Posted: Wed Sep 11, 2019 3:48 pm
by Joram
garyan2 wrote:
Mon Sep 09, 2019 4:36 am
Joram wrote:
Mon Sep 09, 2019 4:09 am
Not sure if this is the right place for this, but here goes:

My wife noticed that recurring programs (such as the late-night and Sunday morning shows) are getting only generic descriptions in the program guide, as opposed to the usual specific info on topics and guests. We use Schedules Direct via EPG123.

Has anybody else noticed this, and what can we do about it?
I would need some examples to say whether it is an issue or not, but for the late-night shows... you will typically only get the next few or maybe a week's worth of episode information. Basically the networks are mostly sure at that point on who the guests or what the topics will be for the near future. Going beyond a week for those types of shows is a gamble and the guide will typically be generic.

Same probably goes for your Sunday morning programs.
Sorry for the delay in replying, it's been a crazy few days.

Yup, it was the lack of guest listings even for this week that had wife concerned. But by the next morning (Monday) everything seemed to be OK. The overnight schedule update must have taken care of it.

Thanks for getting back to us on this!

Re: EPG123 Bug Reports

Posted: Sun Oct 06, 2019 2:56 pm
by StinkyImp
Yesterday afternoon I cloned my hard drive and then extracted version 1.2.18 over my existing version 1.2.7.

On first look everything appears to have worked as intended with these exceptions.
  1. Line 19 in my trace.log.
  2. The emblem in WMC which I believe should have been red?
  3. Ooops! I just noticed that v1.2.18.10 is available.

Code: Select all

EPG123 Log Parser (and Report Generator) - v 1.7.5 (64 bit)
Report Created on 10/06/2019 at 07:08:07
================================================================
     1 [10/6/2019 12:15:07 AM] ===============================================================================
     2 [10/6/2019 12:15:07 AM]  Beginning epg123 update execution. version 1.2.18.0
     3 [10/6/2019 12:15:07 AM] ===============================================================================
     4 [10/6/2019 12:15:07 AM] [ INFO] Beginning EPG123 update execution. 2019-10-06 07:15:07Z
     5 [10/6/2019 12:15:08 AM] [ INFO] DaysToDownload: 14 , TheTVDBNumbers : True , PrefixEpisodeTitle: False , PrefixEpisodeDescription : False , AppendEpisodeDesc: False , OADOverride : True , TMDbCoverArt: True , IncludeSDLogos : True , AutoAddNew: True , CreateXmltv: False , ModernMediaUiPlusSupport: False
     6 [10/6/2019 12:15:09 AM] [ INFO] Token request successful. serverID: 20141201.web.1
     7 [10/6/2019 12:15:09 AM] [ INFO] Status request successful. account expires: 2020-02-12T14:47:08Z , lineups: 1/4 , lastDataUpdate: 2019-10-05T22:14:20Z
     8 [10/6/2019 12:15:09 AM] [ INFO] system status: Online , message: No known issues.
     9 [10/6/2019 12:15:09 AM] [ INFO] Successfully retrieved TMDb configurations.
    10 [10/6/2019 12:15:10 AM] [ INFO] Successfully requested listing of client lineups from Schedules Direct.
    11 [10/6/2019 12:15:10 AM] Entering buildLineupServices() for 1 lineups.
    12 [10/6/2019 12:15:10 AM] [ INFO] Successfully retrieved the station mapping for lineup USA-OTA-XXXXX.
    13 [10/6/2019 12:15:11 AM] Exiting buildLineupServices(). SUCCESS.
    14 [10/6/2019 12:15:11 AM] Entering getAllScheduleEntryMd5s() for 14 days on 96 stations.
    15 [10/6/2019 12:15:13 AM] [ INFO] Successfully retrieved Md5s for  96 station's daily schedules. (0:00:00:01.3080748 /   143.128 KB)
    16 [10/6/2019 12:15:22 AM] [ INFO] Successfully retrieved  96 station's daily schedules.          (0:00:00:07.3554207 /     1.387 MB)
    17 [10/6/2019 12:15:23 AM] [ INFO] Found 1115 cached daily schedules.
    18 [10/6/2019 12:15:23 AM] [ INFO] Downloaded 229 daily schedules.
    19 [10/6/2019 12:15:23 AM] [ERROR] Unhandled exception caught from epg123.exe. message: Object reference not set to an instance of an object.
    20 [10/6/2019 12:15:39 AM] ===============================================================================
    21 [10/6/2019 12:15:39 AM]  Beginning epg123 client execution. version 1.2.18.0
    22 [10/6/2019 12:15:39 AM] ===============================================================================
    23 [10/6/2019 12:15:39 AM] [ INFO] Beginning epg123 client execution. 2019-10-06 07:15:39Z
    24 [10/6/2019 12:15:39 AM] [ INFO] Import: True , Match: True , NoLogo: False , Force: False , ShowProgress: False
    25 [10/6/2019 12:15:40 AM] Entering importMxfFile() for file  C:\epg123\output\epg123.mxf 
    26 [10/6/2019 12:16:07 AM] [ INFO] Successfully imported .mxf file into Media Center database. Exit code: 0
    27 [10/6/2019 12:16:07 AM] Exiting importMxfFile(). SUCCESS.
    28 [10/6/2019 12:16:07 AM] [ INFO] Skipped matching KFPHDT3 to channel 35.3 due to channel already having an assigned listing.
    29 [10/6/2019 12:16:07 AM] [ INFO] Completed the automatch of lineup stations to tuner channels.
    30 [10/6/2019 12:16:07 AM] [ INFO] Completed lineup refresh.
    31 [10/6/2019 12:16:07 AM] Entering runWmcTask(ReindexSearchRoot)
    32 [10/6/2019 12:16:07 AM] [ INFO] SUCCESS: Attempted to run the scheduled task  Microsoft\Windows\Media Center\ReindexSearchRoot .
    33 [10/6/2019 12:16:07 AM] [ INFO] Successfully started the ReindexSearchRoot task. Exit code: 0
    34 [10/6/2019 12:16:07 AM] Exiting runWmcTask(ReindexSearchRoot). SUCCESS.
    35 [10/6/2019 12:16:08 AM] Entering runWmcTask(PvrScheduleTask)
    36 [10/6/2019 12:16:08 AM] [ INFO] SUCCESS: Attempted to run the scheduled task  Microsoft\Windows\Media Center\PvrScheduleTask .
    37 [10/6/2019 12:16:08 AM] [ INFO] Successfully started the PvrScheduleTask task. Exit code: 0
    38 [10/6/2019 12:16:08 AM] Exiting runWmcTask(PvrScheduleTask). SUCCESS.
    39 [10/6/2019 12:16:08 AM] [ INFO] Completed EPG123 client execution.
    40 [10/6/2019 12:16:08 AM] [ INFO] EPG123 client execution time was 00:00:28.5426325.

===== QUERY INFORMATION (Predefined) ===========================
Logs used:		trace.log ONLY
Search String:		Everything
Date Range:		10/06/2019 thru 10/06/2019 (1 days)
Total results found:	40
Query time:		04 seconds

===== GENERAL INFORMATION ======================================
Log Path:		C:\epg123\
Logfile timespan:	6/24/2019 thru 10/6/2019 (105 days)
Total lines processed:	8934

===== SYSTEM INFORMATION =======================================
Operating System:	Windows 7 Professional (64 bit)
Processor:		Intel(R) Core(TM) i3-3220 CPU @ 3.30GHz
Total RAM:		8.00 GB
ehshell version:	6.1.7601.23434
EPG123 version:		1.2.18.0
Last boot time:		October 05, 2019 - 11:33 AM
System Uptime:		19 Hours 34 Minutes
Event Viewer shows a .NET Runtime error at 12:15:23

Code: Select all

Application: epg123.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.NullReferenceException
   at epg123.sdJson2mxf.processMd5ScheduleEntry(System.String)
   at epg123.sdJson2mxf.getAllScheduleEntryMd5s(Int32)
   at epg123.sdJson2mxf.Build(epg123.epgConfig)
   at epg123.Program.Main(System.String[])
...and an Application error at 12:15:25

Code: Select all

Faulting application name: epg123.exe, version: 1.2.18.0, time stamp: 0x5d8fc61a
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x000007fe95bdd068
Faulting process id: 0x2fc
Faulting application start time: 0x01d57c15c4002131
Faulting application path: C:\epg123\epg123.exe
Faulting module path: unknown
Report Id: 10f4b342-e809-11e9-832f-ed85521a5d73
Can I provide any additional information?

Do you think this may be a one off?

Re: EPG123 Bug Reports

Posted: Sun Oct 06, 2019 3:47 pm
by garyan2
StinkyImp wrote:
Sun Oct 06, 2019 2:56 pm
Yesterday afternoon I cloned my hard drive and then extracted version 1.2.18 over my existing version 1.2.7.
I just successfully downloaded the OTA in your area, may not have been the right zip code though.

I would try again to see if the error is still there. If so, the error is occurring when processing the daily schedules so you can clear the cache and try again. If the error is still there, then I will need to know your lineup so I can try and duplicate it here.

Thanks.

Re: EPG123 Bug Reports

Posted: Tue Oct 08, 2019 6:09 pm
by sptrainman
I am having a problem with channels 49/1049 on my system. This should be TBS (Turner Broadcasting), but the guide shows that it is BET instead and that there is no data available.BET is Black Entertainment Television which is on 59/1059. So I cannot record or watch TBS with WMC.

I downloaded the latest update for EPG123, installed it, and did a rebuild of the WMC database. That did not fix the problem. I checked the lineup on Schedules Direct and it shows that channel 49 is TBS. I am able to tune TBS normally with my Cox Cable recorder. So the channel is available on the cable.

Please help.
Thanks,
Jerry

Re: EPG123 Bug Reports

Posted: Tue Oct 08, 2019 6:33 pm
by garyan2
sptrainman wrote:
Tue Oct 08, 2019 6:09 pm
I am having a problem with channels 49/1049 on my system. This should be TBS (Turner Broadcasting), but the guide shows that it is BET instead and that there is no data available.BET is Black Entertainment Television which is on 59/1059. So I cannot record or watch TBS with WMC.

I downloaded the latest update for EPG123, installed it, and did a rebuild of the WMC database. That did not fix the problem. I checked the lineup on Schedules Direct and it shows that channel 49 is TBS. I am able to tune TBS normally with my Cox Cable recorder. So the channel is available on the cable.

Please help.
Thanks,
Jerry
What is your lineup so I can check it out.

If you open the client, is TBS present on the right side and on channel 49/1049?

Re: EPG123 Bug Reports

Posted: Tue Oct 08, 2019 6:42 pm
by garyan2
I took a look at your lineup and everything is good there. I have TBSP on channel 49, and TBSHDP on channel 1049; both with guide listings.

In the client, you can manually attach the guide listings for TBSP and TBSHDP.

1. Select channel 49 on the left side (left-click)
2. Select channel 49 on the right side (right-click) and select Subscribe
3. Repeat for channel 1049.

Re: EPG123 Bug Reports

Posted: Tue Oct 08, 2019 8:19 pm
by sptrainman
That doesn't seem to work for me. I did get a a pop up and selected Subscribe, but nothing changed. What I am seeing on the left side for tuning info for 1049 is 1059. Everything else looks correct. The right side shows 1049 and TBS Also, when I go into edit mode in WMC, it shows the same problem, but I don't now how to use the WMC editor. It shows that the source for 1049 is 1059.

Jerry

Re: EPG123 Bug Reports

Posted: Tue Oct 08, 2019 8:31 pm
by garyan2
sptrainman wrote:That doesn't seem to work for me. I did get a a pop up and selected Subscribe, but nothing changed. What I am seeing on the left side for tuning info for 1049 is 1059. Everything else looks correct. The right side shows 1049 and TBS Also, when I go into edit mode in WMC, it shows the same problem, but I don't now how to use the WMC editor. It shows that the source for 1049 is 1059.

Jerry
On the left side, is the channel number highlighted pink/salmon? If so, for the channel with tuning info 1049, right click and select Renumber... change it back to 1049.


Re: EPG123 Bug Reports

Posted: Wed Oct 09, 2019 4:51 pm
by sptrainman
Yes, it is highlighted but the channel number on the left side of the left panel is correct. On the right side of the left panel, the tuned channel number is still showing 1059. There is no way to edit that column. When I right click on the right panel for the 1049 entry, I get a popup with "subscribe" and I think "renumber." But they disappear when I move the cursor over them IIRC.

So this morning, I rebooted the WMC computer which I thought might refresh something that needed to be rebuilt. Now I cannot tune any channels. The system says that no tuners are available.

So I selected Rebuild WMC Database on the client tool and am waiting for that to rebuild.

Thanks,
Jerry

Re: EPG123 Bug Reports

Posted: Wed Oct 09, 2019 5:03 pm
by garyan2
The channel number on the left side of the left panel is showing the custom number you put in at some point. Above the left panel, you will see a red'ish button labled 'Custom Labels'... click that and it will change to 'Original Labels'. Your channel will now show 1059.

The 'custom' number on the left side of the left panel is what your guide will show. The number on the right side of the left panel is what the tuner actually tunes to and can not be changed.

Click the 'Original Labels' button to change back to 'Custom Labels', right-click the channel and select 'Renumber'. Delete the number and keyboard press Enter, or just change the number back to 1059. After that, it should be easier to understand what is going on.

Re: EPG123 Bug Reports

Posted: Wed Oct 09, 2019 5:34 pm
by sptrainman
OK. I will try that when I get a chance. I restarted WMC hoping that might fix the problem. Instead, WMC cannot find my tuners. This is the first time that has happened. I have two Silicon Dust Homerun boxes that I have been using for years. Each has three tuners. According to the diagnostic software, both tuners are up an working, so I don't know what is wrong. I started a rescan on the tuners.

Hope I don't have to reload WMC. I have been concerned that my HDs are getting old -- at least three years I think. I think they may be losing sectors now.
Jerry

Re: EPG123 Bug Reports

Posted: Wed Oct 09, 2019 6:22 pm
by garyan2
A rescan on the tuners will straighten the channel numbering issue. You will need to import the guide listings again and then match them. In the client do a [Manual Import] and the a Match by [# Number].

Re: EPG123 Bug Reports

Posted: Wed Oct 09, 2019 8:00 pm
by sptrainman
Well, right now, I can't tune any channels. This came about after I restarted WMC this morning to try to resolve the channel mapping issue. Now, WMC cannot see any of my six tuners, but the Silicon Dust software shows that all six tuners are working and I can tune in channels that are not proprietary and watch them live. I'm stumped. I have no idea how to fix this. If you have any hints, please let me know!!!

Thanks,
Jerry

Re: EPG123 Bug Reports

Posted: Wed Oct 09, 2019 8:03 pm
by garyan2
If you open the client, what does it show? Are there channels on the left side?

Re: EPG123 Bug Reports

Posted: Wed Oct 09, 2019 10:09 pm
by sptrainman
Yes. There are channels on the left side. I was trying to send you an attachment but it won't allow a word or RTF document.

The problem with my tuners was that Windows changed my network type to public and WMC will not allow that. So after fixing that, I am back where I started. The TBS entry shows 1059 still on the right side of the left panel so that it still what it is tuning. I can try a manual import, but not until tomorrow now. I ran out of time. It will do one automatically again tonight.

I'm wondering if I have a disk problem where the guide is being stored that changes the '4' to a '5'.

If you can tell me how to send an attachment with a screenshot, I will send that to you.

Jerry