EPG123 Bug Reports

An evolving, supported alternative to Rovi
Forum rules
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf
User avatar
garyan2

Posts: 5344
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

Re: EPG123 Bug Reports

#1341

Post by garyan2 » Fri Sep 25, 2020 2:54 am

Just your slider values to see if there is something wrong with my geometry.

EDIT: an image of the guide would be nice of the problem as well, if you can.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

NOYB

Posts: 36
Joined: Thu Sep 10, 2020 8:03 am
Location:

HTPC Specs: Show details

#1342

Post by NOYB » Fri Sep 25, 2020 3:00 am

1) Click Default button
Snap2.jpg
Snap2.jpg (2.09 KiB) Viewed 236 times
2) Click Update button
Result is chopped off channel name in guide.
Snap1.jpg
Snap1.jpg (1.96 KiB) Viewed 236 times
3) Set Channel Column Width lever to 0 (default pixels) and click Update button.
Snap1.jpg
Snap1.jpg (1.96 KiB) Viewed 236 times
Applying any tweaks results in the channel name being chopped off.
Snap1.jpg
Snap1.jpg (1.96 KiB) Viewed 236 times
Snap3.jpg

User avatar
garyan2

Posts: 5344
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#1343

Post by garyan2 » Fri Sep 25, 2020 3:04 am

Okay, I'll work on this, but to solve your issue just set the Channel Logo Size to Medium and everything will be good.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

User avatar
garyan2

Posts: 5344
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#1344

Post by garyan2 » Fri Sep 25, 2020 4:20 am

It's been a long time since I worked/looked at this code. The difficulty with this one is I had to set the insets to a certain value in order to center the logos. What is chopping off the text is the logo mask/borders. Making the logo larger allows the full text to be seen but at small size the text is not centered.

I'll play around with it for a bit to see what I can come up with, but everything is really optimized with a logo size selection of medium or large so everything will be nice and centered.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

NOYB

Posts: 36
Joined: Thu Sep 10, 2020 8:03 am
Location:

HTPC Specs: Show details

#1345

Post by NOYB » Fri Sep 25, 2020 4:59 am

Interesting that it doesn't happen for default. Which also has small logo.

User avatar
garyan2

Posts: 5344
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#1346

Post by garyan2 » Fri Sep 25, 2020 5:05 am

The [Default] button restores WMC defaults which will place the logos off center in the row height so that the mask doesn't block any text. When EPG123 applies an [Update], it will center everything but due to the text of the call sign having a non-symmetrical space above and below, the visible pixels get pushed below the logo mask and cutting it off.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

User avatar
garyan2

Posts: 5344
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#1347

Post by garyan2 » Fri Sep 25, 2020 5:31 am

I'm not finding anything I am satisfied with so far. If you use small logos, then to see all the text you can enable the 'Remove Channel Focus Animations' which will make the logos about 20% larger and removes the logo mask.

The only other option I see to still keep the small logo option would be to make the font size of the call sign smaller which looks a bit weird.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

User avatar
garyan2

Posts: 5344
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#1348

Post by garyan2 » Fri Sep 25, 2020 6:13 am

Okay, I'm going to call this one. In my calculations, rather than round to the nearest font size for the call sign text, I'm going to subtract 1 point. The text will be slightly smaller, and for small logos the text won't be centered vertically, but you will be able to see all of it.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

User avatar
garyan2

Posts: 5344
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#1349

Post by garyan2 » Fri Sep 25, 2020 10:51 pm

Version 1.4.0 has just been released with this adjustment as well as other new features.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

tcolumb

Posts: 4
Joined: Thu Jul 06, 2017 12:55 am
Location:

HTPC Specs: Show details

#1350

Post by tcolumb » Fri Oct 09, 2020 3:52 pm

My schedule stopped updating on 9/27 (and I just noticed). Included is the latest entry from the log file and it looks OK to me ... any help is appreciated!

[10/9/2020 11:32:38 AM] ===============================================================================
[10/9/2020 11:32:38 AM] Beginning epg123 update execution. version 1.4.10.10
[10/9/2020 11:32:38 AM] ===============================================================================
[10/9/2020 11:32:38 AM] [ INFO] Beginning EPG123 update execution. 2020-10-09 15:32:38Z
[10/9/2020 11:32:38 AM] [ INFO] DaysToDownload: 21 , TheTVDBNumbers : True , PrefixEpisodeTitle: True , PrefixEpisodeDescription : True , AppendEpisodeDesc: False , OADOverride : True , TMDbCoverArt: True , IncludeSDLogos : True , AutoAddNew: True , CreateXmltv: False , ModernMediaUiPlusSupport: False
[10/9/2020 11:32:38 AM] [ INFO] Status request successful. account expires: 2021-01-07T19:34:20Z , lineups: 1/4 , lastDataUpdate: 2020-10-09T06:25:05Z
[10/9/2020 11:32:38 AM] [ INFO] system status: Online , message: No known issues.
[10/9/2020 11:32:39 AM] [ INFO] Successfully retrieved TMDb configurations.
[10/9/2020 11:32:39 AM] [ INFO] Successfully requested listing of client lineups from Schedules Direct.
[10/9/2020 11:32:39 AM] Entering buildLineupServices() for 1 lineups.
[10/9/2020 11:32:45 AM] [ INFO] Successfully retrieved the station mapping for lineup USA-CT06408-X.
[10/9/2020 11:32:45 AM] Exiting buildLineupServices(). SUCCESS.
[10/9/2020 11:32:45 AM] Entering getAllScheduleEntryMd5s() for 21 days on 138 stations.
[10/9/2020 11:32:49 AM] [ INFO] Successfully retrieved Md5s for 138 station's daily schedules. (0:00:00:03.9797214 / 263.601 KB)
[10/9/2020 11:33:16 AM] [ INFO] Successfully retrieved 138 station's daily schedules. (0:00:00:18.6086973 / 3.053 MB)
[10/9/2020 11:33:18 AM] [ INFO] Found 1932 cached daily schedules.
[10/9/2020 11:33:18 AM] [ INFO] Downloaded 547 daily schedules.
[10/9/2020 11:33:20 AM] [ INFO] Processed 2479 daily schedules for 138 stations.
[10/9/2020 11:33:20 AM] Exiting getAllScheduleEntryMd5s(). SUCCESS.
[10/9/2020 11:33:20 AM] Entering buildAllProgramEntries() for 28892 programs.
[10/9/2020 11:33:21 AM] [ INFO] epg123 update execution time was 00:00:42.1970460.

User avatar
garyan2

Posts: 5344
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#1351

Post by garyan2 » Fri Oct 09, 2020 4:10 pm

It is ending at the time it is scanning through the cache file so I would suspect there is something wrong with the cache. Open the configuration GUI, click the [Clear Cache] button and the [Save & Execute]. Should be fine after that.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

tcolumb

Posts: 4
Joined: Thu Jul 06, 2017 12:55 am
Location:

HTPC Specs: Show details

#1352

Post by tcolumb » Fri Oct 09, 2020 5:53 pm

That did the trick, thanks!

Space

Posts: 2043
Joined: Sun Jun 02, 2013 9:44 pm
Location:

HTPC Specs: Show details

#1353

Post by Space » Fri Oct 09, 2020 9:56 pm

Are there errors/warnings missing from this log? It looks like it is skipping stuff but no error or warning is logged. You would have to understand what should be logged to know if there was anything wrong rather than having an explicit error message telling you there was a problem.

For instance, just going from my failing memory, I know that there should be a log entry in there stating that it is writing (or has written) the MXF file, so I know if that is missing there is a problem. But I think there should be an explicit message logged so that it is clear there was a problem (and also so that the bug in the WMC GUI is colored red/yellow to indicate a problem.)
Last edited by Space on Sat Oct 10, 2020 3:53 am, edited 1 time in total.

User avatar
garyan2

Posts: 5344
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#1354

Post by garyan2 » Sat Oct 10, 2020 1:19 am

I would love to add something in the log in this case, but for some reason it is not catching it. I don't exactly know where the error is coming from in order to try and prevent it either, nor can I recreate it. Next time I see it, I'll try to get the user's cache file to see if I can pinpoint the problem.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

Space

Posts: 2043
Joined: Sun Jun 02, 2013 9:44 pm
Location:

HTPC Specs: Show details

#1355

Post by Space » Sat Oct 10, 2020 3:55 am

If it's not catching it how is it logging that final message ("epg123 update execution time was ...")? Is that a separate process?

User avatar
garyan2

Posts: 5344
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#1356

Post by garyan2 » Sat Oct 10, 2020 4:09 am

That's why I can't figure it out. If it just failing the process to build the mxf file, then there will be more information in the log file. It isn't throwing anything, it is simply terminating the process and returning to the calling function.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

Space

Posts: 2043
Joined: Sun Jun 02, 2013 9:44 pm
Location:

HTPC Specs: Show details

#1357

Post by Space » Sat Oct 10, 2020 5:25 am

I see, so it is using separate processes? Can't you at least have the process terminate with an error return code so that can be logged by the parent process? Then the parent can just log a generic "XXX process terminated unexpectedly" if the return code from that process is not what is expected.

User avatar
garyan2

Posts: 5344
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#1358

Post by garyan2 » Sat Oct 10, 2020 5:56 am

Doesn't help much. Not being able to create the MXF file will be obvious since there will be an ERROR reported with the logo/icon change when importing an MXF file that is more than 24 hours old. The client will ensure an error is reported.

I don't think I can terminate with an error return code. The whole point here is that there are no exceptions being thrown, no failures, no nothing. It just dies. I don't know if it gets destroyed and I don't know if I will still have access to its parameters/variables. So my approach will be to get my hands on a cache file that is failing and see if I can recreate and duplicate. I've never had the failure on any of my machines to work with.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

alhaunts

Posts: 9
Joined: Wed Jan 01, 2020 5:45 pm
Location:

HTPC Specs: Show details

#1359

Post by alhaunts » Sat Oct 10, 2020 1:16 pm

For the past month or so, the tray icon app has been throwing errors every couple of days. Event ID: 1000

Here are the details:

Faulting application name: epgTray.exe, version: 1.2.0.0, time stamp: 0xb5f1213e
Faulting module name: KERNELBASE.dll, version: 6.1.7601.24520, time stamp: 0x5d673e23
Exception code: 0xe0434352
Fault offset: 0x000000000000b87d
Faulting process id: 0x498
Faulting application start time: 0x01d69e7622a518e8
Faulting application path: C:\Program Files (x86)\epg123\epgTray.exe
Faulting module path: C:\Windows\system32\KERNELBASE.dll
Report Id: 613fc4b8-0a69-11eb-b347-e0cb4e8bb65c

This occurs at random times of the day & doesn't seem to affect functionality AFAIK

System is Win 7 x64

Cheers, Al.

Space

Posts: 2043
Joined: Sun Jun 02, 2013 9:44 pm
Location:

HTPC Specs: Show details

#1360

Post by Space » Sat Oct 10, 2020 1:29 pm

garyan2 wrote:
Sat Oct 10, 2020 5:56 am
Doesn't help much. Not being able to create the MXF file will be obvious since there will be an ERROR reported with the logo/icon change when importing an MXF file that is more than 24 hours old. The client will ensure an error is reported.

I don't think I can terminate with an error return code. The whole point here is that there are no exceptions being thrown, no failures, no nothing. It just dies. I don't know if it gets destroyed and I don't know if I will still have access to its parameters/variables. So my approach will be to get my hands on a cache file that is failing and see if I can recreate and duplicate. I've never had the failure on any of my machines to work with.
Yeah, I guess I don't understand enough about this.

I mean if the process gets to the end, it can set something somewhere indicating it got to the end (ran successfully). If the process does not get to the end, for instance it just dies, it will not have set that thing since it never got there.

You then can have the part that prints that last line to the log just check the above thing and if it is not set to indicate it ran successfully, then it can just print a generic error about that part exiting unexpectedly.

But I admit I have very little knowledge of how it works.

Post Reply