EPG123 Client crashes

An evolving, supported alternative to Rovi
Forum rules
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf
Post Reply
markfromBrooklyn

Posts: 39
Joined: Wed Jul 15, 2015 8:14 pm
Location: Brooklyn New York

HTPC Specs: Show details

EPG123 Client crashes

#1

Post by markfromBrooklyn » Tue Jan 05, 2021 10:49 pm

EPG Client crashes, both when run by scheduled task, and when I attempt t rum manually.

I have restaryed Win 7 Pro system, and have no idea what else to try. Should I try reinstalling EPG123? Any other advice would be appreciated. Thanks


Code: Select all

  [1/5/2021 5:40:25 PM] [ INFO] Found 10538 cached series image links.
[1/5/2021 5:40:25 PM] [ INFO] Refreshing 337 series image links.
[1/5/2021 5:40:25 PM] [ INFO] Successfully retrieved artwork info for 337 programs. (0:00:00:00.5700000 /     3.092 MB)
[1/5/2021 5:40:25 PM] [ INFO] Processed 10875 series image links.
[1/5/2021 5:40:25 PM] Exiting getAllSeriesImages(). SUCCESS.
[1/5/2021 5:40:26 PM] [ INFO] Completed compiling keywords and keyword groups.
[1/5/2021 5:40:27 PM] [ INFO] Completed save of the MXF file to "C:\EPG123\output\epg123.mxf".
[1/5/2021 5:40:27 PM] [ INFO] 0 entries deleted from the cache file during cleanup.
[1/5/2021 5:40:29 PM] [ INFO] Downloaded and processed     4.062 MB of data from Schedules Direct.
[1/5/2021 5:40:29 PM] [ INFO] Generated .mxf file contains 519 services, 10875 series, 52217 programs, and 70977 people with 15014 image links.
[1/5/2021 5:40:29 PM] [ INFO] Completed EPG123 update execution. SUCCESS.
[1/5/2021 5:40:29 PM] [ INFO] epg123 update execution time was 00:00:24.0530000.
[1/5/2021 5:40:29 PM] [ERROR] Unhandled exception caught from epg123Client.exe. message: Access to the path 'Global\{CD7E6857-7D92-4A2F-B3AB-ED8CB42C6F65}' is denied.
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.Threading.Mutex.MutexTryCodeHelper.MutexTryCode(Object userData)
   at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
   at System.Threading.Mutex.CreateMutexWithGuaranteedCleanup(Boolean initiallyOwned, String name, Boolean& createdNew, SECURITY_ATTRIBUTES secAttrs)
   at System.Threading.Mutex..ctor(Boolean initiallyOwned, String name, Boolean& createdNew, MutexSecurity mutexSecurity)
   at System.Threading.Mutex..ctor(Boolean initiallyOwned, String name)
   at epg123.Program.Main(String[] args)
[1/5/2021 5:42:25 PM] [ERROR] Unhandled exception caught from epg123Client.exe. message: Access to the path 'Global\{CD7E6857-7D92-4A2F-B3AB-ED8CB42C6F65}' is denied.
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.Threading.Mutex.MutexTryCodeHelper.MutexTryCode(Object userData)
   at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
   at System.Threading.Mutex.CreateMutexWithGuaranteedCleanup(Boolean initiallyOwned, String name, Boolean& createdNew, SECURITY_ATTRIBUTES secAttrs)
   at System.Threading.Mutex..ctor(Boolean initiallyOwned, String name, Boolean& createdNew, MutexSecurity mutexSecurity)
   at System.Threading.Mutex..ctor(Boolean initiallyOwned, String name)
   at epg123.Program.Main(String[] args)

User avatar
garyan2

Posts: 5665
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#2

Post by garyan2 » Tue Jan 05, 2021 11:01 pm

Close all epg123 GUIs and make sure epg123.exe and epg123Client.exe are not running in the background using Task Manager (processes tab and [Show processes from all users]). Then try to run an update using the 'Update Guide Now' option from the tray icon or a [Save & Execute] from the configuration GUI.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

markfromBrooklyn

Posts: 39
Joined: Wed Jul 15, 2015 8:14 pm
Location: Brooklyn New York

HTPC Specs: Show details

#3

Post by markfromBrooklyn » Wed Jan 06, 2021 12:12 am

Problem seems to be resolved. I had tried running the installation again and re re running epg manually. That worked.

I suspect but am not sure that the problem may have been the result of a malware scan. I will not use that program again.

Thank you again for all your help..

Post Reply