Page 1 of 1

Problem with scheduled task

Posted: Tue Dec 29, 2020 9:22 am
by technodevotee
I'm following on from viewtopic.php?p=143149#p143149 as this now appears to be an issue with EPG123.

When I try to edit the scheduled task to add -nogc to the epg123client argument line, I get the following when saving it:
and it screws up the program/script entry.

So I tried wrapping the command in quotes in the scheduled task and it saved ok. This morning, however, the scheduled EPG123 update downloaded new guide data twice but didn't load it into the database. All the tray icon says is 'downloading, 10/10'.

If I execute the complete line

Code: Select all

"C:\Program Files (x86)\epg123\epg123Client.exe" -i "C:\ProgramData\GaRyan2\epg123\output\epg123.mxf" -nogc
from a command line, the client imports the mxf into the database but even if I wrap the program/script part in quotes it doesn't seem to work in the scheduled task

This morning, I deleted the task and recreated it using the configuration GUI but didn't try adding -nogc.

I feel that am no further forward but we'll see what happens tomorrow.

Re: problem with scheduled task

Posted: Tue Dec 29, 2020 10:23 am
by Space
When you add arguments in the Task Scheduler, they must go in the "Add arguments (optional)" field, not the "Program/script" field.

So it should look like this:

Program/script: "C:\Program Files (x86)\epg123\epg123Client.exe"

Add arguments (optional): -i "C:\ProgramData\GaRyan2\epg123\output\epg123.mxf" -nogc

Note that you need the double quotes around the entire Program/script entry due to it having spaces in it. You probably don't need the quotes around the mxf file path name in the "Add arguments" field (due to no spaces in the path), but it is good practice to include them.

Also, I think you had a problem with your edit due to the way EPG123 used to add the program path in the "Program/script" field. It used to leave the quotes out (but somehow still worked) but when you edit it, the missing quotes cause the program to not be added properly (due to the space).

Re: problem with scheduled task

Posted: Tue Dec 29, 2020 10:54 am
by technodevotee
What you describe is exactly what I had yesterday and it didn't work.

I exported the task and included it it in my last post (the one I linked to at the beginning of this thread).

As explained in that post, I am using the latest version.

Re: Problem with scheduled task

Posted: Tue Dec 29, 2020 4:01 pm
by garyan2
The trick is to realize MS doesn't know everything. When you edit the task and it gives you the prompt to "correct" it, just say 'No'.

The command line will be preserved and the task should run just fine.

Re: Problem with scheduled task

Posted: Fri Jan 01, 2021 9:06 am
by technodevotee
So it does. Thanks