Task Scheduler

An evolving, supported alternative to Rovi
Forum rules
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf
Post Reply
John UTAZ

Posts: 9
Joined: Mon Feb 06, 2017 7:31 pm
Location:

HTPC Specs: Show details

Task Scheduler

#1

Post by John UTAZ » Thu Jul 30, 2020 6:51 pm

This is likely not a very common problem. We were gone for over a month and shortly after leaving, we had a short power outage that caused the WMC PC to reboot. When we got back, it appears that the guide downloaded just before the power outage eventually ran out... then no new recordings after this because the guide was empty and not updating. I am only guessing that this is related to the Task Scheduler but am a novice when it comes to Task Scheduler. The Task Scheduler says, "Run whether user is logged on or not." but this didn't seem to work as the screen was waiting for our login PW when we got back and the guide had not been getting updated for a couple of weeks. This situation reoccurring is a very unlikely scenario but thought I would ask anyway.
Thanks in advance.
John
Still running V1.3.2 and it works great! I know I should update but I am nervous I'll mess something up. :D

User avatar
IT Troll

Posts: 794
Joined: Sun Nov 27, 2011 9:42 am
Location: Edinburgh, UK

HTPC Specs: Show details

#2

Post by IT Troll » Thu Jul 30, 2020 7:10 pm

I have my HTPC configured to auto login. This ensures that both EPG123 and MMC will continue to function in this scenario.
Are you a Recorded TV HD user or want to give it a try? Check out the new community-made update; Recorded TV HD v2.1

User avatar
garyan2

Posts: 5123
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#3

Post by garyan2 » Thu Jul 30, 2020 7:19 pm

I have my EPG123 running on a server, running 24/7 on UPS, which is never logged in to and the task runs without issue so that shouldn't be an issue. You didn't have any recordings after the power outage either? If so, that means the WMC recording didn't run either. If you did have recordings after the power outage then it is just the epg123_update task that was not running, or it was failing. Is there anything in the log file to show if there was a problem updating the WMC database after the outage?

Updating EPG123 is simple. Just run the setup file and you're done. If you are on Win7 or Win10 and you want to take advantage of being able to use the [Get Latest Guide Listings] button in WMC, then you will have to delete your current task and create a new one.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

John UTAZ

Posts: 9
Joined: Mon Feb 06, 2017 7:31 pm
Location:

HTPC Specs: Show details

#4

Post by John UTAZ » Thu Jul 30, 2020 7:42 pm

So it looks like WMC kept running. From the log, the last epg123 update was 6/5/20 and then again on 7/2/20 when we returned. I have shows that recorded until mid-June. I messed around a little with the User Account in Task Scheduler but didn't think I was making a lot of progress or find a setting that worked while the system was on but no user logged in (waiting at password screen.). I'll have to look at the auto login option for this PC.... and upgrade to the latest version.

John UTAZ

Posts: 9
Joined: Mon Feb 06, 2017 7:31 pm
Location:

HTPC Specs: Show details

#5

Post by John UTAZ » Thu Jul 30, 2020 8:04 pm

Auto login seems to be working... now on to the latest epg123 upgrade. Thank you IT Troll for your feedback and as always, thank you Gary for epg123 that has kept my WMC running so nicely.

User avatar
garyan2

Posts: 5123
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#6

Post by garyan2 » Tue Aug 04, 2020 7:11 am

Apologies. I was able to recreate the task not running if not logged in. I'll see what I can do about that. It works for Win10 because it uses NETWORK SERVICE as the user, but Win7 has problems letting that service access some registry keys.

Sent from my SM-G965U using Tapatalk

- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

User avatar
garyan2

Posts: 5123
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#7

Post by garyan2 » Tue Aug 04, 2020 2:55 pm

Okay, like I said NETWORK SERVICE doesn't have access to some registry keys EPG123 uses... not really a big issue. Everything will still work but the status logo on the WMC home page may not work exactly as intended. I did just did a test using SYSTEM as the user and it worked, so I may go that route. More testing needed.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

Space

Posts: 1988
Joined: Sun Jun 02, 2013 9:44 pm
Location:

HTPC Specs: Show details

#8

Post by Space » Tue Aug 04, 2020 10:56 pm

I don't know that much about this, but I do know that registry keys have ownership and permissions (similar to files), so maybe they can be set so that NETWORK SERVICE can access them?

Although it might just be cleaner to have it run as SYSTEM.

User avatar
garyan2

Posts: 5123
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#9

Post by garyan2 » Tue Aug 04, 2020 11:00 pm

I thought about that, but it's not a route I want to take. So far it appears that the SYSTEM user works for Win7 and Win10, both logged in and logged out. If the solution is this simple then that is what I will do.

I'm just a little embarrassed that after 5 years thinking everything worked fine using the user account that created the task, I find out that I was wrong.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

User avatar
IT Troll

Posts: 794
Joined: Sun Nov 27, 2011 9:42 am
Location: Edinburgh, UK

HTPC Specs: Show details

#10

Post by IT Troll » Tue Aug 04, 2020 11:27 pm

Network Service has restricted access to local resources, whilst Local Service has restricted access to network resource. This is done to provide a security boundary as it is not good practice to have a single process running with full Local System and network access. This is why services which require both often come as a pair.
Last edited by IT Troll on Wed Aug 05, 2020 7:11 am, edited 1 time in total.
Are you a Recorded TV HD user or want to give it a try? Check out the new community-made update; Recorded TV HD v2.1

User avatar
Gripweed

Posts: 60
Joined: Sun Feb 03, 2013 6:35 pm
Location: Scranton,PA_USA

HTPC Specs: Show details

#11

Post by Gripweed » Wed Aug 05, 2020 12:21 am

So, do you think that that might be the reason why I couldn't get NETWORK SERVICE to work with the mupdate task and only Administrators would work for me? I didn't try SYSTEM. I stopped looking at other Users/Groups when Administrators worked.

User avatar
garyan2

Posts: 5123
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#12

Post by garyan2 » Wed Aug 05, 2020 12:45 am

No, that one is still a mystery. Running the task in Win7 as NETWORK SERVICE would still run. It would just fail to access the registry keys I take a look at on each update to ensure the guide is active in WMC and to check what your status logo options were set to.
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

Post Reply