Mr. Robot

An evolving, supported alternative to Rovi
Forum rules
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf
Post Reply
Gripweed

Posts: 34
Joined: Sun Feb 03, 2013 6:35 pm
Location:

HTPC Specs: Show details

Mr. Robot

#1

Post by Gripweed » Mon Nov 11, 2019 11:58 pm

I'm not sure if this is a EPG123 problem or a WMC problem or a SD problem or a me problem. For some reason Mr. Robot, which normally appears NEW at 10pm Eastern on Sundays on USA Network, also shows up as NEW at 1am Eastern on Mondays on USA. If I record the series I get two copies of the same show each week. Both copies show the Original Airdate as being the Sunday date. Disregarding that only the first showing should be considered NEW, the obvious kludge fix to make it only record one copy is to set the "Airtime:" record setting in WMC to "Around 10pm." That worked fine for quite some time until this last Sunday when USA decided to move the show an hour or two earlier for one week. I recorded nothing. Luckily, I believe, next week's episode is the show finale. It was the only show that I can recall ever having this problem. Any idea on what might cause the double NEW episodes? And how to properly fix if it happens again? The strange thing is that if I look at the EPG for Emby (which I believe is also sourced from SD or Gracenote) it shows the 10pm show as NEW and the 1am as a repeat. As far as EPG123, the only setting that I've found that has anything to do with NEW is that I have checkmarked that NEW overrides Original Air Date. Uncheckmarking doesn't seem to change anything. Any ideas?

Sent from my ASUS Chromebook Flip C302 using Tapatalk


User avatar
garyan2

Posts: 3837
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#2

Post by garyan2 » Tue Nov 12, 2019 12:11 am

I'll check here to see if I can duplicate the behavior, but WMC determines that anything within 7 days of the original air date is new. Regardless, it should have recognized that both airings were of the same episode and only recorded 1 of them.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

User avatar
garyan2

Posts: 3837
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#3

Post by garyan2 » Tue Nov 12, 2019 12:19 am

Everything appears normal here. You can see next Sunday's episode is scheduled to record at 8PM and the same episode at 11PM has the information symbol which says "Another airing will be recorded on 11/17/2019". Do you not see the same?
mrrobot.PNG
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Space

Posts: 1595
Joined: Sun Jun 02, 2013 9:44 pm
Location:

HTPC Specs: Show details

#4

Post by Space » Tue Nov 12, 2019 12:54 am

I don't know if this is the same issue, but there are certain shows that I record that have a similar problem. I use the "New & rerun" setting, but it still means that any particular episode should only record once, however I often see these specific shows have multiple copies of the same episode marked to record. Note that this is with Rovi/Tivo/Microsoft data, not EPG123/SchedulesDirect/Gracenote.

Here is the scenario in which it appears to happen (and based on the screencap above, this may be the same issue):
The episodes first appear in the guide as "generic" and are therefore all, correctly, set to record (as are the November 24th episodes in the screencap), later, in a subsequent update, those episodes are updated with episode specific information, however WMC keeps them both set to record, even though the update set them to be the same specific episode. Note that this happens with more than two episodes if there were more than two airings of the same episode in the guide at the time that episode specific info was downloaded, however any airing of this same episode that is downloaded AFTER the episode specific info is there are fine, and are not set to record.

If you select one of those episodes that are set to record and tell WMC "Do not record", it will no longer be scheduled to record, but the other episode will still be set to record (and will record). So it's like the episodes are treated as two separate episodes, because normally, if you set an episode to "Do not record" it will not record any instance of that episode.

I've reported this problem a couple times here in the forums but have not really heard many people that have the same issue, so I'm not sure if it is specific to my system or not. I've had this problem even way back when WMC used native Gracenote data.

One other point is that the problem seems to be an issue with how the guide is incrementally updated, because one time I ran ObjectStoreRecoveryTask which cleared the guide when this issue was in effect, and then loaded the latest guide update (which had already been loaded prior to clearing the guide) and the issue was no longer there. Note that I don't advise running ObjectStoreRecoveryTask as it clears a few things that you might not want cleared.

Gripweed

Posts: 34
Joined: Sun Feb 03, 2013 6:35 pm
Location:

HTPC Specs: Show details

#5

Post by Gripweed » Tue Nov 12, 2019 1:57 am

That's weird, I replied back to you Gary but the message is gone.
Anyway, no, my two episodes for next week are both set to record. The week after that we have the same in that both are set to record but as Space commented, that week has a generic listing now and it could change. I think I'm just going to follow Space's lead and just manually cancel the second recording and be done with it. I was wrong about the next episode being the finale. According to IMDB there will be 12 episodes and next week is #7. TheTVDB currently lists only 7 episodes for the season.

Gripweed

Posts: 34
Joined: Sun Feb 03, 2013 6:35 pm
Location:

HTPC Specs: Show details

#6

Post by Gripweed » Wed Nov 13, 2019 3:22 am

Gary, this has got me thinking. Is there any way that the "NEW" symbol can be added to the WMC Guide like how Emby has it below?
Screenshot%202019-11-12%20at%208.53.57%20PM.jpg
Sent from my ASUS Chromebook Flip C302 using Tapatalk


User avatar
garyan2

Posts: 3837
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#7

Post by garyan2 » Wed Nov 13, 2019 3:56 am

Gripweed wrote:
Wed Nov 13, 2019 3:22 am
Gary, this has got me thinking. Is there any way that the "NEW" symbol can be added to the WMC Guide like how Emby has it below?
The answer is yes, but probably not by me. There is another project out there, ModernMedia UI+ which does a whole lot of WMC guide enhancements. One of those is the "NEW" indicator. I haven't researched how to add something like that, yet.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Gripweed

Posts: 34
Joined: Sun Feb 03, 2013 6:35 pm
Location:

HTPC Specs: Show details

#8

Post by Gripweed » Wed Nov 13, 2019 6:42 am

Thanks for the suggestion. I just gave it a try and it has potential. Since I use WMC mostly as a DVR and not as a library or player I really don't need most of its features and turned them off. I need more time to play with it because I can't seem to get any displays that aren't basically black or white. It's very distracting not to see WMC in blue.

Post Reply