EPG123 Setup Help

An evolving, supported alternative to Rovi
Forum rules
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf
User avatar
garyan2

Posts: 3835
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

Re: EPG123 Setup Help

#41

Post by garyan2 » Sun Nov 10, 2019 7:57 pm

All right, everybody. Let's be civil.

I'm more interested in if there is anyone else out there using Media Portal as well and has experienced some issues or irregularities.

To the admins: Could we break off this thread from entry #20 and create a new one? Possibly titled "EPG123 Setup and Media Portal" or something like that. Thank you.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

adam1991

Posts: 2678
Joined: Sat Jun 11, 2011 2:31 pm
Location:

HTPC Specs: Show details

#42

Post by adam1991 » Sun Nov 10, 2019 8:30 pm

gzarzycki wrote:
Sun Nov 10, 2019 4:21 pm
Please don't question my experience.
After this train wreck?

Not to worry. We have no more questions about your experience.

User avatar
gzarzycki

Posts: 32
Joined: Fri Nov 08, 2019 9:44 pm
Location: Tucson, AZ.

HTPC Specs: Show details

#43

Post by gzarzycki » Sun Nov 10, 2019 9:00 pm

adam1991 wrote:
Sun Nov 10, 2019 8:30 pm
gzarzycki wrote:
Sun Nov 10, 2019 4:21 pm
Please don't question my experience.
After this train wreck?

Not to worry. We have no more questions about your experience.
Great, have a nice day!
Gary
CEO Network Automation Ltd. (Retired)

User avatar
gzarzycki

Posts: 32
Joined: Fri Nov 08, 2019 9:44 pm
Location: Tucson, AZ.

HTPC Specs: Show details

#44

Post by gzarzycki » Sun Nov 10, 2019 9:02 pm

garyan2 wrote:
Sun Nov 10, 2019 7:57 pm
All right, everybody. Let's be civil.

I'm more interested in if there is anyone else out there using Media Portal as well and has experienced some issues or irregularities.

To the admins: Could we break off this thread from entry #20 and create a new one? Possibly titled "EPG123 Setup and Media Portal" or something like that. Thank you.
Sounds good to me Gary. Thanks again and have a good one

adam1991

Posts: 2678
Joined: Sat Jun 11, 2011 2:31 pm
Location:

HTPC Specs: Show details

#45

Post by adam1991 » Sun Nov 10, 2019 9:39 pm

gzarzycki wrote:
Sun Nov 10, 2019 9:00 pm
adam1991 wrote:
Sun Nov 10, 2019 8:30 pm
gzarzycki wrote:
Sun Nov 10, 2019 4:21 pm
Please don't question my experience.
After this train wreck?

Not to worry. We have no more questions about your experience.
Great, have a nice day!
Gary
CEO Network Automation Ltd. (Retired)
You too!
Adam
CEO, Planet Earth
CFO, Gamma Quadrant

User avatar
gzarzycki

Posts: 32
Joined: Fri Nov 08, 2019 9:44 pm
Location: Tucson, AZ.

HTPC Specs: Show details

#46

Post by gzarzycki » Mon Nov 11, 2019 6:04 pm

Gary,

First, not sure if this is the correct forum for this question, as it was a setup issue, but also a guide issue?

When I setup the last PC with epg123, a Win 7 Ultimate with WMC, it appeared to setup fine, (see log below). But when I went into WMC, the channels were there and tuner worked, but no guide nor icons. In the log it says "Successful" and "Completed". In the log is there anything that tells me if it did install the guide into WMC Successfully ? I seen somewhere where other users have seen this issue happen. I did run the Event again then it installed, but I worry that it will not update automatically and I might not realize this and loose upcoming DVR entries. If there is no check and log entry to verify the guide was installed into WMC successfully could a sub routine be added in your program to check to see if the guide was installed correctly into WMC?

Thanks,
Gary

11/10/2019 11:30:00 PM] ===============================================================================
[11/10/2019 11:30:00 PM] Beginning epg123 client execution. version 1.2.22.0
[11/10/2019 11:30:00 PM] ===============================================================================
[11/10/2019 11:30:00 PM] [ INFO] Beginning epg123 client execution. 2019-11-11 06:30:00Z
[11/10/2019 11:30:00 PM] [ INFO] Import: True , Match: True , NoLogo: False , Force: False , ShowProgress: False
[11/10/2019 11:30:01 PM] Entering importMxfFile() for file "\\exodus\c\programdata\garyan2\epg123\output\epg123.mxf"
[11/10/2019 11:35:57 PM] [ INFO] Successfully imported .mxf file into Media Center database. Exit code: 0
[11/10/2019 11:35:57 PM] Exiting importMxfFile(). SUCCESS.
[11/10/2019 11:36:00 PM] [ INFO] Completed the automatch of lineup stations to tuner channels.
[11/10/2019 11:36:00 PM] [ INFO] Completed lineup refresh.
[11/10/2019 11:36:00 PM] Entering runWmcTask(ReindexSearchRoot)
[11/10/2019 11:36:00 PM] [ INFO] SUCCESS: Attempted to run the scheduled task "Microsoft\Windows\Media Center\ReindexSearchRoot".
[11/10/2019 11:36:00 PM] [ INFO] Successfully started the ReindexSearchRoot task. Exit code: 0
[11/10/2019 11:36:00 PM] Exiting runWmcTask(ReindexSearchRoot). SUCCESS.
[11/10/2019 11:36:00 PM] Entering runWmcTask(PvrScheduleTask)
[11/10/2019 11:36:00 PM] [ INFO] SUCCESS: Attempted to run the scheduled task "Microsoft\Windows\Media Center\PvrScheduleTask".
[11/10/2019 11:36:00 PM] [ INFO] Successfully started the PvrScheduleTask task. Exit code: 0
[11/10/2019 11:36:00 PM] Exiting runWmcTask(PvrScheduleTask). SUCCESS.
[11/10/2019 11:36:02 PM] [ INFO] Completed EPG123 client execution.
[11/10/2019 11:36:02 PM] [ INFO] EPG123 client execution time was 00:06:01.3122347.

User avatar
garyan2

Posts: 3835
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#47

Post by garyan2 » Mon Nov 11, 2019 6:08 pm

Everything worked, but I see you don't have the option to automatically match enabled. Open the client and click the Match by: [# Number] button. That should take care of it.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

User avatar
garyan2

Posts: 3835
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#48

Post by garyan2 » Mon Nov 11, 2019 6:23 pm

My bad. I was trying to read this in the sun on my phone. You do have automatch enabled. If you open the client, do you see anything on the right side?
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

User avatar
gzarzycki

Posts: 32
Joined: Fri Nov 08, 2019 9:44 pm
Location: Tucson, AZ.

HTPC Specs: Show details

#49

Post by gzarzycki » Mon Nov 11, 2019 6:31 pm

garyan2 wrote:
Mon Nov 11, 2019 6:23 pm
My bad. I was trying to read this in the sun on my phone. You do have automatch enabled. If you open the client, do you see anything on the right side?
Yes, the client showed the proper channels on both sides. Everything ran fine on the install, looked like all went fine, then no guide. But, as I mentioned, I went into the Event Scheduler and manual ran of the update and then there was a guide and icons. Maybe just a fluke that happened but I suspect all is fine after the run of the event.

Thanks,
Gary

User avatar
garyan2

Posts: 3835
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#50

Post by garyan2 » Mon Nov 11, 2019 6:44 pm

Take a look at the trace.log file and it shows you when the channels were matched. EPG123 will know if the import was successful or not.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

User avatar
gzarzycki

Posts: 32
Joined: Fri Nov 08, 2019 9:44 pm
Location: Tucson, AZ.

HTPC Specs: Show details

#51

Post by gzarzycki » Mon Nov 11, 2019 10:14 pm

garyan2 wrote:
Mon Nov 11, 2019 6:44 pm
Take a look at the trace.log file and it shows you when the channels were matched. EPG123 will know if the import was successful or not.
Which entry in the log shows that it was successful ? The log said Successful but it didn't write the guide to WMC.

User avatar
garyan2

Posts: 3835
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#52

Post by garyan2 » Mon Nov 11, 2019 10:26 pm

gzarzycki wrote:
Mon Nov 11, 2019 10:14 pm
Which entry in the log shows that it was successful ? The log said Successful but it didn't write the guide to WMC.

Code: Select all

[11/10/2019 11:30:01 PM] Entering importMxfFile() for file "\\exodus\c\programdata\garyan2\epg123\output\epg123.mxf"
[11/10/2019 11:35:57 PM] [ INFO] Successfully imported .mxf file into Media Center database. Exit code: 0
[11/10/2019 11:35:57 PM] Exiting importMxfFile(). SUCCESS.
If this goes good, it means the MXF file was properly formatted (which has never been an issue), and it was imported successfully into the database. If it was not successful, there would have been an ERROR entry with the exception message and the status bug in WMC will be a big RED 'X' to tell you something happened.

Regardless of what you think happened, it wrote to the guide without any issue if you didn't see any errors in the log file. Was WMC open when the initial import was run?

In the trace.log file, you will see entries for each and every channel/station match that was done and when. Was it your initial run, or did it not happen until later? Seeing more of the log will help.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

adam1991

Posts: 2678
Joined: Sat Jun 11, 2011 2:31 pm
Location:

HTPC Specs: Show details

#53

Post by adam1991 » Thu Dec 05, 2019 3:10 am

gzarzycki wrote:
Sat Nov 09, 2019 12:37 am
garyan2 wrote:
Fri Nov 08, 2019 11:46 pm
stated
Okay, I suppose I need to figure out this myself, and maybe write some software that works. Your loss.
I'm following up to see how that worked out for you.

RyC

Posts: 697
Joined: Tue Aug 21, 2012 10:21 pm
Location:

HTPC Specs: Show details

#54

Post by RyC » Thu Dec 05, 2019 4:22 am

adam1991 wrote:
Thu Dec 05, 2019 3:10 am
gzarzycki wrote:
Sat Nov 09, 2019 12:37 am
garyan2 wrote:
Fri Nov 08, 2019 11:46 pm
stated
Okay, I suppose I need to figure out this myself, and maybe write some software that works. Your loss.
I'm following up to see how that worked out for you.
Pretty well I'd say: viewtopic.php?f=99&t=12516

Post Reply