Episode/Season info as a separate filename pattern?

An evolving, supported alternative to Rovi
Forum rules
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf
Post Reply
tuna_ertemalp

Posts: 14
Joined: Wed Mar 16, 2016 8:19 pm
Location:

HTPC Specs: Show details

Episode/Season info as a separate filename pattern?

#1

Post by tuna_ertemalp » Sun Oct 06, 2019 5:45 pm

Just like others, just now started using EPG123, and am rather happy on Win7 with Ceton 4-tuner card! Did a bunch of WMC Tweaks, too. A little request/suggestion: I love the SxxExx data in the show title & description, and included them in the recorded filename. But I am really only interested in having the SxxExx in the filename, not the whole episode title which already goes into the EpisodeName property of the file. There doesn't seem to be a filename pattern to do that. It'd be great to have that as a, say, %SE pattern, or even better (if possible) as separate %S and %E.

Thanks for listening!
Tuna

PS: As a side note, the setup instructions PDF should probably be updated. Nothing major, but at times the written steps did not exactly match what was happening. I survived through it by paying attention, but a fresh run through it by the writer might be useful to the masses that will soon come to EPG123. Sadly I didn't keep notes while going through it.
-- Tuna

User avatar
garyan2

Posts: 3609
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#2

Post by garyan2 » Sun Oct 06, 2019 5:58 pm

tuna_ertemalp wrote:
Sun Oct 06, 2019 5:45 pm
Just like others, just now started using EPG123, and am rather happy on Win7 with Ceton 4-tuner card! Did a bunch of WMC Tweaks, too. A little request/suggestion: I love the SxxExx data in the show title & description, and included them in the recorded filename. But I am really only interested in having the SxxExx in the filename, not the whole episode title which already goes into the EpisodeName property of the file. There doesn't seem to be a filename pattern to do that. It'd be great to have that as a, say, %SE pattern, or even better (if possible) as separate %S and %E.
Unfortunately, I have no control over that. The options that are available are registry tweaks that MS provided with WMC, and Season/Episode was not one of them. The only way to get sXXeYY in the filename is to prefix the episode title with SE info, and add the episode title to the filename pattern. This is actually what I did for a long time.
tuna_ertemalp wrote:
Sun Oct 06, 2019 5:45 pm
PS: As a side note, the setup instructions PDF should probably be updated. Nothing major, but at times the written steps did not exactly match what was happening. I survived through it by paying attention, but a fresh run through it by the writer might be useful to the masses that will soon come to EPG123. Sadly I didn't keep notes while going through it.
Yah, the PDF is about to be retired. I'm building up the website with the instructions and they are pretty much up-to-date (because it required a fresh run through). Take a look. I am trying to quickly get to a point where the pdf will no longer be part of the setup program.

Thank you very much for your feedback. It definitely helps to see other perspectives in making this a better product.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

User avatar
garyan2

Posts: 3609
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#3

Post by garyan2 » Sun Oct 06, 2019 6:32 pm

Just a side note, because it is related. There are a couple more patterns MS provides that I can add, but more importantly I see that I had an error in assuming what the default was. I'll get that fixed in the next update.

Thanks.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

User avatar
garyan2

Posts: 3609
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#4

Post by garyan2 » Sun Oct 06, 2019 8:09 pm

Here is what the tweak form will update to. There is one more pattern that WMC allows, and the is "%Ca" for the network affiliation. Most of the affiliates are blank and are usually only for the OTA stations. I didn't see a reason to include it.
filenamePattern.PNG
filenamePattern.PNG (9.93 KiB) Viewed 261 times
To get anything more, we would have to modify and recompile the Microsoft mcepg.dll file which is a bit outside my wheelhouse. Maybe after January 2020, after we see what WMC looks like after MS drops the guide service, I might research that.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

tuna_ertemalp

Posts: 14
Joined: Wed Mar 16, 2016 8:19 pm
Location:

HTPC Specs: Show details

#5

Post by tuna_ertemalp » Tue Oct 08, 2019 2:06 am

Thanks, Gary!

I looked at the screenshot video you have, and it looks good. I had installed for cable, so some steps are different.

One main thing I remember is that after clicking "Save & Execute" the first time that dialog presented itself during initial setup, it actually complained that there was no scheduled task to run. So, I think I had to create one and run that. Sorry my memory is foggy on that.

And, for the rest of the day, even though I ran the task manually & successfully, the EPG info icon in WMC kept being the yellow "!" one. But the next day, after EPG task was executed by the Task Manager overnight, the info icon turned green.

Another thing I just noticed by looking at "About Guide Listings" in WMC, my data expires on Oct 24 5pm that was downloaded on Oct 7 4:30am, which is 17.5 days despite the fact that my config setting is 21 days; I am guessing this is a WMC limitation on the max guide length or SD limit for the data they return.

And, I just now quickly scanned through the web pages replacing the PDF: In http://epg123.garyan2.net/install/step2/, it says click on Step2. However, since you have the "Automatically proceed to next step" on by default, that click happens automatically. That was a wee bit jarring for me, like "wait, what is going on" until I saw the status in the dialog saying that EPG is waiting for WMC to be closed by the user, and that the AutoNextStep was already selected for me. So, you might want to mention somewhere early in the doc of this automatic advance of steps, unless it is there and I missed it.

And the fact that my Movies tab doesn't show the movie icons is a US market copyright issue? I remember seeing something somewhere that it works for non-USA markets, but I tried again nevertheless since I saw them in your screen video. Nope. I got no movie posters. :(

Thanks for the great work! Much appreciated...

Tuna
-- Tuna

User avatar
garyan2

Posts: 3609
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#6

Post by garyan2 » Tue Oct 08, 2019 2:23 am

tuna_ertemalp wrote:
Tue Oct 08, 2019 2:06 am
One main thing I remember is that after clicking "Save & Execute" the first time that dialog presented itself during initial setup, it actually complained that there was no scheduled task to run. So, I think I had to create one and run that. Sorry my memory is foggy on that.
The latest release no longer does that. It didn't require you to create the task, it was just a friendly reminder... in other words, a nag. So I got rid of it.
tuna_ertemalp wrote:
Tue Oct 08, 2019 2:06 am
And, for the rest of the day, even though I ran the task manually & successfully, the EPG info icon in WMC kept being the yellow "!" one. But the next day, after EPG task was executed by the Task Manager overnight, the info icon turned green.
If you look in the trace.log file ([View Log] button), and search for '[WARNG]', you will find what the yellow icon was about. It was probably a station schedule had an error, or a hash code didn't match. As you can see, those problems are typically temporary.
tuna_ertemalp wrote:
Tue Oct 08, 2019 2:06 am
Another thing I just noticed by looking at "About Guide Listings" in WMC, my data expires on Oct 24 5pm that was downloaded on Oct 7 4:30am, which is 17.5 days despite the fact that my config setting is 21 days; I am guessing this is a WMC limitation on the max guide length or SD limit for the data they return.
About a year ago, 21 days was the typical maximum number of days we could get from SD. I think earlier this year that dropped down to 17/18 which is still greater than the 14 days SD softly guarantees for US customers. WMC can handle as many days as we feed it, as far as I know. Having a setting of 21 really just means "Give me as much data as you can". :)
tuna_ertemalp wrote:
Tue Oct 08, 2019 2:06 am
And, I just now quickly scanned through the web pages replacing the PDF: In http://epg123.garyan2.net/install/step2/, it says click on Step2. However, since you have the "Automatically proceed to next step" on by default, that click happens automatically. That was a wee bit jarring for me, like "wait, what is going on" until I saw the status in the dialog saying that EPG is waiting for WMC to be closed by the user, and that the AutoNextStep was already selected for me. So, you might want to mention somewhere early in the doc of this automatic advance of steps, unless it is there and I missed it.
Yah, I'll probably throw in an "If xxxxxx is not automatically opened, click the yyyyyy button" verbiage in there.
tuna_ertemalp wrote:
Tue Oct 08, 2019 2:06 am
And the fact that my Movies tab doesn't show the movie icons is a US market copyright issue? I remember seeing something somewhere that it works for non-USA markets, but I tried again nevertheless since I saw them in your screen video. Nope. I got no movie posters. :(
From the client, click the [Tweak WMC] button. See if the "Enable Movie Guide (non-US/UK/CA users)" button is enabled. If so, click it. That should activate the Movie guide. Let me know, please. You will be the first to verify for me that it works.

Thanks so much for your feedback. It is greatly appreciated.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

tuna_ertemalp

Posts: 14
Joined: Wed Mar 16, 2016 8:19 pm
Location:

HTPC Specs: Show details

#7

Post by tuna_ertemalp » Tue Oct 08, 2019 9:04 pm

garyan2 wrote:
Tue Oct 08, 2019 2:23 am
tuna_ertemalp wrote:
Tue Oct 08, 2019 2:06 am
And the fact that my Movies tab doesn't show the movie icons is a US market copyright issue? I remember seeing something somewhere that it works for non-USA markets, but I tried again nevertheless since I saw them in your screen video. Nope. I got no movie posters. :(
From the client, click the [Tweak WMC] button. See if the "Enable Movie Guide (non-US/UK/CA users)" button is enabled. If so, click it. That should activate the Movie guide. Let me know, please. You will be the first to verify for me that it works.
Sadly, the ENABLE button along with the "Enable Movie Guide (non-US/UK/CA users)" text is grayed out. I'm guessing that is because I am in WA/USA.

Tuna
-- Tuna

tuna_ertemalp

Posts: 14
Joined: Wed Mar 16, 2016 8:19 pm
Location:

HTPC Specs: Show details

#8

Post by tuna_ertemalp » Tue Oct 08, 2019 9:20 pm

And, even though I am deviating from the title of this thread, the ability of EPG to auto-update itself might be nice to have. At the very least, the EPG status icon in WMC could have a 4th version or some sort of indicator overlaid on the existing 3 versions (i.e. resulting in 6 versions) to indicate that there is an update available to install.
-- Tuna

User avatar
garyan2

Posts: 3609
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#9

Post by garyan2 » Tue Oct 08, 2019 9:26 pm

tuna_ertemalp wrote:
Tue Oct 08, 2019 9:04 pm
Sadly, the ENABLE button along with the "Enable Movie Guide (non-US/UK/CA users)" text is grayed out. I'm guessing that is because I am in WA/USA.
Well, that's weird. To enable it, it is just a registry tweak but there must be something different about how you set up WMC or maybe your OS.

The registry entry is:
HKLM\Software\Microsoft\Windows\CurrentVersion\Media Center\Settings\MCE.GlobalSettings
"SystemGeoISO2" : should be "US"

The fact that the button is grayed out means it is set to "US", "CA", or "GB". When you set up TV in WMC, did you do anything different than typical? Is your OS for a different country?

EDIT: in the registry, what is your "systemGeoID"?
Last edited by garyan2 on Tue Oct 08, 2019 9:33 pm, edited 1 time in total.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

User avatar
garyan2

Posts: 3609
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#10

Post by garyan2 » Tue Oct 08, 2019 9:27 pm

tuna_ertemalp wrote:
Tue Oct 08, 2019 9:20 pm
And, even though I am deviating from the title of this thread, the ability of EPG to auto-update itself might be nice to have. At the very least, the EPG status icon in WMC could have a 4th version or some sort of indicator overlaid on the existing 3 versions (i.e. resulting in 6 versions) to indicate that there is an update available to install.
Already done. If there is an update available, the status icon will have a '+' sign on the top right.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

tuna_ertemalp

Posts: 14
Joined: Wed Mar 16, 2016 8:19 pm
Location:

HTPC Specs: Show details

#11

Post by tuna_ertemalp » Tue Oct 08, 2019 9:38 pm

garyan2 wrote:
Tue Oct 08, 2019 9:26 pm
tuna_ertemalp wrote:
Tue Oct 08, 2019 9:04 pm
Sadly, the ENABLE button along with the "Enable Movie Guide (non-US/UK/CA users)" text is grayed out. I'm guessing that is because I am in WA/USA.
Well, that's weird. To enable it, it is just a registry tweak but there must be something different about how you set up WMC or maybe your OS.

The registry entry is:
HKLM\Software\Microsoft\Windows\CurrentVersion\Media Center\Settings\MCE.GlobalSettings
"SystemGeoISO2" : should be "US"

The fact that the button is grayed out means it is set to "US", "CA", or "GB". When you set up TV in WMC, did you do anything different than typical? Is your OS for a different country?
It is [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Media Center\Settings\MCE.GlobalSettings] "systemGeoISO2"="US"

My Win7 Ultimate (6.1 Build 7601 SP1) is English/US.

In TV setup in WMC, I only chose my ZIP in WA/USA.
-- Tuna

User avatar
garyan2

Posts: 3609
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#12

Post by garyan2 » Tue Oct 08, 2019 9:46 pm

The I don't see a reason why you don't have it enabled already. Was it enabled when you were using the MS/Rovi guide?
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

tuna_ertemalp

Posts: 14
Joined: Wed Mar 16, 2016 8:19 pm
Location:

HTPC Specs: Show details

#13

Post by tuna_ertemalp » Tue Oct 08, 2019 9:51 pm

garyan2 wrote:
Tue Oct 08, 2019 9:27 pm
tuna_ertemalp wrote:
Tue Oct 08, 2019 9:20 pm
And, even though I am deviating from the title of this thread, the ability of EPG to auto-update itself might be nice to have. At the very least, the EPG status icon in WMC could have a 4th version or some sort of indicator overlaid on the existing 3 versions (i.e. resulting in 6 versions) to indicate that there is an update available to install.
Already done. If there is an update available, the status icon will have a '+' sign on the top right.
Cool! I have 1.2.18.0 installed and I don't see the '+' on my green status icon today given that there is a 1.2.18.10. Maybe it was released AFTER my daily EPG update ran at 04:35-04:40 PDT. If so, I should see it tomorrow.
-- Tuna

tuna_ertemalp

Posts: 14
Joined: Wed Mar 16, 2016 8:19 pm
Location:

HTPC Specs: Show details

#14

Post by tuna_ertemalp » Tue Oct 08, 2019 9:59 pm

garyan2 wrote:
Tue Oct 08, 2019 9:46 pm
The I don't see a reason why you don't have it enabled already. Was it enabled when you were using the MS/Rovi guide?
Just to be clear: in WMC, I do have the "Movies" tab. Under it, I have Movie Library, Movie Guide, Search etc. Clicking the Movie Library gives me just the movie titles of all my movie recording, not the movie icon carousel. Similarly under Movie Guide. Actually, when I first click on Movie Guide, I get an alert with "MOVIE DATA NOT AVAILABLE Some of the movie data may not be available because either WMC cannot connect to the Internet or Automatic DOwnload option to retrieve movie data is not enabled." and OK on that brings me to a title-only guide. I am sure I was seeing the movie flyer icon carousel before.

And, the WMC Tweak button is disabled in the EPG dialog.

If you wanted to give me a debug EXE (or DLL) I can drop in to see why the ENABLE button along with its title are disabled in your dialog, I'd be happy to run it.

Tuna
-- Tuna

User avatar
garyan2

Posts: 3609
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#15

Post by garyan2 » Tue Oct 08, 2019 10:09 pm

tuna_ertemalp wrote:
Tue Oct 08, 2019 9:51 pm
Cool! I have 1.2.18.0 installed and I don't see the '+' on my green status icon today given that there is a 1.2.18.10. Maybe it was released AFTER my daily EPG update ran at 04:35-04:40 PDT. If so, I should see it tomorrow.
In this case, it won't give an update indicator. It only compare the first 3 level values (1.2.18). I created a .10 version simply because it was a minor improvement to the client setup and has no impact to current users of 1.2.18.0. When I bump to 1.2.19 or above, then you will get that indicator.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

tuna_ertemalp

Posts: 14
Joined: Wed Mar 16, 2016 8:19 pm
Location:

HTPC Specs: Show details

#16

Post by tuna_ertemalp » Tue Oct 08, 2019 10:12 pm

tuna_ertemalp wrote:
Tue Oct 08, 2019 9:59 pm
And, the WMC Tweak button is disabled in the EPG dialog.
Oh, I get it now. Your button is disabled since the regkey already has the correct value. And, why the regvalue is not resulting in the showing of movie icon carousel in WMC is the mystery. D'oh!

Tuna
-- Tuna

User avatar
garyan2

Posts: 3609
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#17

Post by garyan2 » Tue Oct 08, 2019 10:26 pm

tuna_ertemalp wrote:
Tue Oct 08, 2019 9:59 pm
Just to be clear....
Ah, sorry, we were talking about 2 different things. In the movie library, can you right-click the list and change the view? Options should be 'View Large', 'View Small', 'View List'.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

tuna_ertemalp

Posts: 14
Joined: Wed Mar 16, 2016 8:19 pm
Location:

HTPC Specs: Show details

#18

Post by tuna_ertemalp » Tue Oct 08, 2019 10:35 pm

garyan2 wrote:
Tue Oct 08, 2019 10:26 pm
tuna_ertemalp wrote:
Tue Oct 08, 2019 9:59 pm
Just to be clear....
Ah, sorry, we were talking about 2 different things. In the movie library, can you right-click the list and change the view? Options should be 'View Large', 'View Small', 'View List'.
OMG. I had no idea. How embarrassing... Thank you!!
-- Tuna

User avatar
garyan2

Posts: 3609
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#19

Post by garyan2 » Wed Oct 09, 2019 1:36 am

:lol: :thumbup:
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post Reply