Guide Data not Updating

An evolving, supported alternative to Rovi
Forum rules
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf
Post Reply
ScottRobert

Posts: 3
Joined: Wed Aug 28, 2019 11:33 am
Location:

HTPC Specs: Show details

Guide Data not Updating

#1

Post by ScottRobert » Wed Aug 28, 2019 12:23 pm

On 8/14/19 my guide data stopped updating. My Xbox accesses the media center computer daily but is not logged into for months at a time. I'm getting Exit: 0x8007051F. I unsuccessfully tried two things. I deleted and rescheduled the task and updated from version 1.2.10 to 1.2.15. I'm stuck and would greatly appreciate any suggestions.

User avatar
StinkyImp

Posts: 202
Joined: Thu May 11, 2017 7:53 pm
Location:

HTPC Specs: Show details

#2

Post by StinkyImp » Wed Aug 28, 2019 12:48 pm

ScottRobert wrote:
Wed Aug 28, 2019 12:23 pm
On 8/14/19 my guide data stopped updating... I'm stuck and would greatly appreciate any suggestions.
The best place to start is by looking at (or uploading) your "trace.log" file.

You can view it in the EPG123 Client as shown here.

User avatar
garyan2

Posts: 3748
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#3

Post by garyan2 » Wed Aug 28, 2019 3:03 pm

I'm not sure you'll see anything in the trace.log file. The exit code is a Scheduled Task error, so EPG123 never executes.

If you open Task Scheduler, select epg123_update, and then command it to Run, does it execute?

If you open EPG123 manually and click the [Save&Execute] button, it should update but that is just bypassing the task.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

ScottRobert

Posts: 3
Joined: Wed Aug 28, 2019 11:33 am
Location:

HTPC Specs: Show details

#4

Post by ScottRobert » Thu Aug 29, 2019 1:48 am

What a prompt response!

The trace.log file showed nothing during the outage.

epg123_update was able to execute when I manually selected run. It's the only task on the computer.

I'll update if epg123_update automatically executes at 4am.

Thank you!

User avatar
garyan2

Posts: 3748
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#5

Post by garyan2 » Thu Aug 29, 2019 3:02 am

This sounds like a permission problem. Is your task set to "Run whether user is logged on or not"? If not, then that is probably your issue.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

ScottRobert

Posts: 3
Joined: Wed Aug 28, 2019 11:33 am
Location:

HTPC Specs: Show details

#6

Post by ScottRobert » Thu Aug 29, 2019 12:14 pm

epg12_update automatically updated at 4am this morning without errors. The task was already set to "Run whether user is logged on or not". I'm optimistic you fixed it. If I ever get the error code again, I'll follow your suggestions and execute the task manually.

Thanks again!

Post Reply