"Failed to retrieve netttv"

An evolving, supported alternative to Rovi
Forum rules
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf
Post Reply
mpalandr

Posts: 8
Joined: Mon Feb 29, 2016 4:52 pm
Location:

HTPC Specs: Show details

"Failed to retrieve netttv"

#1

Post by mpalandr » Sun Mar 17, 2019 6:20 pm

I am halfway into my second year of using EPG123, and it has worked flawlessly until now.

Around March 1, I heard about a new TV program I wanted to record that airs April 1. After a few days I searched for it in WMC, it wasn't there yet, which was not a surprise. Yesterday, March 16, I searched for it again, didn't find it, and noticed my guide only goes out until around 0100 on April 1, normally I have 21 days.

I'm running Windows 7. In the event log, which only goes back to March 6, every MCUpdate attempt results in an (!) Error: "Failed to retrieve nettv (Error: PackageName is invalid.)

I saw there was a new version of EPG123 available, so I installed it yesterday, v1.2.11.0.

I ran EPG123 Configuration v1.2.11 as admin

Checking the trace.log from last night's scheduled update at 0300, I see:

[ERROR] Unhandled exception caught from epg123.exe. message: Object reference not set to an instance of an object.

and a four minutes later:

[ERROR] Failed to locate any lineups from EPG123.

At this point, I clicked the Save & Execute button and let it process.

I ran a manual schedule update from within WMC, the trace.log contained no errors, but Event Viewer still shows the "Failed to retrieve nettv" error, and the guide only goes out to April 3 still considerably short of the 21 days it's configured to retrieve.

So, I did pick up two days, but something's still not right.

Any help on these errors would be appreciated.

Thanks!

stuartm

Posts: 359
Joined: Mon Nov 05, 2012 8:05 pm
Location: Longmont, CO

HTPC Specs: Show details

#2

Post by stuartm » Sun Mar 17, 2019 9:39 pm

The "failed to retrieve nettv" is because the manual guide update in WMC does not run the EPG123 guide update software it only runs the old Microsoft guide update and since you are not using it the only thing that happens is that the long ago abandoned nettv component of WMC fails it's update since it no longer exists. You need to manually run EPG123 outside of WMC to do a manual guide update. Depending on what version of EPG123 you updated from/to you may need to delete your old scheduled update task and re-create it. As to not getting 21 days of data see this thread:
viewtopic.php?f=99&t=12128

mpalandr

Posts: 8
Joined: Mon Feb 29, 2016 4:52 pm
Location:

HTPC Specs: Show details

#3

Post by mpalandr » Sun Mar 17, 2019 10:34 pm

Thanks stuartm.

I ran the scheduled task that runs EPG123.exe and the trace.log shows no errors. I am still a bit concerned about the unhandled exception that occurred yesterday, but won't sweat it if it does not recur.

On the other hand, it is still only downloading about 15 1/2 days of guide at this point, but there's another post here in the forum that suggests that may be the new normal.

Anyone that may be reading, are you able to get the full 21 days?

User avatar
garyan2

Posts: 3436
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#4

Post by garyan2 » Mon Mar 18, 2019 1:20 am

It looks like 17 days is all we are getting right now. Maybe I'll send an email to SD to confirm this is intended. They have always said US customers will get 13-14 days minimum and up to 21-24 days possible.

The error you got appears to be due to a crash of your WMC database. The "Failed to locate any lineups from EPG123" error is from when epg123 opens the database to find an imported EPG123 lineup. Not finding means you probably had a crash of the database, or something else critical.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

Post Reply