Page 1 of 2

I'm Still on 1.0.1! What am I in for if I want to Upgrade?

Posted: Fri Feb 15, 2019 11:15 pm
by kmp14
So I have been on 1.0.1 since it was released. It is working perfectly for me, not a single glitch or issue.

Anyway, I am considering adding a OTA tuner to my setup, which is currently only Cable Card tuners. I figured it might make sense to upgrade Epg123 if I do add the OTA tuner.
  • If I want to just stay on 1.0.1, do the instructions for setup still apply? I would assume no.
    If I upgrade to the latest, will I lose my Series and or invalidate my recording history?
    Is it fair to even ask these questions since I let my version get so old?
Any thoughts would be appreciated!

Re: I'm Still on 1.0.1! What am I in for if I want to Upgrade?

Posted: Fri Feb 15, 2019 11:33 pm
by garyan2
Wow, a lot has happened since then, but upgrading should not be an issue since you will have to do TV Setup in WMC again to add the new tuners. If we limit the upgrade to just doing TV Setup, and not doing a clean start, all your series recording history will be just fine and your recording requests will still work.

When do you plan on doing this ... I'll have to set up a virtual machine and do an upgrade from 1.0.1 to 1.2.11 to see if there are any gotchas I can't think of right now.

Re: I'm Still on 1.0.1! What am I in for if I want to Upgrade?

Posted: Fri Feb 15, 2019 11:48 pm
by kmp14
Thanks Gary! I am not ready to upgrade just yet, but when I am I will be bothering you!

Re: I'm Still on 1.0.1! What am I in for if I want to Upgrade?

Posted: Tue Feb 19, 2019 6:07 am
by artm
I'm ready to do it now and started to but with an issue:

1. going from 1.02 to 1.2.11, Win7 SP1
2. copied 1.2.11 portable contents to old version
3. copied epg123utility.exe to old version
4. ran epg123utility.exe by link and DOS prompt with admin privileges

Got an error each time, details below:

====================================================
Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\>cd program files (x86)

C:\Program Files (x86)>cd epg123

C:\Program Files (x86)\EPG123>epg123utility
Requesting Token from Schedules Direct ...

Unhandled Exception: System.IO.FileLoadException: Could not load file or assembly 'Newtonsoft.Json, Version=8.0.0.0, Cul
ture=neutral, PublicKeyToken=30ad4fe6b2a6aeed' or one of its dependencies. The located assembly's manifest definition do
es not match the assembly reference. (Exception from HRESULT: 0x80131040)
at epg123.sdApi.SdApi.sdGetToken(String username, String passwordHash)
at epg123.sdJson2mxf..ctor(epgConfig configuration)
at epg123.Program.Main(String[] args)


====================================================
Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: epg123utility.exe
Problem Signature 02: 1.1.0.0
Problem Signature 03: 58b1ebcc
Problem Signature 04: epg123utility
Problem Signature 05: 1.1.0.0
Problem Signature 06: 58b1ebcc
Problem Signature 07: 61
Problem Signature 08: 4a
Problem Signature 09: System.IO.FileLoadException
OS Version: 6.1.7600.2.0.0.256.1
Locale ID: 1033
Additional Information 1: 82e2
Additional Information 2: 82e23b36efee975bd0e9417ff09fe7bb
Additional Information 3: ada2
Additional Information 4: ada28aa9eb77ec36b2308f2a1746c7d1

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid= ... cid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt
====================================================

Re: I'm Still on 1.0.1! What am I in for if I want to Upgrade?

Posted: Tue Feb 19, 2019 2:32 pm
by garyan2
Since you have to run TV Setup again to add the new tuners, don't bother with the utility. That will all be taken care of.

When you copied the contents of the portable zip file, did you copy everything? We use a newer version of the Newtonsoft dll.

Re: I'm Still on 1.0.1! What am I in for if I want to Upgrade?

Posted: Tue Feb 19, 2019 3:00 pm
by artm
Yes, I copied all the files in the attached screenshot.

New dll version is 10.0.3.21018

Re: I'm Still on 1.0.1! What am I in for if I want to Upgrade?

Posted: Tue Feb 19, 2019 3:59 pm
by kmp14
garyan2 wrote:
Tue Feb 19, 2019 2:32 pm
Since you have to run TV Setup again to add the new tuners....
FYI Gary, that error question was not posted by me (I am the OP), not sure if Artm is adding tuners.

Re: I'm Still on 1.0.1! What am I in for if I want to Upgrade?

Posted: Tue Feb 19, 2019 4:22 pm
by garyan2
Oops... didn't even look.

@artm: I'll have to look at this closer later tonight. Though I don't think related to the current error, I think you will have problems running the portable version out of the Program Files (x86) folder. I'll check that out as well.

Re: I'm Still on 1.0.1! What am I in for if I want to Upgrade?

Posted: Tue Feb 19, 2019 4:33 pm
by artm
Yes, I meant to address that...I already have a fully functional system. So, no need to re-add tuners, etc..

Gary, about running the portable version in the x86 folder, I have always done that since the first version, on all my systems. Never an issue. Damn...epg123 is 64-bit, right? Don't know how I overlooked that.

Can I simply move it and correct the scheduled task? If, yes, I'd move it to c:\Prog folder.

Re: I'm Still on 1.0.1! What am I in for if I want to Upgrade?

Posted: Tue Feb 19, 2019 4:49 pm
by garyan2
artm wrote:
Tue Feb 19, 2019 4:33 pm
Yes, I meant to address that...I already have a fully functional system. So, no need to re-add tuners, etc..

Gary, about running the portable version in the x86 folder, I have always done that since the first version, on all my systems. Never an issue. Damn...epg123 is 64-bit, right? Don't know how I overlooked that.

Can I simply move it and correct the scheduled task? If, yes, I'd move it to c:\Prog folder.
It is 32-bit, but that isn't the issue. With the recent change to the installation package that is friendly to installing in the Program Files folder, when epg123 starts it will look for the configuration file and save all the output files in the ProgramData folder. It will not "see" your current cfg file or cache/logos folders. You can still proceed forward, but all the files will need to be relocated to the ProgramData folder (ProgramData\GaRyan2\epg123).

Re: I'm Still on 1.0.1! What am I in for if I want to Upgrade?

Posted: Tue Feb 19, 2019 5:14 pm
by artm
OK, step back...

1. I have another, new setup, Win7 x64, epg v1.2.11, portable installed in x86 folder. There are files in ProgramData, epg123 sees them and all works well. Am I good here or should I relocate epg to...? I assumed, like any typical portable program, I can install it anywhere. The beauty of portable is that all files are in the installation folder. Not so with epg123.

2. So, for my existing older setups: where should I install the portable? I'll wait for you to advise on the rest of the procedure. No rush.

Re: I'm Still on 1.0.1! What am I in for if I want to Upgrade?

Posted: Tue Feb 19, 2019 7:52 pm
by garyan2
artm wrote:
Tue Feb 19, 2019 5:14 pm
OK, step back...

1. I have another, new setup, Win7 x64, epg v1.2.11, portable installed in x86 folder. There are files in ProgramData, epg123 sees them and all works well. Am I good here or should I relocate epg to...? I assumed, like any typical portable program, I can install it anywhere. The beauty of portable is that all files are in the installation folder. Not so with epg123.

2. So, for my existing older setups: where should I install the portable? I'll wait for you to advise on the rest of the procedure. No rush.
The portable installation is truly portable except when placed in the Program Files folder. In this case, because EPG123 is unaware of how it ended up in the Program Files folder, it will assume it was installed there with the setup program and so uses the accepted method of storing dynamic files in the ProgramData folder.

If you want all files/folders to be co-located, then place the files from the portable zip file anywhere other than the Program Files folder. There is no other restriction.

Re: I'm Still on 1.0.1! What am I in for if I want to Upgrade?

Posted: Wed Feb 20, 2019 3:51 am
by garyan2
artm wrote:
Tue Feb 19, 2019 6:07 am
I'm ready to do it now and started to but with an issue:

1. going from 1.02 to 1.2.11, Win7 SP1
2. copied 1.2.11 portable contents to old version
3. copied epg123utility.exe to old version
4. ran epg123utility.exe by link and DOS prompt with admin privileges

Got an error each time, details below:
Okay, had to revisit my code for the utility program. It is referencing a specific version of the Newtonsoft dll which you had already copied over. Rather than grabbing an older version of the dll just to run the utility, it will probably be easier to just use the client to match the channels with the "new" stations.

Take a look here for a step-by-step.

Re: I'm Still on 1.0.1! What am I in for if I want to Upgrade?

Posted: Thu Feb 21, 2019 6:21 am
by artm
FYI:

NEW system is 1.2.11, fresh install
SECONDARY: 1.0.2, no recording schedule
PRIMARY: 1.0.2, has recording schedule

What I did was:

1. install portable 1.2.11 in NEW system, folder c:\prog
2. copied that folder to the SECONDARY system, not in its x86 folder but the same c:\prog folder

That worked, except...

3. I lost my favorite lineup, only the All lineup exists. The favorite was the same as in my PRIMARY system.

Now, how can I now do this:

4. restore favorite lineup from PRIMARY 1.0.2 to SECONDARY, now has 1.2.11
5. copy recording schedule from PRIMARY 1.0.2 to SECONDARY, now has 1.2.11

Once I do this and it's working, then I can update the PRIMARY to 1.2.11 by doing steps 1, 2 above and then just restoring favorite lineup and scheduled recordings (1.2.11 to 1.2.11).

Re: I'm Still on 1.0.1! What am I in for if I want to Upgrade?

Posted: Thu Feb 21, 2019 6:53 am
by garyan2
The favorite lineups are stored in the database and are backed up along with the tuner configurations. The problem is, right now I have no safe way to "transfer" the tuner configurations from one system to another. It will typically screw things up due to the GUID of the tuners being different between them.

There is however hope of being able to do that in the future; re: this post

Re: I'm Still on 1.0.1! What am I in for if I want to Upgrade?

Posted: Fri Feb 22, 2019 8:03 pm
by kmp14
Ok, I am getting close to wanting to try to upgrade from 1.0.1 and add my OTA tuners.

I am looking at the excellent Installation instructions on the Epg123 website. Here are my questions:

1. If I am prepared to just go ahead and do a Clean Start, can I just get the latest version and follow the instructions?
2. If yes to #1 above, am I able to get my Series recordings back by using the "Series Recordings Transfer Tool" or is that just for when the backup from the Clean Start is from Rovi?
3. Does the "Portable" install option just exist so that users don't have to install to the Program Files folder? (I realize that the answer to this must be on tGB somewhere, I will search after I post these questions)
4. Another "gotchas" if the answers to 1 and 2 are "Yes" and I go forward?

Thanks so much!

Re: I'm Still on 1.0.1! What am I in for if I want to Upgrade?

Posted: Sat Feb 23, 2019 12:04 am
by garyan2
kmp14 wrote:
Fri Feb 22, 2019 8:03 pm
Ok, I am getting close to wanting to try to upgrade from 1.0.1 and add my OTA tuners.

I am looking at the excellent Installation instructions on the Epg123 website. Here are my questions:

1. If I am prepared to just go ahead and do a Clean Start, can I just get the latest version and follow the instructions?
2. If yes to #1 above, am I able to get my Series recordings back by using the "Series Recordings Transfer Tool" or is that just for when the backup from the Clean Start is from Rovi?
3. Does the "Portable" install option just exist so that users don't have to install to the Program Files folder? (I realize that the answer to this must be on tGB somewhere, I will search after I post these questions)
4. Another "gotchas" if the answers to 1 and 2 are "Yes" and I go forward?

Thanks so much!
1. Yes.
2. Yes, the Transfer Tool will work for both series requests from Rovi and EPG123/SD.
3. Kind of. Portable in this case is really so there is no installation package to run. A lot of developers will put in "extra" programs or put dll's in system folders and such... I don't do that. Note that you can also run the setup program and still install it in c:\epg123 if you wanted and it would operate exactly the same as if you extracted the portable files in that location. The setup program will also create program shortcuts in the start menu that the portable will not.
4. Not really. Just that with a clean start, you will lose your recording histories. If you record any series New + Repeat, then you will repeat recordings that you may already have.

Re: I'm Still on 1.0.1! What am I in for if I want to Upgrade?

Posted: Sat Feb 23, 2019 12:19 am
by kmp14
Awesome! Thanks so much for the info. One more question, with either installation method can I specify a different location for to download all of the schedules direct data?

I am probably way overthinking it, but my c drive is an SSD and I'd rather point all that data churn at a spinning drive.

Re: I'm Still on 1.0.1! What am I in for if I want to Upgrade?

Posted: Sat Feb 23, 2019 12:56 am
by garyan2
No. It has been requested, but ............

If you don't want the cache files on your SSD, then just install it on a spinner. Just to note, there may be a whole bunch of files in the cache but the majority of the files will sit there for however many days you are requesting. Some of the generic ones can sit there for multiple months.

Re: I'm Still on 1.0.1! What am I in for if I want to Upgrade?

Posted: Sat Feb 23, 2019 1:01 am
by kmp14
I went ahead and installed the portable version on a spinner so I am good. Thanks again!