2017-06-07: Schedules Direct service issue

An evolving, supported alternative to Rovi
Forum rules
★ Download the latest EPG123 here: http://epg123.garyan2.net <> Setup guide here: http://epg123.garyan2.net/downloads/epg123_Guide.pdf
User avatar
garyan2

Posts: 3436
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

Re: 2017-06-07: Schedules Direct service issue

#101

Post by garyan2 » Tue Aug 01, 2017 7:44 pm

kodi2k6 wrote:My media guide has been stuck at an End Date of "8/8/2017 10 PM" for several days or more. I check the SD page and don't see anything wrong there. In my event logs, it shows that my media "package is already up to date." I am new to EPG123/SD is there something wrong with my set up or SD? When I first switched from Rovi to EPG123/SD, I think I had almost three weeks of media guide data, and I was ecstatic. Now, I am down to less than a week. Suggestions?

Thanks.

Steve
Sounds like you are not importing into the database. Verify running "Full Mode" in the client GUI, or option to "Automatically import ..." is selected in the configuration GUI. Attaching the last update run from the trace.log file if the scheduled task is setup correctly.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

kodi2k6

Posts: 3
Joined: Tue Jul 18, 2017 11:07 pm
Location:

HTPC Specs: Show details

#102

Post by kodi2k6 » Tue Aug 01, 2017 8:08 pm

Thanks for the heads up about SD.

I went into EPG123 and modified my line-up, Save & Exit, and low and behold, my media guide updated !

I don't exactly know what was wrong but it seems to be working now.

User avatar
garyan2

Posts: 3436
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#103

Post by garyan2 » Tue Aug 01, 2017 9:10 pm

kodi2k6 wrote:Thanks for the heads up about SD.

I went into EPG123 and modified my line-up, Save & Exit, and low and behold, my media guide updated !

I don't exactly know what was wrong but it seems to be working now.
A Save & Execute will force an immediate update. Need to make sure your scheduled task is set up properly.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

webminster

Posts: 652
Joined: Tue Dec 20, 2011 11:05 pm
Location:

HTPC Specs: Show details

#104

Post by webminster » Sat Oct 14, 2017 6:33 pm

Seems like overnight overloads. My updates at 2AM MT are consistently failing for last 5 days. Did a manual run today midday and got a full download with no timeouts.
-Alan

User avatar
garyan2

Posts: 3436
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#105

Post by garyan2 » Sat Oct 14, 2017 7:27 pm

webminster wrote:Seems like overnight overloads. My updates at 2AM MT are consistently failing for last 5 days. Did a manual run today midday and got a full download with no timeouts.
I know it goes against everyone's sense of order, but you need to be a bit more random in your choice of update times. The even hours are going to be the worst because of that desire for order along with the thousands of other SD subscribers. I do mine at 04:22 for that reason and never have a timeout.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

User avatar
STC

Posts: 6808
Joined: Mon Jun 06, 2011 4:58 pm
Location:

HTPC Specs: Show details
5+ Yrs TGB Veteran Staff

#106

Post by STC » Sat Oct 14, 2017 8:11 pm

Okay, everyone set their updates to 04:22...
By the Community, for the Community. 100% Commercial Free.

Want decent guide data back? Check out EPG123

User avatar
garyan2

Posts: 3436
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#107

Post by garyan2 » Sat Oct 14, 2017 8:11 pm

STC wrote:Okay, everyone set their updates to 04:22...
:lol: :lol: :lol: :lol: :clap:
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

technodevotee

Posts: 249
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#108

Post by technodevotee » Fri Nov 03, 2017 12:54 pm

Any other UK users with EPG123/Schedules Direct out there?

My PC with DVB-T2 card is fine (now) but the one with DVB-S2 cards has 'to be announced' on some channels after Saturday morning.

I switched over to SD to get away from these problems.
Technodevotee

Sammy2

Posts: 1650
Joined: Fri Aug 24, 2012 7:35 pm
Location:

HTPC Specs: Show details

#109

Post by Sammy2 » Fri Nov 03, 2017 4:16 pm

technodevotee wrote:Any other UK users with EPG123/Schedules Direct out there?

My PC with DVB-T2 card is fine (now) but the one with DVB-S2 cards has 'to be announced' on some channels after Saturday morning.

I switched over to SD to get away from these problems.
But did you get support with the MS/Rovi data?

You probably need to start a new thread with some screen shot of your epg123 settings and with a copy of your trace.log attached so we can see what may be going wrong.

technodevotee

Posts: 249
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#110

Post by technodevotee » Fri Nov 03, 2017 5:08 pm

No I did not - that's why I switched.

I had a look on the SD forum and on here wondering if it was a general issue before getting too involved in troubleshooting it and will take it up with SD and/or Gary if I can't resolve it myself.
Technodevotee

User avatar
newfiend

Posts: 2495
Joined: Tue Jun 07, 2011 12:10 pm
Location: Earth

HTPC Specs: Show details
5+ Yrs TGB Veteran

#111

Post by newfiend » Sat Nov 04, 2017 1:31 am

Don't know if this is related or not but SD had some Server down time yesterday. I wasn't able to login at all or DL new guide data until later yesterday evening. Seems resolved now for me.
newfiend~

User avatar
garyan2

Posts: 3436
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#112

Post by garyan2 » Sat Nov 04, 2017 1:39 am

newfiend wrote:Don't know if this is related or not but SD had some Server down time yesterday. I wasn't able to login at all or DL new guide data until later yesterday evening. Seems resolved now for me.
newfiend~
True, they had some upstream problems yesterday. Below is a message I got from rkulagow concerning the issue. I don't think it is related, but may be. I was hoping some UK users would chime in to answer. I believe the updates to some listings in the UK are only once a week to provide 2 weeks of data. I don't if that is only for specific lineups, or all lineups.
rkulagow wrote:Our upstream has been providing providing bad data for at least the past 6 hours when we perform a passthrough request to get the lineups in a postal code. (We don't cache this because lineups are always
changing.)

Until I was able to troubleshoot, I put the service into maintenance mode.

In this particular case, we're getting bad data. We have guards in place to protect if we got _no_ data, but what we were getting back was valid JSON, just not appropriate.

While they sort out their issue, I have updated our service to allow most requests, but accessing the /headends REST endpoint will now reply with

{
"code": 3001,
"message": "Retrieving headends disabled."
}

There's a thread at

http://forums.schedulesdirect.org/viewt ... =18&t=2930

for status.

Let me know if you have any questions / issues.
- Gary
Stomping out the Rovi disease, one media center at a time. http://epg123.garyan2.net

technodevotee

Posts: 249
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#113

Post by technodevotee » Sat Nov 04, 2017 7:00 am

Thanks guys.

Didn't see any point in doing in-depth troubleshooting if there was a general issue.

The problem seems to have resolved over night as I now seem to have at least 10 days in all channels on both terrestrial and satellite.

Other than a couple of glitches, I like what I see and am very happy that I switched.
Technodevotee

Post Reply