WMC 8.8.5 MSI Installation Package for Win10/11

Discussion of getting WMC to work on Windows 10 (unsupported)
technodevotee

Posts: 834
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#61

Post by technodevotee » Wed Jun 01, 2022 10:26 pm

I'm afraid that reinstalling WMC after a major update is something we are stuck with.

Gary put a lot of effort into making the MSI easy to install and configure and easy to repair but there's always going to be things like the one you encountered that trip people up.

Wildrat

Posts: 12
Joined: Fri Feb 04, 2022 11:51 pm
Location:

HTPC Specs: Show details

#62

Post by Wildrat » Wed Jun 01, 2022 10:30 pm

technodevotee wrote:
Wed Jun 01, 2022 10:26 pm
I'm afraid that reinstalling WMC after a major update is something we are stuck with.

Gary put a lot of effort into making the MSI easy to install and configure and easy to repair but there's always going to be things like the one you encountered that trip people up.
The MSI is much easier than what we had before, though it was not difficult. I prefer the installer since I am lazy! Are you anywhere near RAF Fairford?

technodevotee

Posts: 834
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#63

Post by technodevotee » Fri Jun 03, 2022 10:59 am

Not really.

I'm in Worcestershire.

Wildrat

Posts: 12
Joined: Fri Feb 04, 2022 11:51 pm
Location:

HTPC Specs: Show details

#64

Post by Wildrat » Fri Jun 03, 2022 12:23 pm

technodevotee wrote:
Fri Jun 03, 2022 10:59 am
Not really.

I'm in Worcestershire.
Yep, a few miles away. I looked at my audio driver and Windows did update it, to my dismay. I can't remember which driver I was using. All I know is my receiver is in PCM mode, which I do not like because I can't change surround formats on the receiver. I'll mess with it when I feel more like screwing with my PC. For now, I just switch back and forth between stereo and 7.1.

Phone Guy

Posts: 8
Joined: Sun Aug 07, 2016 3:28 am
Location:

HTPC Specs: Show details

#65

Post by Phone Guy » Mon Jun 13, 2022 12:05 am

Quick question for the gurus here. To play audio from tv/recorded tv (hdhomerun tuners), the system sound has to be to set to stereo otherwise the sound will play for a few seconds and repeat and stay locked in that repeat cycle. This effects 5.1/7.1 surround when playing back of .mkv or .mp4 media using K-lite codecs. Is there anyway to fix this?

More detailed:
Using Klite codecs, which plays everything. PC is connected directly to soundbar, which passes through video to tv (gt1030 to lg atmos soundbar). When PC sound is set to 5.1 or 7.1 and I play atmos or truehd or dts or aac, klite works and I get sound from all the right speakers in this 7.1.2 atmos setup of my soundbar. However, if PC is set to anything other than stereo, when watching tv or playing back recorded tv, the sound plays for a second and skips and repeats and stays in this mode until you stop it, so no sound (video plays fine btw). this is only when playing live tv or recorded tv. so I have been manually switching system sound from 7.1 to stereo when watching tv, and back from stereo to 7.1 when playing back mkv/mp4 files (right click on speaker icon in system tray and changing speaker setup). this is not wife approved and honestly its a pita for me. Is there anyway to either automate this switch or is there a patch or fix? has anyone else experienced this behavior? I remember reading here years ago (yeah this has been an ongoing thing for us), its a flaw in mce and there is no solution.

Thanks for reading, and any help would be appreciated.

leecogan

Posts: 1
Joined: Thu Jul 07, 2022 5:10 pm
Location:

HTPC Specs: Show details

#66

Post by leecogan » Thu Jul 07, 2022 5:29 pm

I had ver. 8.9.0 running very well on Win 10 ver. 1909 with a HDHomeRun duo. Then Windows automatically installed feature update ver. 20H2. After the final re-boot, WMC came up and wanted to re-install itself. I allowed it to. Then re-booted again, just to be sure.

Unfortunately, WMC does not run now at all. After double clicking on the WMC icon, I see a swirling circle over the icon for 2 - 3 seconds, and then nothing happens. I tried uninstalling and then re-installing ver. 8.9.0, but no joy. WMC still won't run.

I forced Windows to remove the feature update and went back to ver. 1909, and confirmed that WMC works perfectly. Then the next day, Windows again automatically installed feature update 20H2, and again, WMC refused to run, even after re-running the .MSI. I know there are ways to freeze my Win 10 version at 1909, but from everything I have read in this thread, it appears that ver. 8.9.0 should run on 20H2 through 21H2.

Any trouble-shooting suggestions?

Wildrat

Posts: 12
Joined: Fri Feb 04, 2022 11:51 pm
Location:

HTPC Specs: Show details

#67

Post by Wildrat » Thu Jul 07, 2022 5:34 pm

It runs fine on the latest update to Win 10. Uninstall, and reinstall. I use the uninstall tool from one of the other versions to insure all the bits and pieces are gone, then do a reboot and install.

byronomo

Posts: 37
Joined: Thu Mar 14, 2013 10:19 am
Location:

HTPC Specs: Show details

#68

Post by byronomo » Wed Aug 10, 2022 9:45 pm

garyan2 wrote:
Sun Feb 13, 2022 5:14 pm
I am surprised no one has done this earlier, but I have created an MSI installation package for WMC 8.8.5. This package has a lot of benefits that we don't get from the zip package we have been using for quite a while. I have it working without issue on Win10 and Win11 for ATSC. You can download it here.
I just found this yesterday. Thank you so much Gary for this! It works wonderfully with Win11 Pro after I corrected some user errors:
First time: I tried to install it WITHOUT the DVD player (thinking that I didn't need it since there was no DVD player on the PC). After you select "No" to the DVD Player prompt, the installer does nothing (no dialog indicating that installation had stopped)---which was puzzling before I realized that I'd made an error.

Second time: I did select "Yes" to the DVD player question and it downloaded and installed properly. I'd expected it to proceed with the WMC installation automatically but nothing happened after that.

Third time (aka "the charm"): Everything installed smoothly and flawlessly.

sirlou2022

Posts: 2
Joined: Sat Aug 13, 2022 9:04 am
Location:

HTPC Specs: Show details

#69

Post by sirlou2022 » Sat Aug 13, 2022 9:14 am

I had a question about this step as well (install DVD player), as I prepare to "upgrade" to Win10 as my 8.1 Pro with WMC nears final end of life on 1/10/23.

How do you get the DVD program? I know Win10 does not come with DVD playback as a default. Did you go and download this program from the Windows Store (https://apps.microsoft.com/store/detail ... n-us&gl=US) per the MS instructions for DVD playback in Win10 here (https://support.microsoft.com/en-us/win ... 5a9e3c4e36)?

Thanks in advance!

Louis

(p.s. new account, I could not log into or reset account or contact Admin for some reason. Longtime user, old account: sirlou2001)
byronomo wrote:
Wed Aug 10, 2022 9:45 pm
garyan2 wrote:
Sun Feb 13, 2022 5:14 pm
I am surprised no one has done this earlier, but I have created an MSI installation package for WMC 8.8.5. This package has a lot of benefits that we don't get from the zip package we have been using for quite a while. I have it working without issue on Win10 and Win11 for ATSC. You can download it here.
I just found this yesterday. Thank you so much Gary for this! It works wonderfully with Win11 Pro after I corrected some user errors:
First time: I tried to install it WITHOUT the DVD player (thinking that I didn't need it since there was no DVD player on the PC). After you select "No" to the DVD Player prompt, the installer does nothing (no dialog indicating that installation had stopped)---which was puzzling before I realized that I'd made an error.

Second time: I did select "Yes" to the DVD player question and it downloaded and installed properly. I'd expected it to proceed with the WMC installation automatically but nothing happened after that.

Third time (aka "the charm"): Everything installed smoothly and flawlessly.

sirlou2022

Posts: 2
Joined: Sat Aug 13, 2022 9:04 am
Location:

HTPC Specs: Show details

#70

Post by sirlou2022 » Mon Aug 15, 2022 2:12 am

Quick question, since you did this recently: how did you install the DVD player? Did you use the free MS one from the MS App Store?
Wildrat wrote:
Thu Jul 07, 2022 5:34 pm
It runs fine on the latest update to Win 10. Uninstall, and reinstall. I use the uninstall tool from one of the other versions to insure all the bits and pieces are gone, then do a reboot and install.

User avatar
garyan2

Posts: 6657
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#71

Post by garyan2 » Mon Aug 15, 2022 4:20 am

The msi will download the DVD Player for you to install if it is not already installed.
- Gary
Keeping WMC alive beyond January 2020. https://garyan2.github.io

Post Reply