WMC on Windows 11?

Discussion of getting WMC to work on Windows 10 (unsupported)
Tweakfiend

Posts: 12
Joined: Mon Aug 17, 2020 2:25 pm
Location:

HTPC Specs: Show details

Re: WMC on Windows 11?

#21

Post by Tweakfiend » Sun Aug 29, 2021 8:59 am

Hi

Reinstalled 8.8.5 and opened again 1st time as administrator ( as opposed to second time etc )
Now seems ok
Thanks for your input Techdevotee

Tweakfiend

Posts: 12
Joined: Mon Aug 17, 2020 2:25 pm
Location:

HTPC Specs: Show details

#22

Post by Tweakfiend » Sun Aug 29, 2021 9:01 am

Now loading after reinstall / first open as administrator
Thanks for your input

A few minutes later can confirm that I have a message that ""setting up media libraries, some components are missing "
So no music , video , DVD libraries etc will populate .

Tweakfiend

Posts: 12
Joined: Mon Aug 17, 2020 2:25 pm
Location:

HTPC Specs: Show details

#23

Post by Tweakfiend » Sun Aug 29, 2021 10:58 am

Strangely, will now store libraries with "Sebas1974" recent ehres.dll update

sebas197422

Posts: 7
Joined: Sat Jan 09, 2021 4:11 pm
Location:

HTPC Specs: Show details

#24

Post by sebas197422 » Sun Aug 29, 2021 2:12 pm

you need too install codecs for it i installed shark007 and it worked after !

Tweakfiend

Posts: 12
Joined: Mon Aug 17, 2020 2:25 pm
Location:

HTPC Specs: Show details

#25

Post by Tweakfiend » Sun Aug 29, 2021 9:49 pm

I had mpg 2 codecs installed but made no difference , perhaps you mean something else ?

sebas197422

Posts: 7
Joined: Sat Jan 09, 2021 4:11 pm
Location:

HTPC Specs: Show details

#26

Post by sebas197422 » Mon Aug 30, 2021 2:50 am

i installed the 64 bit codecs pack from shark007 and after this it worked

User avatar
Mugsy

Posts: 131
Joined: Tue Oct 15, 2013 11:29 am
Location: Houston

HTPC Specs: Show details

#27

Post by Mugsy » Wed Oct 06, 2021 10:43 pm

Just "upgraded" to Win11 (22000.one-ninety-four) and WMC won't launch.

I haven't tried a reinstall yet.

ADDENDUM: Tried to reinstall. Gives "ERROR: Already installed". I don't wish to uninstall/reinstall. I had it all setup with EPG123. Tried the supplied "8.7-8.8-QuickFix.reg" too. Didn't help. Tried running "ehshell.exe" directly as Admin. Didn't help.

Suggestions?

Image
Last edited by Mugsy on Thu Oct 07, 2021 3:25 pm, edited 1 time in total.

john321

Posts: 81
Joined: Sat Jan 23, 2016 9:53 pm
Location:

HTPC Specs: Show details

#28

Post by john321 » Thu Oct 07, 2021 5:07 am

Why bother? Buy a new Tivo.

User avatar
Mugsy

Posts: 131
Joined: Tue Oct 15, 2013 11:29 am
Location: Houston

HTPC Specs: Show details

#29

Post by Mugsy » Thu Oct 07, 2021 12:42 pm

john321 wrote:
Thu Oct 07, 2021 5:07 am
Why bother? Buy a new Tivo.
I assume that reply is directed to everybody, or are you not aware of the purpose of this site? :wtf:

technodevotee

Posts: 728
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#30

Post by technodevotee » Thu Oct 07, 2021 6:26 pm

Mugsy wrote:
Wed Oct 06, 2021 10:43 pm
Just "upgraded" to Win11 (22000.one-ninety-four) and WMC won't launch.

I haven't tried a reinstall yet.

ADDENDUM: Tried to reinstall. Gives "ERROR: Already installed". I don't wish to uninstall/reinstall. I had it all setup with EPG123. Tried the supplied "8.7-8.8-QuickFix.reg" too. Didn't help. Tried running "ehshell.exe" directly as Admin. Didn't help.

Suggestions?

Image
The thing is, Windows upgrades remove the WMC services, registry entries, assembles and a lot of other stuff. Many attempts have been made by me and others at doing repair (over the top) installs but it doesn't work so I'm afraid that you will almost certainly have to uninstall and re-install.

And that will almost certainly mean setting up from scratch as backuprestoresettings doesn't seem to help when going from Windows 10 to Windows 11.

It is a bummer I know but that is the hand we were dealt by MS when they discontinued support for the product.
Last edited by technodevotee on Fri Oct 08, 2021 3:56 pm, edited 1 time in total.

User avatar
Mugsy

Posts: 131
Joined: Tue Oct 15, 2013 11:29 am
Location: Houston

HTPC Specs: Show details

#31

Post by Mugsy » Thu Oct 07, 2021 8:32 pm

Thanks. :(

User avatar
aquadextrous

Posts: 95
Joined: Mon Jul 30, 2018 8:09 pm
Location: Bristol, UK

HTPC Specs: Show details

#32

Post by aquadextrous » Fri Oct 08, 2021 2:41 pm

The good news is (hopefully) that after the initial reinstall on Windows 11, it looks like future W11 updates come through as cumulative updates and so far none of these (there have been quite a few dev/beta builds in the 22000.XXX range and none of these have broken WMC for me (where as when i was on the W10 insider program almost every build released broke WMC in some way)) Plus Windows 11 will only receive the big feature updates annually instead of every 6 months so even if need to reinstall WMC it's only half the work!

User avatar
Mugsy

Posts: 131
Joined: Tue Oct 15, 2013 11:29 am
Location: Houston

HTPC Specs: Show details

#33

Post by Mugsy » Fri Oct 08, 2021 5:13 pm

I uninstalled EPG123 then WMC, rebooted, reinstalled WMC and it worked.

I then reinstalled EPG123 and it remembered my username/password, making setting back up easier.

It'll be a while before I recall/reset all of my scheduled recordings.

tonwes

Posts: 3
Joined: Fri Oct 08, 2021 4:20 am
Location: Netherlands

HTPC Specs: Show details

#34

Post by tonwes » Fri Oct 08, 2021 8:12 pm

@Tweakfriend, did you get .168 to work? What was the trick?

Post Reply