Long delay before WMC starts

Discussion of getting WMC to work on Windows 10 (unsupported)
Post Reply
User avatar
Mugsy

Posts: 114
Joined: Tue Oct 15, 2013 11:29 am
Location: Houston

HTPC Specs: Show details

Long delay before WMC starts

#1

Post by Mugsy » Sat Oct 03, 2020 4:05 pm

For some reason, WMC takes about 30 seconds before it starts playing video (ANY video, be it a file or Live TV.)

The Windows Error Logs reports:
Info:

Code: Select all

10:43:37 AM - Testing internet connection.
10:43:38 AM - Connection established.
10:43:39 AM - Retrieving Directory.
10:43:39 AM - Retrieving Directory.
Error:

Code: Select all

Failed to retrieve Directory (Error: The underlying connection was closed: An unexpected error occurred on a send.)
Info:
Image
I have no idea what any of these "Packages" are. I use an OTA antenna and PCIe tuner card (same problem using a USB tuner.)

What "directory" is it trying to retrieve over the Internet? Could this be "EPG123" related? I "declined" on the "Download Guide" & "Download Region Data" options when installing (first installed 8.8.1, then removed it & installed 8.8.5 to see if it would fix the problem.) My "Recording" directory is local (on my D: drive, but I tried other drives.)

TIA.

technodevotee

Posts: 593
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#2

Post by technodevotee » Sat Oct 03, 2020 4:53 pm

I don't think the error messages are related to the delay playing. Is sounds like a problem with the PlayReady 'database' to me as I have had this happen before.

Deleting or renaming the file (%programdata%\microsoft\PlayReady\mspr.hds) might help - assuming that you installed PlayReady of course.

User avatar
Mugsy

Posts: 114
Joined: Tue Oct 15, 2013 11:29 am
Location: Houston

HTPC Specs: Show details

#3

Post by Mugsy » Sun Oct 04, 2020 2:14 am

technodevotee wrote:
Sat Oct 03, 2020 4:53 pm
Deleting or renaming the file (%programdata%\microsoft\PlayReady\mspr.hds) might help - assuming that you installed PlayReady of course.
Holy heck! That worked. Cut startup time from 38 seconds to 7. :clap:

Big thx.

Post Reply