Audio Out of HTPC HDMI v. PC speaker

Discussion of getting WMC to work on Windows 10 (unsupported)
Post Reply
alect71

Posts: 8
Joined: Mon Jan 20, 2020 11:27 am
Location:

HTPC Specs: Show details

Audio Out of HTPC HDMI v. PC speaker

#1

Post by alect71 » Fri Jan 24, 2020 9:36 am

I recently upgtaded to Win10 (and WMC on that) from Win7. Never had this problem on Win7:

HTPC is connected to TV via HDMI. So audio output goes out to TV.
When I switched off the TV last night going to bed, the audio out defaulted to PC speaker. Since we don't switch off WMC overnight (as some recordings are scheduled for night time) the audio out was coming through the PC speaker all night - and when I arose for breakfast the next day. As soon as I switched on the TV in the morning the audio was coming out of the TV as needed.

How do I stop the audio out dropping back to PC speaker when the HDMI connection (TV) is switched off?

technodevotee

Posts: 472
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#2

Post by technodevotee » Fri Jan 24, 2020 2:28 pm

I assume you have tried this: https://www.howtogeek.com/352787/how-to ... indows-10/?

Not sure it will help in your situation because the only thing connected to my HTPC is an A/V Amp so I don't experience that problem.
Last edited by technodevotee on Fri Jan 24, 2020 3:07 pm, edited 1 time in total.

unclebun

Posts: 63
Joined: Sun Jul 09, 2017 11:06 pm
Location:

HTPC Specs: Show details

#3

Post by unclebun » Fri Jan 24, 2020 2:43 pm

Our sound is always on through the PC because we are using Logitech PC Surround speakers. The computer is never off, but the only sounds we ever hear with the TV off are the occasional Windows noises. It's actually helpful because Saturday mornings if there are problems with recordings I can hear the sound of the message box saying the recording couldn't start because of no signal.

Just don't have any playback going on when you shut the TV down. You don't even have to have WMC running. Your shows will still record.

tonywagner

Posts: 163
Joined: Thu Feb 04, 2016 1:53 am
Location:

HTPC Specs: Show details

#4

Post by tonywagner » Fri Jan 24, 2020 3:54 pm

alect71 wrote:
Fri Jan 24, 2020 9:36 am
I recently upgtaded to Win10 (and WMC on that) from Win7. Never had this problem on Win7:

HTPC is connected to TV via HDMI. So audio output goes out to TV.
When I switched off the TV last night going to bed, the audio out defaulted to PC speaker. Since we don't switch off WMC overnight (as some recordings are scheduled for night time) the audio out was coming through the PC speaker all night - and when I arose for breakfast the next day. As soon as I switched on the TV in the morning the audio was coming out of the TV as needed.

How do I stop the audio out dropping back to PC speaker when the HDMI connection (TV) is switched off?
What do you use the PC speaker for? Presumably if you want audio going to the TV when it's off, that means you just want it muted during that time? Could you just unplug the speaker or otherwise disable it?

My Win7 HTPC will default to another audio output if it doesn't detect an HDMI audio output. Win10 likely does the same, and it's possible your new Win10 video drivers can't detect your TV when it is turned off, but your previous Win7 drivers did. I had to change video cards recently on my Win7 HTPC, and the replacement card had trouble detecting my TV properly -- sometimes it would flash "DVI" instead of "HDMI" when I turned it on, and then Windows would fall back to the PC speaker for audio out (since it didn't see an HDMI audio device present).

Something similar might be happening on your system. Check for updated video card drivers, I suppose, and your video card settings. You could also check support or forums for your video card.

Post Reply