Cannot play dvr-ms files in Windows 10 Media Center

Discussion of getting WMC to work on Windows 10 (unsupported)
Post Reply
al.rob

Posts: 15
Joined: Mon Apr 16, 2012 1:19 pm
Location:

HTPC Specs: Show details

Cannot play dvr-ms files in Windows 10 Media Center

#1

Post by al.rob » Mon Dec 02, 2019 6:17 pm

I have gotten Media Center installed in the new Windows 10 PC I recently built, thanks to all of the much-appreciated help in this forum. I have been using it for a few weeks now and it is recording all of the shows without issues. However, I recently discovered that my older programs will not play, starting in April 2014. That rang a bell, as that is when I switched over to Windows 7 from XP Media Center Edition. The XP Media Center shows were all recorded in dvr-ms format instead of the wtv format in Windows 7 Media Center. None of the dvr-ms files will play. Instead, I get an error "This trial version has expired and can no longer be used." The dvr-ms files always played in Media Center on my Windows 7 PC, so I know it is supposed to be backwards compatible and work. Has anyone else had this problem, and is there a way to make it work? They all show up in the listings and can be clicked on, but I get the error instead of the show playing.

Thanks,

Al

al.rob

Posts: 15
Joined: Mon Apr 16, 2012 1:19 pm
Location:

HTPC Specs: Show details

#2

Post by al.rob » Mon Dec 02, 2019 6:24 pm

I forgot to mention in my post above that I am running 64 bit Windows 10, a fresh installation that is fully updated to build 1903.

al.rob

Posts: 15
Joined: Mon Apr 16, 2012 1:19 pm
Location:

HTPC Specs: Show details

#3

Post by al.rob » Mon Dec 02, 2019 6:29 pm

I also forgot to indicate that I did run the "replace dlls" script, which fixed the other problem I was having with the "all tuners in use" error.

technodevotee

Posts: 339
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#4

Post by technodevotee » Mon Dec 02, 2019 10:37 pm

Which version of WMC are you running?

I'm running V13 on 2004 build 19033.1 and can play wtv and dvr-ms files with no problem.

al.rob

Posts: 15
Joined: Mon Apr 16, 2012 1:19 pm
Location:

HTPC Specs: Show details

#5

Post by al.rob » Tue Dec 03, 2019 1:51 am

I have Windows 10 Pro Version 1903 OS build 18362.476, a new installation done on 11/3/19. I did use the WMC-V13_x64 installer that you issued back in June. I ran the test_rights script first, then the installer, and then the replace DLLs script. I did this after I had checked for Windows updates several times until it could find no more updates.

technodevotee

Posts: 339
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#6

Post by technodevotee » Tue Dec 03, 2019 7:02 am

Try running fix_thumbnails.cmd in case it is because encdec.dll is missing.

That should also give you thumbnails in Recorded TV.

al.rob

Posts: 15
Joined: Mon Apr 16, 2012 1:19 pm
Location:

HTPC Specs: Show details

#7

Post by al.rob » Wed Dec 04, 2019 1:41 am

Running the thumbnails script fixed the problem, and I did get the thumbnails. So it does more than fix thumbnails, it also allows the dvr-ms files to play. Thank you very much for all of your work on this. Without the help from this forum, i'd be lost.

Al

technodevotee

Posts: 339
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#8

Post by technodevotee » Wed Dec 04, 2019 8:23 am

I always thought that encdec.dll was used for more than generating thumbnails but never really investigated it.

The most obvious result of it being missing is missing thumbnails - hence the name of the script.

Post Reply