Any success with Windows 10 1909?

Discussion of getting WMC to work on Windows 10 (unsupported)
Rik007

Posts: 1
Joined: Tue Dec 10, 2019 8:12 pm
Location:

HTPC Specs: Show details

Re: Any success with Windows 10 1909?

#21

Post by Rik007 » Tue Dec 10, 2019 8:16 pm

Running WMC 8.8.4 with anysee. Until now no issues. Fantastic job!

twegner

Posts: 16
Joined: Thu Jul 11, 2019 6:48 pm
Location:

HTPC Specs: Show details

#22

Post by twegner » Tue Dec 10, 2019 11:26 pm

Because I am completely insane, and have a solid backup system, I applied today's (12/10/2019) cumulative update on my WMC HTPC on Windows 10 1909 with EGP123. I held my breath, and after I rebooted WMC seems to be running fine.

I do have one nagging annoyance that is related to Windows 10 and likely has nothing to do with WMC. My HTPC is connected to a Sony TV via HDMI which includes both video and sound. Sometimes when I start the system the audio is not recognized. A reboot always gets the sound on. I never saw this with Windows 7. I can live with it.

edlegs

Posts: 1
Joined: Wed Dec 11, 2019 3:37 am
Location:

HTPC Specs: Show details

#23

Post by edlegs » Wed Dec 11, 2019 3:40 am

twegner wrote:
Tue Dec 10, 2019 11:26 pm
Because I am completely insane, and have a solid backup system, I applied today's (12/10/2019) cumulative update on my WMC HTPC on Windows 10 1909 with EGP123. I held my breath, and after I rebooted WMC seems to be running fine.

I do have one nagging annoyance that is related to Windows 10 and likely has nothing to do with WMC. My HTPC is connected to a Sony TV via HDMI which includes both video and sound. Sometimes when I start the system the audio is not recognized. A reboot always gets the sound on. I never saw this with Windows 7. I can live with it.
I see this same issue frequently with my Win7 machine. I've found I can also unplug/re-plug the HDMI cable from/to the PC if I don't want to bother with a restart.

technodevotee

Posts: 407
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#24

Post by technodevotee » Wed Dec 11, 2019 9:25 am

HDMI initialization issues seem to have been worse for me since getting a Sony Smart TV as well: Sometimes there's no picture and sometimes there's no sound when starting up.

There is an A/V Amp between the HTPC and the TV but I moved my old HTPC and Samsung Smart TV to another room and connected them directly to each other and that isn't perfect either.

I have often wondered if it is poor quality cables preventing proper handshaking.
Last edited by technodevotee on Thu Dec 12, 2019 8:29 am, edited 1 time in total.

jachin99

Posts: 1202
Joined: Wed Feb 24, 2016 3:36 pm
Location:

HTPC Specs: Show details

#25

Post by jachin99 » Wed Dec 11, 2019 3:28 pm

I can't quote anyone directly but I have heard of others having much better luck with high quality HDMI cables. It's especially bad on long cable runs.

twegner

Posts: 16
Joined: Thu Jul 11, 2019 6:48 pm
Location:

HTPC Specs: Show details

#26

Post by twegner » Wed Dec 11, 2019 8:16 pm

Even though triggered by an offhand comment about HDMI on my part, I appreciated the several comments about HDMI cables. I have a very short cable, certainly not a high quality one. I unplugged both ends, plugged in again, connected securely, and for good measure switched from the Sony HDMI 2 port to HDMI 1. So far so good. The computer and the TV also have a VGA, but I vaguely recall this didn't work as well as HDMI, not to mention I would have to also connect audio cables. We shall see. I used to run the HTPC 24/7, which would likely eliminate this problem, but more recently have been turning it off if nothing to record. My experience has been that once I have sound, it stays on until the next time I turn the computer off and then on again. (later) Nope, audio was off again when HTPC started, but reboot fixed it. I think I'll stop worrying about it as long as the reboot always works.

Back to the original topic, I will probably keep rashly applying cumulative updates, but will be very very cautious when we get to the 2020 feature update, since the experience here is they often break WMC. From what I understand, the 1909 was unusually small and not like the usual Windows 10 feature update.
Last edited by twegner on Wed Dec 11, 2019 10:39 pm, edited 1 time in total.

technodevotee

Posts: 407
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#27

Post by technodevotee » Wed Dec 11, 2019 10:26 pm

I'm running the latest insider build of 2004 on one of my testbed PCs and WMC still works fine once I've rolled back the updated DLLs and reinstated the missing DLLs and registry entries using my utility.

twegner

Posts: 16
Joined: Thu Jul 11, 2019 6:48 pm
Location:

HTPC Specs: Show details

#28

Post by twegner » Wed Dec 18, 2019 2:48 am

RE the problem I was experiencing with Windows 10 HTPC not recognizing the Sony HDMI Audio. While it always worked to start the computer, and then reboot, it turns out that the root cause was Windows 10's fast startup feature. You can turn this off with Control Panel->Hardware and Sound-Power Options-> Choose What the Power Buttons Do (menu on left) Then clear the checkbox "Turn On Fast Startup (Recommended)" After I did this, the Sony HDMI audio was recognized every time when the computer is started. I hope this helps others. I was almost ready to go back to Windows 7 for running WMC, but now that the HDMI audio problem is fixed, I feel better about Windows 10!

technodevotee

Posts: 407
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#29

Post by technodevotee » Wed Dec 18, 2019 7:14 am

Thanks for updating us. Glad it is working better for you.

I always turn off fast start up as it causes problems for me on every PC I have.

IMHO, it really isn't worth having just for the sake of 10-15 seconds.

jppl2000

Posts: 12
Joined: Tue May 22, 2012 3:10 am
Location:

HTPC Specs: Show details

#30

Post by jppl2000 » Thu Dec 26, 2019 7:14 pm

Hello, I have version 1909 of Windows 10. I have an infinitv6 tuner(s). It used to work in Windows 7 but strangely went south. The Ceton diagnostic detects all in Win 10 but WMC does not detect tuners. At this point what should I do? Thanks, JIM

rogoued

Posts: 44
Joined: Thu Jul 23, 2015 12:10 am
Location:

HTPC Specs: Show details

#31

Post by rogoued » Mon Dec 30, 2019 2:13 pm

My setup is PC->HDMI->Denon Receiver->DVI to Monitor (No sound an old Pioneer DUMB Plasma)
Most of the time when I wake up the PC and the monitor there is no video, I am guessing this is because of the DVI handshake to the Denon receiver?
My other issue is that the sound on the PC itself is OK, but when I play a recorded show the sound goes sky high - is there a way to get these balanced in one level?? TIA

technodevotee

Posts: 407
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#32

Post by technodevotee » Tue Dec 31, 2019 2:22 pm

rogoued wrote:
Mon Dec 30, 2019 2:13 pm
My setup is PC->HDMI->Denon Receiver->DVI to Monitor (No sound an old Pioneer DUMB Plasma)
Most of the time when I wake up the PC and the monitor there is no video, I am guessing this is because of the DVI handshake to the Denon receiver?
My other issue is that the sound on the PC itself is OK, but when I play a recorded show the sound goes sky high - is there a way to get these balanced in one level?? TIA
This doesn't really help but:

I have PC > Onkyo A/V Amp > Sony Smart TV (all HDMI) which was working pretty well but coming out of standby seems to have been really problematic since 1909 was installed.

Sometimes there's no picture and sometimes there's no sound and I have to shut everything down and start again.

Different hardware I know but definitely seems like issues have been worse since 1909.

Can't help with sound problems either I'm afraid but It certainly sounds like a handshaking problem.

I assume you tried turning off fast startup?

rogoued

Posts: 44
Joined: Thu Jul 23, 2015 12:10 am
Location:

HTPC Specs: Show details

#33

Post by rogoued » Tue Dec 31, 2019 2:42 pm

technodevotee wrote:
Tue Dec 31, 2019 2:22 pm
rogoued wrote:
Mon Dec 30, 2019 2:13 pm
My setup is PC->HDMI->Denon Receiver->DVI to Monitor (No sound an old Pioneer DUMB Plasma)
Most of the time when I wake up the PC and the monitor there is no video, I am guessing this is because of the DVI handshake to the Denon receiver?
My other issue is that the sound on the PC itself is OK, but when I play a recorded show the sound goes sky high - is there a way to get these balanced in one level?? TIA
This doesn't really help but:

I have PC > Onkyo A/V Amp > Sony Smart TV (all HDMI) which was working pretty well but coming out of standby seems to have been really problematic since 1909 was installed.

Sometimes there's no picture and sometimes there's no sound and I have to shut everything down and start again.

Different hardware I know but definitely seems like issues have been worse since 1909.

Can't help with sound problems either I'm afraid but It certainly sounds like a handshaking problem.

I assume you tried turning off fast startup?
It is strange that there are two levels to the sound, but honestly, we do not need sound when moving around the WMC menu, so we left the sound at the level that is good for watching shows. So that has been "solved", though I do not know if this issue is new or not as we moved to this setup as part of my move to Windows 10. Before we had audio coming from a separate SP/DIF channel on our old PC.
In regards to the blank screen, yeah it can be annoying but the plan now is to just quit WMC with a keyboard. I will add a Quit WMC to the Logitech remote, but I am in no rush.

Many thanks!

technodevotee

Posts: 407
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#34

Post by technodevotee » Tue Dec 31, 2019 3:17 pm

A lot of people find that having navigation sounds enabled in WMC causes problems. It seems that Windows can't handle multiple audio streams of different formats simultaneously.

It drives my A/V amp nuts - long delays before I get sound and speaker relays clicking and clunking so I have them turned off.

Post Reply