Update Playready

Discussion of getting WMC to work on Windows 10 (unsupported)
Post Reply
Rodrigo667

Posts: 8
Joined: Fri Oct 11, 2019 4:24 pm
Location:

HTPC Specs: Show details

Update Playready

#1

Post by Rodrigo667 » Fri Oct 11, 2019 5:03 pm

Every time i try to update Playready to watch live tv it says "The PlayReady Update was incomplete" i have tried lots of methods to no result. any way to fix this? :?:

User avatar
StinkyImp

Posts: 211
Joined: Thu May 11, 2017 7:53 pm
Location:

HTPC Specs: Show details

#2

Post by StinkyImp » Fri Oct 11, 2019 5:34 pm

Garyan2 posted the download locations for the Playready installers here.

viewtopic.php?p=132212#p132212

Rodrigo667

Posts: 8
Joined: Fri Oct 11, 2019 4:24 pm
Location:

HTPC Specs: Show details

#3

Post by Rodrigo667 » Fri Oct 11, 2019 6:03 pm

StinkyImp wrote:
Fri Oct 11, 2019 5:34 pm
Garyan2 posted the download locations for the Playready installers here.

viewtopic.php?p=132212#p132212
i tried installing that and it still did not work

technodevotee

Posts: 341
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#4

Post by technodevotee » Fri Oct 11, 2019 6:50 pm

Those links are for the old versions.

Try installing the new version (v1.3.2313.10) from my website https://technodevotee.co.uk/WMC-Downloads.htm

Dkeyguy1

Posts: 158
Joined: Sun Dec 23, 2012 3:38 pm
Location:

HTPC Specs: Show details

#5

Post by Dkeyguy1 » Fri Oct 11, 2019 7:19 pm

Playready update failure;
- Ensure that you're logged in with admin rights, and that under Control Panel->Folder Options->View, you have "Show Hidden Files, Folders and drives" selected and "Hide protected operating system files" unchecked.

- From Control Panel->Programs and Features, uninstall "PlayReady PC Runtime" if present (x86 or x64 as appropriate)



net stop ehrecvr

cd %programdata%\Microsoft\PlayReady

del *.hds

rmdir /s Cache

cd %programdata%\Microsoft\ehome

del *.hds

rmdir /s Cache

- Go to C:\ProgramData\Microsoft\Windows\DRM and delete all files and folders underneath (don't delete the DRM directory itself)

net start ehrecvr


Run Windows Media Center. Update PlayReady by going through Tasks, Settings, TV, TV Signal, Update PlayReady.

Rodrigo667

Posts: 8
Joined: Fri Oct 11, 2019 4:24 pm
Location:

HTPC Specs: Show details

#6

Post by Rodrigo667 » Fri Oct 11, 2019 7:42 pm

Dkeyguy1 wrote:
Fri Oct 11, 2019 7:19 pm
Playready update failure;
- Ensure that you're logged in with admin rights, and that under Control Panel->Folder Options->View, you have "Show Hidden Files, Folders and drives" selected and "Hide protected operating system files" unchecked.

- From Control Panel->Programs and Features, uninstall "PlayReady PC Runtime" if present (x86 or x64 as appropriate)



net stop ehrecvr

cd %programdata%\Microsoft\PlayReady

del *.hds

rmdir /s Cache

cd %programdata%\Microsoft\ehome

del *.hds

rmdir /s Cache

- Go to C:\ProgramData\Microsoft\Windows\DRM and delete all files and folders underneath (don't delete the DRM directory itself)

net start ehrecvr


Run Windows Media Center. Update PlayReady by going through Tasks, Settings, TV, TV Signal, Update PlayReady.
Still nothing :crazy:

technodevotee

Posts: 341
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#7

Post by technodevotee » Fri Oct 11, 2019 7:53 pm

Rodrigo667 wrote:
Fri Oct 11, 2019 7:42 pm
Still nothing :crazy:
Are you using DVBLink by any chance?

Rodrigo667

Posts: 8
Joined: Fri Oct 11, 2019 4:24 pm
Location:

HTPC Specs: Show details

#8

Post by Rodrigo667 » Fri Oct 11, 2019 8:37 pm

technodevotee wrote:
Fri Oct 11, 2019 7:53 pm
Rodrigo667 wrote:
Fri Oct 11, 2019 7:42 pm
Still nothing :crazy:
Are you using DVBLink by any chance?
Nope.

technodevotee

Posts: 341
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#9

Post by technodevotee » Fri Oct 11, 2019 9:42 pm

Are there any pertinent errors in Event Viewer?

Rodrigo667

Posts: 8
Joined: Fri Oct 11, 2019 4:24 pm
Location:

HTPC Specs: Show details

#10

Post by Rodrigo667 » Sat Oct 12, 2019 2:46 am

technodevotee wrote:
Fri Oct 11, 2019 9:42 pm
Are there any pertinent errors in Event Viewer?
What do you mean by "pertinent errors"?

technodevotee

Posts: 341
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#11

Post by technodevotee » Sat Oct 12, 2019 6:41 am

Errors that relate to installation or initialization of playready .

Rodrigo667

Posts: 8
Joined: Fri Oct 11, 2019 4:24 pm
Location:

HTPC Specs: Show details

#12

Post by Rodrigo667 » Sat Oct 12, 2019 3:24 pm

technodevotee wrote:
Sat Oct 12, 2019 6:41 am
Errors that relate to installation or initialization of playready .
How do i check that?

technodevotee

Posts: 341
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#13

Post by technodevotee » Sat Oct 12, 2019 6:18 pm

right click start and select event viewer from the list or type event viewer in search and select it from the list that appears

it can take a while to load the logs.

once event viewer is open there are a few places that might contain clues as to what the problem is.
the first one I would look at is Media Center, which is in the section named applications and services logs on the left hand side
the next places I would look are application and system, which are under the section named windows logs on the left hand side

Scroll through each section and see if there's any thing that refers to playready, which occurred at about the time you had the error messages appear

errors will show up as a red disc with a white exclamation mark

Rodrigo667

Posts: 8
Joined: Fri Oct 11, 2019 4:24 pm
Location:

HTPC Specs: Show details

#14

Post by Rodrigo667 » Sat Oct 12, 2019 10:55 pm

technodevotee wrote:
Sat Oct 12, 2019 6:18 pm
right click start and select event viewer from the list or type event viewer in search and select it from the list that appears

it can take a while to load the logs.

once event viewer is open there are a few places that might contain clues as to what the problem is.
the first one I would look at is Media Center, which is in the section named applications and services logs on the left hand side
the next places I would look are application and system, which are under the section named windows logs on the left hand side

Scroll through each section and see if there's any thing that refers to playready, which occurred at about the time you had the error messages appear

errors will show up as a red disc with a white exclamation mark
these are the errors i got:
9:45:33 AM - Error connecting to the internet.
9:45:33 AM - Unable to contact server..

9:17:01 PM - Error connecting to the internet.
9:17:01 PM - Unable to contact server..

9:16:56 PM - Error connecting to the internet.
9:16:56 PM - Unable to contact server..

5:41:30 PM - Error connecting to the internet.
5:41:30 PM - Unable to contact server..

still nothing... :crazy:

Manual Recording was not recorded. There was no TV signal when the show was scheduled to record.

Manual Recording was not recorded. There was no TV signal when the show was scheduled to record.

technodevotee

Posts: 341
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#15

Post by technodevotee » Sun Oct 13, 2019 6:39 am

What happened when you installed the latest version of PlayReady from my website?

Rodrigo667

Posts: 8
Joined: Fri Oct 11, 2019 4:24 pm
Location:

HTPC Specs: Show details

#16

Post by Rodrigo667 » Sun Oct 13, 2019 11:26 pm

technodevotee wrote:
Sun Oct 13, 2019 6:39 am
What happened when you installed the latest version of PlayReady from my website?
Nothing, still gave me an error :problem:

technodevotee

Posts: 341
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#17

Post by technodevotee » Mon Oct 14, 2019 6:08 am

can you be more specific? what was the error? when did it occur? are there any other errors in the event logs that tie up with your attempts to repair the PC?

joelkirzner

Posts: 88
Joined: Wed May 22, 2013 3:18 pm
Location:

HTPC Specs: Show details

#18

Post by joelkirzner » Thu Oct 31, 2019 7:44 pm

Every time I reimage my HTPC, I run into this issue.
There is pretty much ONE FIX to this and it's to reset the DRM keys in Windows.
You likely run into this playready problem when you either add or remove hardware, or in my case, clone my drive from another drive.
The DRM gets messed up and playready will not work, no matter what you try.

Solution:
viewtopic.php?t=3760

You're welcome. :)

Post Reply