Page 3 of 3

Re: Windows Version 1903 Issues

Posted: Wed Sep 25, 2019 7:01 pm
by Speedy
technodevotee wrote:
Sat Sep 21, 2019 7:46 pm
As many of you will know, WMC won't start in builds of Windows 10 after 18958. The resolution is to reinstate the functionality of MSSQLLite.

I have just included an add-on to WMC V13, which can be used to do that per Kévin Chalet's instructions on MDL.

It is also available in WMC Multi Tool.
Thank you very, very much!!! For all your work, especially for this advice about MSSQLLite and for WMC Multi Tool.

Now WMC V13 worked OK on my Win 10 build 18990 machine :)

Re: Windows Version 1903 Issues

Posted: Wed Oct 02, 2019 11:02 pm
by rband
Greetings all! I too have been bit by the 1903 monster. In my case I was able to install and run v8.8.3 but I am unable to connect to live TV. I am connected to an OTA antenna thru a Hauppauge WinTV-HVR 2255 tuner card running updated Win 10 drivers. I am able to start the program and see all the recordings I've made in the past but I am unable to watch any of them, WMC crashes. When I try to watch live TV, I get the error message telling me there are no tuners available. The hardware setup has been in the box for five or so years and worked flawlessly. Any idea where it all went wrong? Thanks

Re: Windows Version 1903 Issues

Posted: Thu Oct 03, 2019 5:27 am
by technodevotee
rband wrote:
Wed Oct 02, 2019 11:02 pm
Greetings all! I too have been bit by the 1903 monster. In my case I was able to install and run v8.8.3 but I am unable to connect to live TV. I am connected to an OTA antenna thru a Hauppauge WinTV-HVR 2255 tuner card running updated Win 10 drivers. I am able to start the program and see all the recordings I've made in the past but I am unable to watch any of them, WMC crashes. When I try to watch live TV, I get the error message telling me there are no tuners available. The hardware setup has been in the box for five or so years and worked flawlessly. Any idea where it all went wrong? Thanks
It's almost certain that CPFilters had been updated and needs rolling back.

8.8.4 has a fix for that and you can get it here: https://mega.nz/#!eHh10AyC!rACoUNaJYMqm ... dx5Hp6nNkc

Re: Windows Version 1903 Issues

Posted: Thu Oct 03, 2019 10:51 pm
by rband
techodevotee, thanks for the info, it's up and running. I was about to give up.

Re: Windows Version 1903 Issues

Posted: Sun Oct 13, 2019 4:02 pm
by scott750
After the latest Windows Cumulative update KB4517389 on 10/9, my WMC 8.8.3 says it can't find my libraries or there is no content in them. Although it wont open my recorded programs, WMC continues to record stuff and is still saving them in the recorded folder. I can see new recordings everyday. When I tried to remove/re-add my library folders, the only one available to remove was a public recording folder on the C: drive. My current recording folder is on a separate E: drive. I tried to rollback the DLLs using both the Rollback_DLLs and WMC_Multi_Tool programs listed above, but only 1 file was copied. I'm currently on OS Build 1903 18362.418

Below are my current DLL versions. Do I need to uninstall the latest MS update? Or reinstall WMC?
WMC No Libraries.jpg
WMC DLLs.jpg

Re: Windows Version 1903 Issues

Posted: Sun Oct 13, 2019 4:19 pm
by technodevotee
I assume you had to uninstall and reinstall WMC to get this far? Surely it wouldn't be working at all otherwise.

It looks OK DLL wise for 8.8.3.

Can you have a look in the registry and let us know what it gives you in here?

Code: Select all

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Media Center\Service\Recording
WMC (various versions) running fine on 18362.418 here

Re: Windows Version 1903 Issues

Posted: Sun Oct 13, 2019 5:29 pm
by scott750
technodevotee wrote:
Sun Oct 13, 2019 4:19 pm
I assume you had to uninstall and reinstall WMC to get this far? Surely it wouldn't be working at all otherwise.

It looks OK DLL wise for 8.8.3.

Can you have a look in the registry and let us know what it gives you in here?

Code: Select all

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Media Center\Service\Recording
WMC (various versions) running fine on 18362.418 here
Nothing uninstalled/reinstalled recently. WMC 8.8.3 has been installed for at least 4 months now and running fine. The CPFilters.DLL was a newer version that I rolled back using your app. The error in WMC just popped up in the past couple days and that's when I checked the latest Windows updates.

Here's a screenshot of the registry.
WMC Registry.jpg
Another issue I just noticed is I can't view live TV. Says no tuners are available. But I know all 4 tuners aren't being used right now. I have 2 HDHomeRun tuner boxes. Not sure if this issue is related or separate.

Re: Windows Version 1903 Issues

Posted: Sun Oct 13, 2019 9:20 pm
by technodevotee
Mysterious, everything looks OK and I don't know anything about HD Homerun tuners I'm afraid.

Does WMC play recorded programmes if you double click them or right click and open with WMC?

Re: Windows Version 1903 Issues

Posted: Sun Oct 13, 2019 11:21 pm
by scott750
Yes it does play them. Loads up the file quickly like usual.

Re: Windows Version 1903 Issues

Posted: Mon Oct 14, 2019 6:55 am
by technodevotee
Does WMC 'see' a recorded tv programme if you copy one of your recordings to c:\users\public\recorded tv?

Normally I would say it is time to uninstall 8.8.3 and install 8.8.4 but I'm not sure whether it will make matters worse or better.

Do you remember whether you had to install the HD Homerun software after before or installing WMC?

Re: Windows Version 1903 Issues

Posted: Mon Oct 14, 2019 2:12 pm
by scott750
WMC isn't showing a list of recorded programs so cannot confirm your first question. But it has been recording new shows and if I open the recording from Windows Explorer it plays just like normal. So I know the tuners are all still working.

I'm willing to reinstall v8.8.3 since it was working before. Not sure what additional benefits v8.8.4 offer. Everything is already backed up so will be easy to get all of my settings and recordings again after reinstall.

My laptop is running v8.8.3 and has not updated to 1903 18362.418. I paused its Windows updates for now until I resolve my HTPC WMC issue.

Re: Windows Version 1903 Issues

Posted: Mon Oct 14, 2019 2:33 pm
by technodevotee
I'm puzzled why it doesn't list the E drive in settings/media libraries when that is clearly in the registry and I wondered if WMC is looking for recordings in the default location of c:\users\public\recorded tv despite what is in the registry.

Kevin's 8.8.4 now includes the required version of cpfilters in ehome and the manifests have been redone.

My main concern is that uninstalling and reinstalling might break WMC altogether by stopping it recording. I have no idea how the Homerun tuners are setup or configured.

Re: Windows Version 1903 Issues

Posted: Mon Oct 14, 2019 2:52 pm
by scott750
Yes very weird why it thinks the E drive isn't there. But it also has the E: drive checked when going into TV Setup: Settings > TV > Recorder > Media Libraries > Add folders
WMC No Libraries2.jpg
Although E: drive is still checked, it doesn't give me the option to highlight the line to uncheck it.
Do you remember whether you had to install the HD Homerun software after before or installing WMC?
Forgot to respond to this. Yes I had to install the HDHomeRun software before WMC.

Instead of uninstalling/reinstalling WMC, would going thru the EPG123 TV setup help at all? Delete/re-add the EHome folder and all? Could uninstall/rollback the latest Windows update that caused of of these issues?

Re: Windows Version 1903 Issues

Posted: Mon Oct 14, 2019 3:34 pm
by garyan2

scott750 wrote: Instead of uninstalling/reinstalling WMC, would going thru the EPG123 TV setup help at all? Delete/re-add the EHome folder and all? Could uninstall/rollback the latest Windows update that caused of of these issues?
No on EPG123. I believe all the library info is in your registry for WMC and WMP? There is nothing in the database to control that.

Re: Windows Version 1903 Issues

Posted: Mon Oct 14, 2019 11:08 pm
by scott750
Ok I feel like a total dumbass! I figured out what I did to cause this issue and it's really embarrassing, but hope it helps someone out in the future. In my recorded programs I must have selected "Shared" in the sorting feature up top. So of course it says I don't have any shared folders because I don't have any. I changed it to one of the other sorting settings and all of my recorded programs show up again.

Technodevotee I'm so sorry for wasting your time with this, but greatly appreciate all of your time and help troubleshooting this issue!!

Before
WMC No Libraries3.jpg
After
WMC No Libraries4.jpg

Re: Windows Version 1903 Issues

Posted: Mon Oct 14, 2019 11:33 pm
by scott750

garyan2 wrote: No on EPG123. I believe all the library info is in your registry for WMC and WMP? There is nothing in the database to control that.
Thanks Gary!

Sent from my SM-G965U using Tapatalk


Re: Windows Version 1903 Issues

Posted: Tue Oct 15, 2019 6:16 am
by technodevotee
I'm glad it is working.

I think it is great that you let us know what it was. A lot of people would have said they'd fixed it by reinstalling or whatever and we'd have been none the wiser.

Re: Windows Version 1903 Issues

Posted: Wed Oct 30, 2019 6:03 pm
by ferrellsl
I performed a clean install of 8.8.4 on my system and it works 100%. Thanks so much for your time and efforts in getting WMC running on Win 10 1903. I wish MS would reconsider their decision to drop WMC and start selling/supporting it again. It's by far the easiest and best performing live TV app out there. All the others, both paid and free are monstrosities to install and configure.