WMC 8.8.3 for Win 10

Discussion of getting WMC to work on Windows 10 (unsupported)
BMV

Posts: 17
Joined: Wed Jun 05, 2019 7:46 am
Location:

HTPC Specs: Show details

Re: WMC 8.8.3 for Win 10

#21

Post by BMV » Sun Jun 09, 2019 5:22 pm

No i was not creating a reg file for patching an installed system, i was try to create a 32-bit version and found this bug.
But the 32-bit version doen't work, a message from windows was that some files could not run in windows version 1903.
But also the 64-bit version doesn't works in Windows 1903. I can install WMC and it wil scan all the TV channels properly, but when i select a channel to watch, WMC will close.
And when i start WMC again and select the same or an other channel, then it give a message that it can not be recorded. See the Windows Help page for more details about codecs.
When i install it on Windows 1809 there is no problem. And it is the same computer.

technodevotee

Posts: 325
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#22

Post by technodevotee » Sun Jun 09, 2019 6:57 pm

@BMV

Unfortunately, despite Kevin Chalet's valiant efforts, we are back to having to replace some DLLs in system32 to get WMC to run in 1903.

I posted a DLL replacer that I built on another thread viewtopic.php?p=131556#p131556 which makes the job a lot easier.

If you want to use that, just unzip it into your WMC installer folder and run dll_replacer.cmd.

I have also created a patched registry file and a patch installer to fix the problem you highlighted and with your permission, I will post that here as well. I'll obviously mention you for your observations.

technodevotee

Posts: 325
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#23

Post by technodevotee » Mon Jun 10, 2019 1:16 pm

BMV wrote:
Sat Jun 08, 2019 7:55 pm
I found a little bug in line 621 of the file: "bin\Install.reg"

Original line is:
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{3109CFE8-DCA4-4272-BD4E-605AF9D675A1}\HKEY_LOCAL_MACHINE\SOFTWARE\\{62C8FE65-4EBB-45e7-B440-6E39B2CDBF29}]

It have to be replaced with:
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{3109CFE8-DCA4-4272-BD4E-605AF9D675A1}\Implemented Categories\{62C8FE65-4EBB-45e7-B440-6E39B2CDBF29}]
Thanks for flagging this up @BMV. I have discovered that the error actually exists in 8.8.1, 8.8.2 and 8.8.3 and relates to the linkage to the Infra Red Remote control subsystem.

I created a zip file containing a corrected install.reg file and a script to patch an installed system. It is available here: https://www.dropbox.com/s/2bg6hlmcv49hi ... g.zip?dl=1.

As with the other things I have put up recently, just unzip it into the folder containing whichever WMC installer you are using. Allow it to overwrite the existing install.reg file so that future installs from that installer get the corrected version.

To patch an installed system, run fix_reg.cmd.

As always, I would recommend making a backup first - just to be safe.

BMV

Posts: 17
Joined: Wed Jun 05, 2019 7:46 am
Location:

HTPC Specs: Show details

#24

Post by BMV » Tue Jun 11, 2019 8:03 pm

Technodevotee, thanks for your help and input. Next week i have more time to install WMC-8.8.3 with your patches.
And of course you can post what i have found. The idea is to get a properly functioning Windows Media Center.
I'm only searching for a ready to use WMC-8.8.3 32-bit version.

technodevotee

Posts: 325
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#25

Post by technodevotee » Tue Jun 11, 2019 9:12 pm

BMV wrote:
Tue Jun 11, 2019 8:03 pm
The idea is to get a properly functioning Windows Media Center.
I'm only searching for a ready to use WMC-8.8.3 32-bit version.
My hybrid 64 bit WMC V12 installs and runs fine on every version of windows 10 I have tried it on as long as you replace the DLLs. The only things you can't do are to use cable cards and extenders.

I have installed 32 bit windows 10 1709 with the 32 bit V12 on one of my testbed PCs and am trying to see if I can replicate the steps I used before.

I won't be able to patch the files but it might be of use to some people if I can get it to install on later versions of Windows

BMV

Posts: 17
Joined: Wed Jun 05, 2019 7:46 am
Location:

HTPC Specs: Show details

#26

Post by BMV » Fri Jun 14, 2019 6:46 pm

I was free today and tried out your dll patch on a clean installation of Windows 10 1903 19H1 64-bit. And it all seems to work perfectly. Testing the 32-bit version is currently not possible, so that will come later. I'll let you know. Thank you a lot for all your help and input. And hopefully we can use Windows Media Center for a long time to come.

scott750

Posts: 27
Joined: Fri Nov 01, 2013 12:19 am
Location: Austin, TX

HTPC Specs: Show details

#27

Post by scott750 » Fri Jun 28, 2019 3:16 am

I'm having issues on my 2nd computer trying to run WMC 8.8.3. I just upgraded it from Win 7 Home to Win 10 1809 using a retail upgrade. Then immediately forced the 1903 upgrade. I instaled 8.8.3 and was able to replace the EncDec.dll and MSVidCtl.dll files, but when I replaced the CPfilters.dll and rebooted, the computer got hung up with the hour glass cursor that would never go away and nothing in Windows would respond. Had to reboot into safe mode and reinstate the original CPfilters.dll file. So then I used the Intelligent DLL Replacer, I'm finally able to complete WMC setup, but have no sound and won't play a recorded video or live TV. What am I missing here? Is it because I upgraded from Win 7? I didn't have this many problems on my laptop running Win 10 1903.

technodevotee

Posts: 325
Joined: Thu Sep 10, 2015 4:10 pm
Location: West Midlands

HTPC Specs: Show details

#28

Post by technodevotee » Sat Jun 29, 2019 5:56 am

I haven't had the problem you describe installing any version of WMC on a PC that was upgraded from Windows 7 so I can't say if that is the problem. However, I have had Windows 10 become unresponsive after an upgrade a couple of times even before trying to install WMC.

I've found that it is always best to leave it alone until it has finished installing all the modern apps and all the updates and restarted a couple of times before trying to install anything on it.

scott750

Posts: 27
Joined: Fri Nov 01, 2013 12:19 am
Location: Austin, TX

HTPC Specs: Show details

#29

Post by scott750 » Sat Jul 06, 2019 10:45 am

Update: I ended up clean reinstalling 1809 and re-installed WMC 8.8.3. I replaced the 3 dll files and WMC worked perfectly. Since I wanted to run 1903, I uninstalled WMC, updated to 1903, then reinstalled WMC and replaced the 3 dlls again. And again WMC worked flawlessly. Something about upgrading from win 7 to win 10 must have had fies or settings in a weird state. While the win u to win 10 1809 upgrade worked fine, WMC did not like something about it. But a clean install seems to always fix it. Just cost me a little time in resetup. No biggie as it was worth it to get WMC working again.

Post Reply