How do I disable version 1709 from auto installing?!

Discussion of getting WMC to work on Windows 10 (unsupported)
Post Reply
seanbperiod

Posts: 41
Joined: Tue Dec 30, 2014 12:56 am
Location:

HTPC Specs: Show details

How do I disable version 1709 from auto installing?!

#1

Post by seanbperiod » Sun Feb 25, 2018 9:31 pm

For the last 3 days, 1709 has been attempting to auto install on my machine. I've gone through the steps of uninstalling the Upgrade Assistant, stopping/disabling Windows Updates, and editing the Group Policy Manager, but the next day, I'll be watching something and it will just restart out of nowhere and attempt to install the update again and I have to reboot once it starts to interrupt it, then it auto restores to previous version, and I'll start the process all over again.

How can I stop this once and for all?!

User avatar
DavidinCT

Posts: 1434
Joined: Mon Feb 13, 2012 3:45 pm
Location:

HTPC Specs: Show details

#2

Post by DavidinCT » Mon Feb 26, 2018 3:02 pm

Start> Run> services.msc and select OK or hit enter. Find the Windows update service and disable it (once you open it, you will need to stop it before you can disable it), Reboot your computer and that should end it. This will disable Windows Updates completely. Never have to worry about a update again.

If you want to keep Windows updates running, you will need to take that 1709 update. If you want to run Windows Media Center, dump Windows 10 and install Windows 7...it's better anyway at running WMC.
-Dave
Twitter @TheCoolDave

Windows Media Center certified and WMC MVP 2010 - 2012

seanbperiod

Posts: 41
Joined: Tue Dec 30, 2014 12:56 am
Location:

HTPC Specs: Show details

#3

Post by seanbperiod » Tue Feb 27, 2018 1:11 am

Thanks, but I've done this- and Upgrade Assistant continues to automatically install and reenable everything again.

dkrom

Posts: 217
Joined: Mon Nov 17, 2014 11:39 pm
Location:

HTPC Specs: Show details

#4

Post by dkrom » Tue Feb 27, 2018 2:54 am

My sons computer would download a 3gig update every time he started the computer, then the update would fail EVERY SINGLE TIME! Win 10 is the worst (I know some love it, but I am NOT a fan). Anyway, in the firewall I blocked all incoming and outgoing traffic to the 9 files in the update folder. This is a video on it https://m.youtube.com/watch?v=5efeXjLYz8c

Then I disabled all the scheduled tasks for updates and uninstalled the updater. This was the video on it https://m.youtube.com/watch?v=MeHFM5H5CRw

No more updates!

I know some will probably comment that we should be updating, I've tried multiple times and multiple ways to install updates. I downloaded Win10 on a flash drive and tried to install from the flash drive as a startup (Win 10 says I must update from the HD running Win10) tried installing from the flash as Win10 asked - nope, fail. Basically we have to reinstall a fresh install of Win10 then reinstall all programs. Not something I feel like doing since it'll probably fail again anyway.

User avatar
joecrow

Posts: 191
Joined: Fri Oct 21, 2011 8:34 am
Location:

HTPC Specs: Show details

#5

Post by joecrow » Wed Feb 28, 2018 9:21 am

If you have Win 10 pro (I'm not sure about other versions you will have to try it yourself if you have Home) logon to an account with Admin. privs. and go to settings/Update & Security/Advanced options and set the "defer feature update option to 365, this will block 1709 from installing for up to a year while still allowing other updates to be downloaded and installed (see attached screenshot). After a year we can only hope that all the bugs have been fixed in 1709 and it can be safely installed or a more permanent block will need to be found ;) . BTW the "Some settings are managed by your organisation" indicates that I have disabled auto updates in Group Policy, updates only happen when I press the check for updates button. :D Google it for more info.
block.jpg

User avatar
Crash2009

Posts: 4357
Joined: Thu May 17, 2012 12:38 am
Location: Ann Arbor, Michigan

HTPC Specs: Show details

#6

Post by Crash2009 » Wed Feb 28, 2018 9:32 am

You might have to disable defender a well.

I suspect defender could be used to repair Critical Security Issues......come in the back door and turn updates on again.

SpencerC

Posts: 124
Joined: Sat Aug 15, 2015 1:35 am
Location:

HTPC Specs: Show details

#7

Post by SpencerC » Thu Mar 01, 2018 12:51 am

I woke up this morning and my PC was updated to 1709. I had the windows update service stopped and disabled. I did notice that a "Windows 10 Update Assistant" was recently installed and assume this utility performed the update for me. I reverted back. WMC is still installed but my tuner (HDHomeRun Prime with cable card) is no longer seen. I think this also got updated. I tried uninstalling the drivers and installing a known good driver. No luck. So now I am building a hyper-v Virtual Machine running Win7 and will run my WMC on that. Does anyone have experience with this? This is my first time trying this. Can you maximize the VM to watch WMC? Will sound transfer thru the VM to my headset?

Post Reply