Page 1 of 1

RecordedTV on network share randomly disappearing

Posted: Wed Feb 14, 2018 9:20 pm
by Bard78
I am running MCE on Win10. I have a network share that I move my recordings to. They will randomly not be visable in MCE under the "recorded TV" listings. If I close MCE and reopen it again they reappear and are listed properly. Any ideas?

Re: RecordedTV on network share randomly disappearing

Posted: Wed Feb 14, 2018 11:34 pm
by Crash2009
sleep/green settings? server/switch/client

hug the trees

Re: RecordedTV on network share randomly disappearing

Posted: Thu Feb 15, 2018 2:31 am
by Bard78
I've gone through the sleep settings on all the devices, that was my first thought, but thinking deeper about it, it doesn't really make sense - I can be actively watching a recorded show from the network share, and then delete it when it's finished and before I can choose the next episode, they all disappear. Close MCE and reopen, and they are all back. But I've definitely disabled all the sleep/energy efficiency settings and it's made no difference.

Re: RecordedTV on network share randomly disappearing

Posted: Thu Feb 15, 2018 4:00 am
by Bryan
What kind of network share is it? Another Windows machine, NAS, etc.? When Media Center can't see the recordings, can you see them in File Explorer on that machine? If it's the same there, my first guess from experience (at work, not with Media Center) would be a SMB client redirector cache issue; specifically, directory cache.

https://docs.microsoft.com/en-us/previo ... 0(v=ws.10)

Re: RecordedTV on network share randomly disappearing

Posted: Thu Feb 15, 2018 1:48 pm
by Crash2009
Bard78 wrote:a recorded show from the network share, and then delete it
If delete is always part of the issue, could this be an Indexing Problem..... either, in the share or the server?

Is that similar to Directory Cache?

Re: RecordedTV on network share randomly disappearing

Posted: Thu Feb 15, 2018 2:33 pm
by Bard78
It's an SMB share on a NAS - the MCE box and the NAS are plugged directly into the same switch. I am able to see the files in file explorer when media center is unable to see them. I'll dig into from the redirector cache angle - i hadn't gotten that far yet.

I disabled the client side caching and at first it didn't help, but after a reboot, and also switching to having the library point to a mapped drive instead of UNC path, it appears that files are staying visible in MCE. *crosses fingers*

Thanks for pointing me in the right direction!

Re: RecordedTV on network share randomly disappearing

Posted: Thu Feb 15, 2018 2:34 pm
by Bard78
Crash - delete wasn't always part of the problem, but it was definitely a way that I could almost always use to reproduce the issue.

*edit - sometimes after watching a show, going back to the show listings there would be nothing there, or if MCE has been up and running for a few days and we haven't used it, pulling up the recorded TV listing would be empty. It's strange to me that my music and photos aren't exhibiting the same behaviors, they are on the same NAS and are pointed via UNC path just like recorded TV was? Anyway - keeping my fingers crossed that disabling client side caching and changing to mapped drive for recorded tv did the trick.

Re: RecordedTV on network share randomly disappearing

Posted: Mon Feb 19, 2018 8:08 pm
by Bard78
So it looks like I spoke too soon and I'm still having this issue. Any other ideas?

Re: RecordedTV on network share randomly disappearing

Posted: Mon Feb 19, 2018 8:52 pm
by Crash2009
Maybe have a look into the SMB 1.0 issue.

Some versions of Win10 disable SMB 1.0 during their last update.

Re: RecordedTV on network share randomly disappearing

Posted: Mon Feb 19, 2018 9:18 pm
by Bard78
I did not have SMB 1 installed. I enabled it and the problem persists. Do I want to disable SMB direct?

Re: RecordedTV on network share randomly disappearing

Posted: Tue Feb 20, 2018 12:30 am
by Crash2009
Not sure..... the SMB thing was more of a hunch then a tried-and-true method. I believe that WMC uses SMB 1.0. Looks like Microsoft is going to drop SMB 1.0 eventually. Might be too early to affect this at the present time. Do a little reading on that SMB 1.0 I seem to remember there's a catch-22 in there.

Here is a link to a couple of us discussing this SMB 1.0. Jachin99 implies you can't join a workgroup anymore in win 10 1703

http://www.thegreenbutton.tv/forums/vie ... 28#p123528


Is your win 10 Network setup to use username and passwords?

I assume you could have username and password setup on the network share.

Something different you can try is 2 remove all your libraries in WMC and then add them back in the same way you had them.

Along the same lines you could try the 2nd Library setup option.. my libraries are stored on another PC that requires a username and password,

As I recall there are three methods in the library set up. I forget what the third one is.

Re: RecordedTV on network share randomly disappearing

Posted: Tue Feb 20, 2018 12:53 am
by Crash2009
There it is not a catch-22 it's more of a 15-day self-destruct mechanism

https://support.microsoft.com/en-nz/hel ... rsion-1709

Re: RecordedTV on network share randomly disappearing

Posted: Tue Feb 20, 2018 7:47 pm
by SpencerC
Have you tried mapping a drive letter to the share instead of using a UNC path and then changing the recording location to the new drive letter? just something to try and I don't know if it will help. I suggest this because I save my recordings to a different drive letter and I don't experience this.

Re: RecordedTV on network share randomly disappearing

Posted: Wed Feb 21, 2018 3:50 pm
by Crash2009
Crash2009 wrote:
Along the same lines you could try the 2nd Library setup option.. my libraries are stored on another PC that requires a username and password,

As I recall there are three methods in the library set up. I forget what the third one is.
Have you tried these "Other Setup Options"

Library Setup Option #

2) allows you to select a PC

3) allows you to setup a path/username/password

Re: RecordedTV on network share randomly disappearing

Posted: Wed Feb 28, 2018 3:16 pm
by DavidinCT
You could always MAP a network drive to a letter, go into Indexing options (search for it in 10), and ADD the drive letter to the index. Then add it to WMC. This solved a similar problem I had a while ago. Not the best option but, it worked.
SpencerC wrote:Have you tried mapping a drive letter to the share instead of using a UNC path and then changing the recording location to the new drive letter? just something to try and I don't know if it will help. I suggest this because I save my recordings to a different drive letter and I don't experience this.
Recording to a network share ? Bad idea... No question. Don't do this. You might not have problems now but, in time, you will miss recordings and get broken up video.

Re: RecordedTV on network share randomly disappearing

Posted: Mon Mar 19, 2018 3:47 pm
by Bard78
Sorry for the long delay on responses guys - I believe I've finally found my solution - I had tried all 3 of the options for adding the folder, and I was having issues with each.

When I first created my folder on my NAS, I created it as "Recorded TV" - I know, very origional.
In the script I made to move the files over to the NAS folder I apparently keyed in the folder as "recorded tv", no caps.
On my NAS, this made a second folder, which was not visible from the PC. I eventually found it when I got back into my NAS to completely remove/recreate the folder so all the permissions were fresh, thinking maybe something was wonky there. I saw both a "Recorded TV" folder and a "recorded tv" folder. This was obviously confusing the heck out of windows as the lowercase one had all the files in it, and the upper case one had nothing. When browsing from the PC/WMC all I ever saw was the uppercase one, and at first connection I could see the data, but it would just go away after a while.

So - I edited my script to say "Recorded TV" and now everything stays. no more issues. Thanks a ton for all the ideas guys, much appreciated!

Re: RecordedTV on network share randomly disappearing

Posted: Mon Mar 19, 2018 6:18 pm
by Crash2009
Now that the "Cat" is out of the bag, you have reminded me of a similar issue that I experienced in the past. I started out with the default "Recorded TV" on C:\Users\Public. Then, as I added additional local drives to the HTPC, I named the additional Recorded TV folders the same D:\Recorded TV, E:\..., F:\..., Etc

When changing the "Record To Drive" in WMC, it was a bit confusing, as the folders were all the same name, (even though the path's were different).

For simplicity sake, I renamed the additional Recorded TV folders with a number added.... Recorded TV2, Recorded TV3, etc. For me, this reduced mistakes when changing the Record To Folder within WMC.