Windows cannot open this program... restriction policy

Discussion of getting WMC to work on Windows 10 (unsupported)
Post Reply
French_lolo

Posts: 1
Joined: Sat Jan 06, 2018 3:36 pm
Location:

HTPC Specs: Show details

Windows cannot open this program... restriction policy

#1

Post by French_lolo » Sat Jan 06, 2018 3:45 pm

Hello,
After installed WMC10 on W10-64, when launching first, I have message box : "Windows cannot open this program because it has been prevented by a software restriction policy. For more information, cotact your system administrator".
I found some information to change something in the registry.

--> Browse to the following location: HKEY_CURRENT_USER, SOFTWARE, Policies, Microsoft, and select WindowsMediaCenter
On the list to the right look for an item named MediaCenter. If it is there, check the Data column and ensure it is set to zero [0 ]. If it isn’t double click on the item and enter the number zero [0 ] in the Value data field then press OK.

But I don't have WindowsMediaCenter under the location: HKEY_CURRENT_USER, SOFTWARE, Policies, Microsoft.
How can I solve this ?
Thank you.

Lolo

User avatar
DavidinCT

Posts: 1390
Joined: Mon Feb 13, 2012 3:45 pm
Location:

HTPC Specs: Show details
5+ Yrs TGB Veteran Microsoft MVP

#2

Post by DavidinCT » Sat Jan 06, 2018 7:49 pm

French_lolo wrote:Hello,
After installed WMC10 on W10-64, when launching first, I have message box : "Windows cannot open this program because it has been prevented by a software restriction policy. For more information, cotact your system administrator".
I found some information to change something in the registry.

--> Browse to the following location: HKEY_CURRENT_USER, SOFTWARE, Policies, Microsoft, and select WindowsMediaCenter
On the list to the right look for an item named MediaCenter. If it is there, check the Data column and ensure it is set to zero [0 ]. If it isn’t double click on the item and enter the number zero [0 ] in the Value data field then press OK.

But I don't have WindowsMediaCenter under the location: HKEY_CURRENT_USER, SOFTWARE, Policies, Microsoft.
How can I solve this ?
Thank you.

Lolo
What version of WMC did your install ? And Did you run the "test" permissions AND reboot before installing ?

Only time I have seen this in the past is where the installer person Rushed to get it installed and skipped over the test and didn't have to correct permissions to install OR had a really old version.

Make sure you have the NEWEST version, Re-download it... Right click on it and go to pproperties and select "UNBLOCK" (VERY IMPORTANT), THen Extract the file, Run test permissions, IF it opens to a command prompt right away, then you should be ok.. Just to be safe I would run the test as an administrator, then reboot your computer. After it reboots, install WMC.

I would select the uninstall option, clean up the files and retry with the directions above.
-Dave
Twitter @TheCoolDave

Windows Media Center certified and WMC MVP 2010 - 2012

Post Reply