WMC and Windows 10 creator update

Discussion of getting WMC to work on Windows 10 (unsupported)
Post Reply
User avatar
lachape_one

Posts: 72
Joined: Fri May 06, 2016 10:54 am
Location: Versailles, France

HTPC Specs: Show details

WMC and Windows 10 creator update

#1

Post by lachape_one » Fri Mar 24, 2017 9:10 pm

The new Windows 10 15063 (creator update) is released for slow ring Insiders today. Is there among some insider who installed it and test Windows Media Center ? We had some surprise this week with the damn KB4013429 and earlier last year when we found that V12 not compatible.
If someone can share his experience it can help the community thanks

User avatar
lachape_one

Posts: 72
Joined: Fri May 06, 2016 10:54 am
Location: Versailles, France

HTPC Specs: Show details

#2

Post by lachape_one » Sat Mar 25, 2017 5:35 am


hansolo89

Posts: 113
Joined: Sun Oct 27, 2013 8:41 pm
Location: California

HTPC Specs: Show details

#3

Post by hansolo89 » Sat Mar 25, 2017 6:12 am

that's good news if WMC works on next major update, hope for a better alternative, amazing that WMC is still one the best options after a decade of being a dead product, all MS really needed to do was integrate the new OTT options into WMC

User avatar
Crash2009

Posts: 4356
Joined: Thu May 17, 2012 12:38 am
Location: Ann Arbor, Michigan

HTPC Specs: Show details

#4

Post by Crash2009 » Sat Mar 25, 2017 6:30 am

WMC Version-Whatever works on just about any version of Win10. The problem is CableCard (CC) Tuners DON'T WORK. So, if you are in the US, OTA or Satellite is your only choice.

A large percentage of the population of the United States must use a CableCard. So, 14393 and the 150*** you mention are absolutely useless to them.

User avatar
lachape_one

Posts: 72
Joined: Fri May 06, 2016 10:54 am
Location: Versailles, France

HTPC Specs: Show details

#5

Post by lachape_one » Sun Mar 26, 2017 1:54 am

hansolo89 wrote:that's good news if WMC works on next major update, hope for a better alternative, amazing that WMC is still one the best options after a decade of being a dead product, all MS really needed to do was integrate the new OTT options into WMC
Totally agree

sophware

Posts: 3
Joined: Thu Apr 06, 2017 1:34 am
Location:

HTPC Specs: Show details

#6

Post by sophware » Thu Apr 06, 2017 12:17 pm

Crash2009 wrote:WMC Version-Whatever works on just about any version of Win10. The problem is CableCard (CC) Tuners DON'T WORK. So, if you are in the US, OTA or Satellite is your only choice.

A large percentage of the population of the United States must use a CableCard. So, 14393 and the 150*** you mention are absolutely useless to them.
Thanks (I'm in that large percentage). Is this true for all versions of Windows 10, even if I have an static older build, like LTSB 10240.17319?

User avatar
Crash2009

Posts: 4356
Joined: Thu May 17, 2012 12:38 am
Location: Ann Arbor, Michigan

HTPC Specs: Show details

#7

Post by Crash2009 » Fri Apr 07, 2017 6:38 am

I don't know about 10240 (likely it will work)

10586 definitely works. mine plays all the DRM we have here in 48103

bb193

Posts: 14
Joined: Thu Aug 04, 2016 8:41 am
Location:

HTPC Specs: Show details

#8

Post by bb193 » Sat Apr 08, 2017 2:44 pm

Mmmmm - I've updated one of my two Win 10 MCE machines to Creators update and MCE doesn't run. :(

I get a couple of errors in the event log:-
Faulting application name: ehshell.exe, version: 10.0.10134.0, time stamp: 0x556a7732
Faulting module name: KERNELBASE.dll, version: 10.0.15063.0, time stamp: 0x461a0ff5
Exception code: 0xe0434352
Fault offset: 0x0000000000069e08
Faulting process ID: 0x21f4
Faulting application start time: 0x01d2b07591005b7a
Faulting application path: C:\WINDOWS\ehome\ehshell.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report ID: 2c54f348-b2e2-4f73-b6c0-cb051305f77b
Faulting package full name:
Faulting package-relative application ID:
and also
Application: ehshell.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.InvalidOperationException
at MediaCenter.Store.SqlLite.SqlLiteErr.LogAndThrowException(Int32, System.String, System.Object[])
at MediaCenter.Store.SqlLite.ObjectStore.Open(System.String)
at MediaCenter.Store.SqlLite.ObjectStoreManager.Open(System.String, Boolean)
at Microsoft.MediaCenter.Store.ObjectStore.Open(System.String, System.String, System.String, System.Reflection.Assembly, Boolean)
I've tried uninstalling and reinstalling MCE, and I get the same faults.

I'm in the UK, using DVB-T (Freeview) and trying to install MCE version 10.0.10134.0. :(

User avatar
Crash2009

Posts: 4356
Joined: Thu May 17, 2012 12:38 am
Location: Ann Arbor, Michigan

HTPC Specs: Show details

#9

Post by Crash2009 » Sun Apr 09, 2017 1:45 am

10.0.10134v2.1 is as old as T-Rex. The key to identifying the version is the numbers after v

v2.1 was improved all the way up to v12

After v12 the next one is v8.5

The v8.*.* series went to v8.8.1 with v8.8.1 being the most recent and so far the final.

The v8.*.* series has the best un-installer. Try it and install v8.8.1 or even your v2.1 again. You should be OK after that, unless the O/S is chewed up as well.

Here is a link to the developers of WMC for Win10.

https://forums.mydigitallife.info/threa ... ost1026727

You need to become a member to see all the content at that site.

bb193

Posts: 14
Joined: Thu Aug 04, 2016 8:41 am
Location:

HTPC Specs: Show details

#10

Post by bb193 » Sun Apr 09, 2017 8:18 am

Thanks for the reply.
Incidentally, I found that my source of MCE was not the V10, but was actually 8.7 (to my shame, my records got a bit confused as I scrambled to make it work again after Anniversary update a year ago). I used the uninstall in 8.7 and reinstalled, and it seems to work perfectly now. I'll tidy up my records, and I'll also seek out 8.8.1 (https://forums.mydigitallife.info/threa ... ost1244333). It looks like MCE has survived another major update!

User avatar
Crash2009

Posts: 4356
Joined: Thu May 17, 2012 12:38 am
Location: Ann Arbor, Michigan

HTPC Specs: Show details

#11

Post by Crash2009 » Sun Apr 09, 2017 11:08 am

I hear ya. Here is an organizational tip for ya....Create the extract-to folder prior to extracting the WMC zip file, then select the extract-to folder during the extraction process. Short folder name was a requirement in some of the older versions.

The long file name, and, the change of file name format (different authors), create confusion.
Attachments
WinWmcVersion004.jpg

newappz

Posts: 6
Joined: Sun Dec 13, 2015 7:18 am
Location:

HTPC Specs: Show details

#12

Post by newappz » Fri Apr 14, 2017 2:57 pm

Please help! Is anyone have solution how to get Ceton InfiniTV 4 PCIe tuner working with Windows 10 creator edition. Problem is that Media center doesn't see tuner :( Thank you!

User avatar
Crash2009

Posts: 4356
Joined: Thu May 17, 2012 12:38 am
Location: Ann Arbor, Michigan

HTPC Specs: Show details

#13

Post by Crash2009 » Sat Apr 15, 2017 1:28 am

newappz wrote:Please help! Is anyone have solution how to get Ceton InfiniTV 4 PCIe tuner working with Windows 10 creator edition. Problem is that Media center doesn't see tuner :( Thank you!
Make sure to check all the links within this post.....

https://forums.mydigitallife.info/threa ... ost1334090

DavidG

Posts: 2
Joined: Sat Apr 15, 2017 5:31 am
Location:

HTPC Specs: Show details

#14

Post by DavidG » Sat Apr 15, 2017 6:21 am

Sadly on both my machines WMC_6.3.9600.16384_x64_v12 doesn't work on Windows 10 creators update.
I will follow the thread on https://forums.mydigitallife.info/threa ... ost1334090 to see if there is a fix
David

Just been reading the threads apparently the fix is to simply reinstall WMC - I will keep you posted

User avatar
Crash2009

Posts: 4356
Joined: Thu May 17, 2012 12:38 am
Location: Ann Arbor, Michigan

HTPC Specs: Show details

#15

Post by Crash2009 » Sat Apr 15, 2017 2:20 pm

Not quite.

Uninstall v12 with one of the v8 versions, (WMCv8.8.1 preferred) then, re-install with with any version. See Page #1/Release History/Spoiler

https://forums.mydigitallife.info/threa ... ost1026727

Port from Windows 8.1 Pro (Build 9600.16384)

Release Date

v12 X January 29, 2016
v11 X December 22, 2015
v10 X November 25, 2015
v10 X November 24, 2015
v9 X November 20, 2015
v8.8.1 August 12, 2016
v8.8 X August 11, 2016
v8.7 X August 7, 2016
v8.6 X July 12, 2016
v8.5 X July 6, 2016
DISM v0 X November 14, 2015
v8 X October 5, 2015
v7 X September 22, 2015
v6 X
v5 X
v4 X
v3 X
v3 X
v2 X
v1 X
v0 revised X September 12, 2015
v0 X September 9, 2015 Port from Windows 10 Insider Preview Build 10537.0
v0 X September 16, 2015 Port from Windows 10 Insider Preview Build 10134.0
v4 X
v3 X
v2.1 X September 7, 2015
v2 X
v0 revised X
v0 X September 5, 2015

DavidG

Posts: 2
Joined: Sat Apr 15, 2017 5:31 am
Location:

HTPC Specs: Show details

#16

Post by DavidG » Sat Apr 15, 2017 3:58 pm

Actually uninstalling with V12 and reinstalling works. It says windows corrected an error when you start setup, then a reboot, restart setup and it then completes without a problem. Both my machines exhibit same behaviour

User avatar
Crash2009

Posts: 4356
Joined: Thu May 17, 2012 12:38 am
Location: Ann Arbor, Michigan

HTPC Specs: Show details

#17

Post by Crash2009 » Sat Apr 15, 2017 4:14 pm

DavidG wrote:simply reinstall WMC
I guess I should have quoted to begin with.....

simply reinstall never works with any version

jazz_dude

Posts: 19
Joined: Tue Oct 25, 2016 10:35 pm
Location:

HTPC Specs: Show details

#18

Post by jazz_dude » Sat Apr 15, 2017 11:34 pm

re: uninstalling WMC on Windows 10: as well as using the uninstaller that comes in the MDL package, you should make sure the folder

C:\Windows\ehome

is empty, ditto the hidden folder

C:\ProgramData\Microsoft\eHome

In fact, I did all the above before upgrading with CU. Once CU was up and running I just ran the MDL v12 installer and everything was OK. I'm on UK Freeview using TBS6205 quad HD pci-e tuners on 2 * W10 Pro x64 boxes.

Post Reply