14/29 Framerate Bug On WMC Version 11

Discussion of getting WMC to work on Windows 10 (unsupported)
Post Reply
mustardbomb

Posts: 17
Joined: Tue Mar 22, 2016 1:48 pm
Location:

HTPC Specs: Show details

14/29 Framerate Bug On WMC Version 11

#1

Post by mustardbomb » Mon Nov 07, 2016 4:45 pm

Hello all, hoping someone will know what to do here. I upgraded my computer and used the same video card as in my old computer where everything was working, and I’m suddenly having an issue with the 14/29 bug where my framerate on live television fluctuates between 14.9 and 29.9. It does it especially bad on commercials and fast moving things like football games. It will usually start up in the commercials and calm down during the normal show. It also does it in any king of pre recorded skits like on SNL. It also seems to be much worse on NBC than other channels. I am using x64 Windows 10 Home and I am using the WMC11 version (worked fine before now on the old machine). I tried to get WMC12 to work but it installs, and then won’t launch when I click on the WMC icon, it does nothing.

I feel like this must be caused by the video driver somehow, but it was working fine before on the previous machine. I am using an Nvidia FeForce GT 740, and I’ve tried various version of its driver but no change. I haven’t installed any other codecs or anything, as I’ve never needed them, it always worked flawlessly using whatever comes with WMC. Does anyone have any idea what needs to be changed to fix this framerate bug? I tried to figure out what I need to do to disable any post-processing that my video card might be doing, but I don’t see anything to disable.

Here are the rest of my specs on the PC:
Core i5-2500 3.3GHZ
8GB System Ram
1TB HDD

Thanks in advance for any advice!

Space

Posts: 1556
Joined: Sun Jun 02, 2013 9:44 pm
Location:

HTPC Specs: Show details

#2

Post by Space » Tue Nov 08, 2016 12:32 am

You did not state what symptoms you are seeing. There is no fix for this bug, just alleviation of the symptoms. You will always see the frame rate fluctuation on content that is encoded that way (by looking at the debug screen in WMC).

Various symptoms are color "flashing", frame skipping during pans, and interlacing artifacts. These symptoms can often be alleviated by turning off some of the video enhancement for the graphics card, such as dynamic contrast on an ATI card (I don't have and Nvidia card, so not sure what settings need to be tweaked there).

Do a search for "29/59 bug" to find other settings that may work on Nvida cards, or I am sure someone with an Nvidia card will post here with some suggestions.

Unfortunately, there is no fix-all for this problem, and what works varies by what video card you have and perhaps other factors.

mustardbomb

Posts: 17
Joined: Tue Mar 22, 2016 1:48 pm
Location:

HTPC Specs: Show details

#3

Post by mustardbomb » Wed Nov 09, 2016 2:00 pm

Thank you for your response. The issue I was having was choppy playback due to the frame rate fluctuation. I actually got it working. I uninstalled Media Center, changed my computer's resolution to 720p, reinstalled Media Center (it also defaulted to 720p) and now it's fixed. The fluctuation is still there but isn't noticeable in the picture. I figured this out by hooking my old computer back up and seeing it was set at 720p and it didn't have the issue. I can only assume my video card (which I used in the old machine and moved to the new one) was chugging down because the new computer had defaulted to 1080p when I installed the card drivers, and as a result so did Media Center when I installed it. Anyway, if anyone else is having this issue, I'd suggest uninstalling Media Center and then changing your computer to resolution to 720p and reinstalling Media Center if you don't mind your computer being at 720p. I have it set up as a HTPC so I really don't care if it's 720p and can't tell any difference at the distance I'm viewing it. Worth it for free, smooth live TV playback and recording.

scrambler

Posts: 64
Joined: Sat Jul 23, 2011 9:38 pm
Location:

HTPC Specs: Show details

#4

Post by scrambler » Wed Nov 09, 2016 7:42 pm

If your card is an Nvidia, the fix is below
Open Nvidia Control panel > Adjust Desktop Settings > Select the TV (must be on to be visible) > Set “content type reported to the display” to “Full Screen Videos”.

Post Reply