Help with WMC Guide

Global guide related discussion. All Windows versions.
Post Reply
Anoniem

Posts: 14
Joined: Tue Oct 20, 2020 5:07 pm
Location:

HTPC Specs: Show details

Help with WMC Guide

#1

Post by Anoniem » Sun Apr 04, 2021 10:22 am

Can anybody help me out with the WMC epg guide.
its driving me nuts.

I got 2 issues:

I use the epg collector and it starts at 5:00 am and it runs every days, it works fine.
but in the evening when i watch live tv the guide gets suddenly empty.
The last couple of days when i start to watch live tv i have a filled epg and then after a couple of minutes its empty.

the second issue is when i ran the epg collector in the evening my tuner suddenly disapears.
i got 4 tuners but when i run epg collector i have 3 tuners.
The next day when i run epg collector, i have 2 tuners and so on.

hope someone can explain to my how the WMC epg works or can help me out.

prsa01

Posts: 43
Joined: Fri Dec 13, 2019 4:19 pm
Location:

HTPC Specs: Show details

#2

Post by prsa01 » Sun Apr 04, 2021 11:23 am

It will help if you provide more info.

Where are you?
What tuners?

From your description, I'm assuming you are pulling guide info from the broadcast stream. That works fine but the number of hours/days of guide info varies depending on btoadcaster (locale, channel, etc).

You may want to look at other guide sources to get more days of guide and better guide info. The most straightforward, for most parts of the world, is schedules direct combined with epg123. There is a whole section here dedicated to that setup.

If you want to stay with epgCollector, there are a number of different guide sources, again, depending on where you are in the world. Probably best to look for help over on their forum.

zap2xml is one guide source used in conjunction with epgCollector. There are threads here and on over on epgCollector site on how to set that up. It is significantly more complex then setting up epg123/SD, is expressly against the zap2it terms of use, and, is no longer supported. The next time zap2it changes their site it may stop working and currently no one is setup to fix it.

Unfortunately I don't have any idea why your tuners are disappearing n epgCollector. Someone over there may be able to help.

Anoniem

Posts: 14
Joined: Tue Oct 20, 2020 5:07 pm
Location:

HTPC Specs: Show details

#3

Post by Anoniem » Mon Apr 05, 2021 7:44 am

I live in the netherlands the cable company is ziggo and i have a 4 days epg.
I have a hdhomerun tuner with dvblogic (they stoppped) with acamd for the encrypted channels.
Its all installed on the same machine.

The epg from dvblogic uses EIT and that works fine

epg collector runs fine its updating every day at 5 am, and when its finished i got a fully epg.

but something its overwriting or setting the guide to an empty guide in the evening

maybe some processes or some registry settings?

unfortunately i cannot use 123epg because of schedules direct is not in the netherlands

Anoniem

Posts: 14
Joined: Tue Oct 20, 2020 5:07 pm
Location:

HTPC Specs: Show details

#4

Post by Anoniem » Mon Apr 05, 2021 10:57 am

Maybe i found it.
There was a services running hdhomerun WMC service.
I stopped it and disabled it.

Fingers crossed.


Verzonden vanaf mijn iPhone met Tapatalk

Anoniem

Posts: 14
Joined: Tue Oct 20, 2020 5:07 pm
Location:

HTPC Specs: Show details

#5

Post by Anoniem » Thu Apr 08, 2021 5:48 pm

It went fine but tonight i started WMC.
checked the guide and it was again empty
the days before i had no problems
i started epg collector to import the guide again.

is there anybody that can help me?
is it possible to use epg collector and 123epg to import the guide?
what triggers WMC to empty the guide?

prsa01

Posts: 43
Joined: Fri Dec 13, 2019 4:19 pm
Location:

HTPC Specs: Show details

#6

Post by prsa01 » Fri Apr 09, 2021 11:02 am

My best guess would be that WMC own guide update is still running. There are threads here on how to disable that.

If that isn't it I'm out of ideas.

Anoniem

Posts: 14
Joined: Tue Oct 20, 2020 5:07 pm
Location:

HTPC Specs: Show details

#7

Post by Anoniem » Sun Apr 11, 2021 9:13 am

I tried to search for the owner of the guide in the forum but did not find it.
I thought epg collector is the owner of the guide.
this morning again suddenly an empty guide

who's got the solution and can help me out?

User avatar
StinkyImp

Posts: 401
Joined: Thu May 11, 2017 7:53 pm
Location:

HTPC Specs: Show details

#8

Post by StinkyImp » Sun Apr 11, 2021 3:55 pm

Anoniem wrote:
Sun Apr 11, 2021 9:13 am
I tried to search for the owner of the guide in the forum but did not find it.
I thought epg collector is the owner of the guide.

who's got the solution and can help me out?
I don't believe the developer of EPG Collector uses this forum. He's the one that can help you the most.

The developer (owner) of EPG Collector is Steve Bickell.

The EPG Collector support forum is at https://sourceforge.net/p/epgcollector/ ... on/1125945

Chances are you'll get a more definitive response from there. ;)

Anoniem

Posts: 14
Joined: Tue Oct 20, 2020 5:07 pm
Location:

HTPC Specs: Show details

#9

Post by Anoniem » Sun Apr 11, 2021 4:15 pm

I'm sorry my english is not so good.

I meant by the owner what prsa01 said:
My best guess would be that WMC own guide update is still running. There are threads here on how to disable that.
how can i disable that?

User avatar
d00zah

Posts: 160
Joined: Fri Nov 07, 2014 7:20 pm
Location:

HTPC Specs: Show details

#10

Post by d00zah » Sun Apr 11, 2021 4:47 pm

Try unchecking everything under WMC Settings > General > Automatic Download Options & save.

Anoniem

Posts: 14
Joined: Tue Oct 20, 2020 5:07 pm
Location:

HTPC Specs: Show details

#11

Post by Anoniem » Mon Apr 12, 2021 4:27 pm

d00zah wrote:
Sun Apr 11, 2021 4:47 pm
Try unchecking everything under WMC Settings > General > Automatic Download Options & save.
both options are uncheck

mwpeterson

Posts: 87
Joined: Sun Jul 31, 2016 11:55 pm
Location:

HTPC Specs: Show details

#12

Post by mwpeterson » Mon Apr 12, 2021 9:38 pm

When you setup your tv signal in WMC, you need to make sure you do NOT agree to the Program Guide Terms of Service.

unclebun

Posts: 92
Joined: Sun Jul 09, 2017 11:06 pm
Location:

HTPC Specs: Show details

#13

Post by unclebun » Tue Apr 13, 2021 12:38 pm

mwpeterson wrote:
Mon Apr 12, 2021 9:38 pm
When you setup your tv signal in WMC, you need to make sure you do NOT agree to the Program Guide Terms of Service.
What this means is you have to go through the TV Setup in WMC again, and when you get to the screen with the Program Guide Terms of Service, do not agree.

Anoniem

Posts: 14
Joined: Tue Oct 20, 2020 5:07 pm
Location:

HTPC Specs: Show details

#14

Post by Anoniem » Tue Apr 13, 2021 5:41 pm

unclebun wrote:
Tue Apr 13, 2021 12:38 pm
mwpeterson wrote:
Mon Apr 12, 2021 9:38 pm
When you setup your tv signal in WMC, you need to make sure you do NOT agree to the Program Guide Terms of Service.
What this means is you have to go through the TV Setup in WMC again, and when you get to the screen with the Program Guide Terms of Service, do not agree.
I think i already did that but afterwards i did not get the guide, i only have recordings and live tv.
Maybe i can use 123epg client to backup WMC, then rebuild the database?

User avatar
garyan2

Posts: 5917
Joined: Fri Nov 27, 2015 7:23 pm
Location:

HTPC Specs: Show details

#15

Post by garyan2 » Tue Apr 13, 2021 11:19 pm

Anoniem wrote:
Tue Apr 13, 2021 5:41 pm
I think i already did that but afterwards i did not get the guide, i only have recordings and live tv.
If you deny the Program Guide ToS, you will need to manually set some registry values for the Guide option to appear.
guidereg.png
- Gary
Keeping WMC alive beyond January 2020. http://epg123.garyan2.net

Anoniem

Posts: 14
Joined: Tue Oct 20, 2020 5:07 pm
Location:

HTPC Specs: Show details

#16

Post by Anoniem » Sat Apr 17, 2021 7:19 am

garyan2 wrote:
Tue Apr 13, 2021 11:19 pm
Anoniem wrote:
Tue Apr 13, 2021 5:41 pm
I think i already did that but afterwards i did not get the guide, i only have recordings and live tv.
If you deny the Program Guide ToS, you will need to manually set some registry values for the Guide option to appear.
guidereg.png
I did what you said.
The guide is now up and running.
I hope it stays so.

thanks to everyone

Post Reply