Page 5 of 6

Re: myForecast weather addin

Posted: Sat Mar 07, 2020 4:38 am
by nelinory
myForecast v1.0.8 release.

Enhancements
- Added support for Tsl 1.2 protocol when calling Dark Sky ® API (Dark Sky ® API removed support for Tsl 1.0 and Tsl 1.1 which broke the old version)

Links at GitHub
- Introduction, configuration and source code: https://github.com/nelinory/myForecast (README.md is your friend)
- Download the latest release: https://github.com/nelinory/myForecast/releases

Re: myForecast weather addin

Posted: Mon Mar 09, 2020 11:29 am
by aquadextrous
Thank you for the update, all working perfectly here :)
Great to see more add-ons still being supported :thumbup: :thumbup: :thumbup:

Re: myForecast weather addin

Posted: Mon Mar 09, 2020 7:58 pm
by stuartm
I installed your latest release but all I get is a popup about a Catastrophic Error and nothing else. The log just shows
repeatedly:
03/09/2020 13:41:28.992 Error The requested security protocol is not supported.
Stack: at System.Net.ServicePointManager.set_SecurityProtocol(SecurityProtocolType value)
at myForecast.WeatherModel.LoadWeatherData()

Re: myForecast weather addin

Posted: Wed Mar 11, 2020 12:03 am
by nelinory
stuartm wrote:
Mon Mar 09, 2020 7:58 pm
I installed your latest release but all I get is a popup about a Catastrophic Error and nothing else. The log just shows
repeatedly:
03/09/2020 13:41:28.992 Error The requested security protocol is not supported.
Stack: at System.Net.ServicePointManager.set_SecurityProtocol(SecurityProtocolType value)
at myForecast.WeatherModel.LoadWeatherData()
Hello stuartm,

I am surprised that you get this error with the latest v1.0.8 release - it happen on the previous v1.0.7 because Dark Sky ® API started rejecting requests with security settings Tls 1.0.
Well I have made a small hotfix v1.0.9 which only supports Tls 1.2 per Dark Sky ® API suggestions. Can you give it a try ?
Tested the release on my own WMC Windows 7 Home Premium and my test-bed WIndows 7 Pro with MCE.

Enhancements
- Removed support for Tls 1.0 and Tls 1.1. When calling Dark Sky ® API only Tls 1.2 will be used.

Links at GitHub
- Introduction, configuration and source code: https://github.com/nelinory/myForecast (README.md is your friend)
- Download the latest release: https://github.com/nelinory/myForecast/releases

Re: myForecast weather addin

Posted: Wed Mar 11, 2020 5:32 am
by stuartm
The 1.0.9 version behaves exactly the same. Perhaps the installer is not overwriting the old version with the new version? However I also tried doing an uninstall followed by an install and still no difference.

Re: myForecast weather addin

Posted: Fri Mar 13, 2020 8:50 pm
by stuartm
This was fixed with nelinory's help. He provided a debug version and it showed my system did not support TLS 1.2 This was because I long ago stopped allowing updates to my win 7 systems that were my HTPC's. I manually added KB3154518 to my HTPC systems and then the v1.0.8 release of myForecast started working properly. Thanks to nelinory for his kind help in solving this problem.

Re: myForecast weather addin

Posted: Sat Mar 14, 2020 3:12 am
by nelinory
myForecast v1.0.9 release.

Credits
Special thanks to stuartm for all the help with Tls 1.2 related error :thumbup:

Enhancements
- Removed support for Tls 1.0 and Tls 1.1. When calling Dark Sky ® API only Tls 1.2 will be used.
- Added application version to the log file entry.
- Added Tls 1.2 validation routine.
- Improved the error handling when Tls 1.2 is not supported on the host.
- Updated myForecast requirements with information of how to fix Tls 1.2 error.

Links at GitHub
- Introduction, configuration and source code: https://github.com/nelinory/myForecast (README.md is your friend)
- Download the latest release: https://github.com/nelinory/myForecast/releases

Re: myForecast weather addin

Posted: Wed Apr 01, 2020 1:49 pm
by nelinory
myForecast update:

Dark Sky ® API company have been acquired by Apple.
As of 04/01/2020 Dark Sky ® API does not accepts new sign ups. The existing API keys will function through the end of 2021.
Looking for a replacement weather API (need ~400 free calls per day + current weather + 5 days forecast + weather alerts). Any suggestions are welcome.

Re: myForecast weather addin

Posted: Wed Apr 01, 2020 2:40 pm
by jachin99
Would open weather map work? https://openweathermap.org/price

Re: myForecast weather addin

Posted: Wed Apr 01, 2020 8:56 pm
by AJNegron

Re: myForecast weather addin

Posted: Thu Apr 02, 2020 1:20 pm
by DaveInPa
stuartm wrote:
Fri Mar 13, 2020 8:50 pm
This was fixed with nelinory's help. He provided a debug version and it showed my system did not support TLS 1.2 This was because I long ago stopped allowing updates to my win 7 systems that were my HTPC's. I manually added KB3154518 to my HTPC systems and then the v1.0.8 release of myForecast started working properly. Thanks to nelinory for his kind help in solving this problem.
I am in a similar situation. I stopped updates a long time ago.
Where did you find KB3154518? I am not able to find it. It looks like it was absorbed in a later update.

Re: myForecast weather addin

Posted: Thu Apr 02, 2020 1:32 pm
by nelinory
DaveInPa wrote:
Thu Apr 02, 2020 1:20 pm
stuartm wrote:
Fri Mar 13, 2020 8:50 pm
This was fixed with nelinory's help. He provided a debug version and it showed my system did not support TLS 1.2 This was because I long ago stopped allowing updates to my win 7 systems that were my HTPC's. I manually added KB3154518 to my HTPC systems and then the v1.0.8 release of myForecast started working properly. Thanks to nelinory for his kind help in solving this problem.
I am in a similar situation. I stopped updates a long time ago.
Where did you find KB3154518? I am not able to find it. It looks like it was absorbed in a later update.
I have posted the link on GitHub myForecast page - "Requirements" section. Here is the link: https://support.microsoft.com/en-us/hel ... -framework

Re: myForecast weather addin

Posted: Thu Apr 02, 2020 2:54 pm
by jachin99
Might not be helpful for those outside of the US but the national weather service has a weather API. https://api.weather.gov/

Re: myForecast weather addin

Posted: Thu Apr 02, 2020 5:00 pm
by stuartm
I think that is the actual link to get to the API. This link is for info about using the API: https://www.weather.gov/documentation/services-web-api

Re: myForecast weather addin

Posted: Thu Apr 09, 2020 1:35 pm
by nelinory
It appears that the https://openweathermap.org have a nice free tier - thanks jachin99 for the tip. They also provide an easy way/guide to migrate from DarkSky API calls to OpenWeatherMap API calls. I will build a myForecast prototype using OpenWeatherMap API as weather provider and see how it goes.

Re: myForecast weather addin

Posted: Sun May 17, 2020 2:24 pm
by nelinory
myForecast v1.1.0 release.

Enhancements
- Replaced Dark Sky ® API with OpenWeather ® API, due to Dark Sky ® API discontinuing the free access after been acquired by Apple.
- Rain/Snow precipitation is shown in inches/mm based on the weather units. It is expected precipitation by volume not probability of precipitation (not available in OpenWeather ® API).
- Weather alerts are provided by National Weather Service (https://www.weather.gov) and they are only available for location coordinates within continental US.

Note
- myForecast v1.0.9 should work fine until the end of 2021 when the Dark Sky ® API will be shutdown. Upgrade to OpenWeather ® API version is not required at this time.

Links at GitHub
- Introduction, configuration and source code: https://github.com/nelinory/myForecast (README.md is your friend)
- Download the latest release: https://github.com/nelinory/myForecast/releases

Re: myForecast weather addin

Posted: Thu May 28, 2020 11:28 am
by boxcar32
Thanks for the Apple info. Guess I will have to redo my python weather script for my lcd 2x20 screen using openweather.

Re: myForecast weather addin

Posted: Sun Sep 06, 2020 12:09 pm
by vanleeuwen
Anyone else getting Invalid API Key message with a valid API?

I checked again and API matches the default api from my account but still get error. Was working before on v1.1.0

Re: myForecast weather addin

Posted: Tue Sep 22, 2020 2:26 pm
by nelinory
vanleeuwen wrote:
Sun Sep 06, 2020 12:09 pm
Anyone else getting Invalid API Key message with a valid API?

I checked again and API matches the default api from my account but still get error. Was working before on v1.1.0
My Forecast v1.1.0 works fine. Do you still have an issue with the API key ? You can use the following URL (just replace XXXXXXXXX with your API key) to test if the key works:

Code: Select all

https://api.openweathermap.org/data/2.5/onecall?lat=40.7127&lon=-74.0059&exclude=minutely&appid=XXXXXXXXX&lang=us&units=imperial

Re: myForecast weather addin

Posted: Mon Oct 12, 2020 5:37 pm
by nelinory
myForecast v1.1.1 release.

Enhancements
- OpenWeather ® API now provides "Probability of precipitation" in percentage. Expected precipitation by volume is replaced with probability of precipitation (POP) on the daily/hourly forecast screen.
- Updated the weather alerts functionality to use the new OpenWeather ® API weather alerts data.

Links at GitHub
- Introduction, configuration and source code: https://github.com/nelinory/myForecast (README.md is your friend)
- Download the latest release: https://github.com/nelinory/myForecast/releases