myForecast weather addin

Romain

Posts: 6
Joined: Tue Sep 23, 2014 1:56 pm
Location:

HTPC Specs: Show details

Re: myForecast weather addin

#61

Post by Romain » Mon Mar 07, 2016 10:44 am

perfect
thank you

nelinory

Posts: 36
Joined: Mon Jan 18, 2016 4:18 am
Location:

HTPC Specs: Show details

#62

Post by nelinory » Tue Apr 12, 2016 2:59 pm

myForecast v1.0.3 release.

Enhancements
- Redesigned the application to support localization. French translation is provided by Romain.
- myForecast now will request the weather data from WeatherUnderground API(R) using the selected language.
- Replaced the default application icon in MCE extras menu and the start menu strip with a new one by d3stroy(weezle icon set).

Bugfixes
- Fixed an issue when removing the decimal point from the current temperature (thanks to stuartm and Embiggens)
- Removed the complicated (buggy) logic for the forecast tile, now the title is just named "Forecast"

Links at GitHub
- Introduction, configuration and source code: https://github.com/nelinory/myForecast (README.md is your friend)
- Download the latest release: https://github.com/nelinory/myForecast/releases

User avatar
Scallica

Posts: 2562
Joined: Mon Jun 06, 2011 7:09 pm
Location: USA!

HTPC Specs: Show details
5+ Yrs TGB Veteran Staff

#63

Post by Scallica » Wed Apr 13, 2016 8:09 pm

^Wow, great job! I love the new Sun icon. The only cosmetic issue I see is in the settings area. The Save, Cancel, and About buttons overlap the adjacent text.
HTPC Enthusiast / Forum Moderator - TGB.tv Code of Conduct

DaveInPa

Posts: 70
Joined: Fri Oct 30, 2015 3:56 pm
Location:

HTPC Specs: Show details

#64

Post by DaveInPa » Thu Apr 14, 2016 12:47 pm

I just updated to 1.0.3 and I like the improvements. Thanks!

nelinory

Posts: 36
Joined: Mon Jan 18, 2016 4:18 am
Location:

HTPC Specs: Show details

#65

Post by nelinory » Thu Apr 14, 2016 2:13 pm

Scallica wrote:^Wow, great job! I love the new Sun icon. The only cosmetic issue I see is in the settings area. The Save, Cancel, and About buttons overlap the adjacent text.
Hello Scallica,

Are you having the overlap issue on an extender ? Can you provide more information like the resolution of the device/brand name and maybe a screenshot ?
I would like to fix the settings screen if possible (it does looks fine on both Media Center servers I have).

User avatar
Scallica

Posts: 2562
Joined: Mon Jun 06, 2011 7:09 pm
Location: USA!

HTPC Specs: Show details
5+ Yrs TGB Veteran Staff

#66

Post by Scallica » Thu Apr 14, 2016 4:28 pm

nelinory wrote:Are you having the overlap issue on an extender ? Can you provide more information like the resolution of the device/brand name and maybe a screenshot ?
I would like to fix the settings screen if possible (it does looks fine on both Media Center servers I have).
No, I am using a 20" Dell widescreen monitor (2007WFP) connected directly to the HTPC, resolution is 1680x1050.
Attachments
weather-settings.jpg
HTPC Enthusiast / Forum Moderator - TGB.tv Code of Conduct

nelinory

Posts: 36
Joined: Mon Jan 18, 2016 4:18 am
Location:

HTPC Specs: Show details

#67

Post by nelinory » Sat Jun 04, 2016 2:33 am

myForecast v1.0.4 release.

Enhancements
- N/A

Bugfixes
- Updated the application layout to render better on 16:10 displays (example: 1680x1050 resolution, thanks to Scallica)

Links at GitHub
- Introduction, configuration and source code: https://github.com/nelinory/myForecast (README.md is your friend)
- Download the latest release: https://github.com/nelinory/myForecast/releases

nelinory

Posts: 36
Joined: Mon Jan 18, 2016 4:18 am
Location:

HTPC Specs: Show details

#68

Post by nelinory » Sat Jan 14, 2017 6:44 pm

myForecast v1.0.5 release.

Enhancements
- Minor updates to the English and French localization.
- Forecast tile captions will now be correctly localized based on the selected language.

Bugfixes
- Fixed the current forecast/hourly forecast icons. Night time forecast will use the night version of the icons.

Links at GitHub
- Introduction, configuration and source code: https://github.com/nelinory/myForecast (README.md is your friend)
- Download the latest release: https://github.com/nelinory/myForecast/releases

nelinory

Posts: 36
Joined: Mon Jan 18, 2016 4:18 am
Location:

HTPC Specs: Show details

#69

Post by nelinory » Tue Mar 12, 2019 2:41 pm

WeatherUnderground discontinued (Thanks Space :) ) free API accounts as of 03/01/2019 (myForecast stopped working on my MCE server as of 03/08/2019). I am investigating a replacement weather API. So far I am leaning towards darksky weather API since it have a very similar weather response structure to WeatherUnderground API so the changes should not be that much.
Last edited by nelinory on Wed Mar 13, 2019 1:58 pm, edited 2 times in total.

Space

Posts: 1506
Joined: Sun Jun 02, 2013 9:44 pm
Location:

HTPC Specs: Show details

#70

Post by Space » Wed Mar 13, 2019 9:07 am

I believe you meant "discontinued" not "discounted".

nelinory

Posts: 36
Joined: Mon Jan 18, 2016 4:18 am
Location:

HTPC Specs: Show details

#71

Post by nelinory » Tue Mar 26, 2019 1:48 pm

myForecast v1.0.6 release.

Enhancements
- Replaced WeatherUnderground ® API with Dark Sky ® API, due to WeatherUnderground ® API discontinuing the free access.
- All weather icons are provided by d3stroy (https://www.deviantart.com/d3stroy - weezle icon set)

Bugfixes
- N/A

Links at GitHub
- Introduction, configuration and source code: https://github.com/nelinory/myForecast (README.md is your friend)
- Download the latest release: https://github.com/nelinory/myForecast/releases

john9kover

Posts: 21
Joined: Thu Apr 07, 2016 10:30 pm
Location:

HTPC Specs: Show details

#72

Post by john9kover » Tue Mar 26, 2019 6:34 pm

Ok I tried it, in WMC it says "invalid application" unable to launch "myforecast". No problem install, puts weather in the menu. I get the error when I try to run it.
below is what I am running to help you out in case the error is my end.
Running Win7 SP1 x64. ehshell ver. 6.1.7600.16385

nelinory

Posts: 36
Joined: Mon Jan 18, 2016 4:18 am
Location:

HTPC Specs: Show details

#73

Post by nelinory » Tue Mar 26, 2019 11:24 pm

john9kover wrote:
Tue Mar 26, 2019 6:34 pm
Ok I tried it, in WMC it says "invalid application" unable to launch "myforecast". No problem install, puts weather in the menu. I get the error when I try to run it.
below is what I am running to help you out in case the error is my end.
Running Win7 SP1 x64. ehshell ver. 6.1.7600.16385
Thank you john9kover for the information. You found a bug :oops: which happens when myForecast is installed on a new WMC machine without existing configuration from the previous version of myForecast. This is fixed now, integration tests are updated to accommodate this case and the setup file was rebuilt. Please, redownload the v1.0.6 from https://github.com/nelinory/myForecast/releases and try again.

nelinory

Posts: 36
Joined: Mon Jan 18, 2016 4:18 am
Location:

HTPC Specs: Show details

#74

Post by nelinory » Tue Mar 26, 2019 11:34 pm

myForecast v1.0.6 release (better luck the second time :) ).

Enhancements
- Replaced WeatherUnderground ® API with Dark Sky ® API, due to WeatherUnderground ® API discontinuing the free access.
- All weather icons are provided by d3stroy (https://www.deviantart.com/d3stroy - weezle icon set)
- On fresh installation the configuration defaults to New Your, NY. When the application is executed for first time it will ask for the API key from Dark Sky API.

Bugfixes
- Fixed a bug when myForecast is installed on a new WMC machine without existing configuration from the previous version of myForecast. (thanks to john9kover for reporting it)

Links at GitHub
- Introduction, configuration and source code: https://github.com/nelinory/myForecast (README.md is your friend)
- Download the latest release: https://github.com/nelinory/myForecast/releases

john9kover

Posts: 21
Joined: Thu Apr 07, 2016 10:30 pm
Location:

HTPC Specs: Show details

#75

Post by john9kover » Wed Mar 27, 2019 10:21 pm

ok getting closer to working. Install fine, registered and put the key in. Now only shows loading weather data and the error invalid application.

sometimes it shows loading weather data and error while connecting to dark sky.

nelinory

Posts: 36
Joined: Mon Jan 18, 2016 4:18 am
Location:

HTPC Specs: Show details

#76

Post by nelinory » Thu Mar 28, 2019 4:02 pm

myForecast v1.0.7 release.

Enhancements
- Improved the formatting of the Probability of Precipitation value
- Selected the correct Min/Max temperature from the response to match the DarkSky website values

Bugfixes
- Fixed a bug with incorrectly parsing decimals under different regional settings like Dutch (Netherlands), due to the decimal separator from Dark Sky API response always being a comma, example: 32.34 (thanks to Alex Kelder)

Links at GitHub
- Introduction, configuration and source code: https://github.com/nelinory/myForecast (README.md is your friend)
- Download the latest release: https://github.com/nelinory/myForecast/releases

vanleeuwen

Posts: 1
Joined: Mon Apr 01, 2019 4:45 am
Location:

HTPC Specs: Show details

#77

Post by vanleeuwen » Mon Apr 01, 2019 4:49 am

Works well, thanks for fixing it :)

nelinory

Posts: 36
Joined: Mon Jan 18, 2016 4:18 am
Location:

HTPC Specs: Show details

#78

Post by nelinory » Mon Apr 01, 2019 10:05 pm

john9kover wrote:
Wed Mar 27, 2019 10:21 pm
ok getting closer to working. Install fine, registered and put the key in. Now only shows loading weather data and the error invalid application.

sometimes it shows loading weather data and error while connecting to dark sky.
john9kover, I sent you a private board message requesting some details that can help me troubleshoot the issue you are experience with MyForecast.

Another thing you can try is to delete everything in the folder C:\Users<YOUR USER NAME>\Documents\myForecast and then run the myForecast app thru MCE. This way it will load the default settings and a location New York, NY. You will have to enter your API key again.

john9kover

Posts: 21
Joined: Thu Apr 07, 2016 10:30 pm
Location:

HTPC Specs: Show details

#79

Post by john9kover » Sun Apr 07, 2019 12:24 am

ok deleted myforecast from docs and reinstalled myforecast (just in case) and now it works thanks.

oakley516

Posts: 103
Joined: Sun Mar 16, 2014 9:59 pm
Location: LI, NY

HTPC Specs: Show details

#80

Post by oakley516 » Wed Apr 10, 2019 3:10 am

Thanks for this :thumbup:

Post Reply