Media Center Calendar Addin

.Nico

Posts: 111
Joined: Fri Jun 10, 2011 9:59 am
Location: Maarssen - the Netherlands

HTPC Specs: Show details

Re: Media Center Calendar Addin

#41

Post by .Nico » Sat Dec 03, 2011 3:37 pm

It works! thank you very much. Any chance it is going to work on an Exchange 2007 server with SP1, maybe via the EWS method?

.Nico

sccrgoalie1

Posts: 317
Joined: Fri Jul 08, 2011 5:52 pm
Location:

HTPC Specs: Show details

#42

Post by sccrgoalie1 » Sat Dec 03, 2011 4:17 pm

.Nico wrote:It works! thank you very much. Any chance it is going to work on an Exchange 2007 server with SP1, maybe via the EWS method?

.Nico
Are you currently getting an error trying to use exchange? It should already support Exchange 07 SP1 and up using Exchange Web Services. It requires Autodiscover be setup on the server, but otherwise should be good to go. If you are getting an error please provide it here.

milli260876

Posts: 726
Joined: Wed Jun 08, 2011 2:56 pm
Location: Barnsley Sth Yorks

HTPC Specs: Show details

#43

Post by milli260876 » Sat Dec 03, 2011 8:44 pm

it kinda works for me with gmail but it throws an error every time it loads...
Also you can only view this month and all day reminders don't show....
here's my log

https://skydrive.live.com/redir.aspx?ci ... rEzyJjYxS0

nice work so far tho mate!!!
Lee

sccrgoalie1

Posts: 317
Joined: Fri Jul 08, 2011 5:52 pm
Location:

HTPC Specs: Show details

#44

Post by sccrgoalie1 » Sat Dec 03, 2011 9:05 pm

milli260876 wrote:it kinda works for me with gmail but it throws an error every time it loads...
Also you can only view this month and all day reminders don't show....
here's my log

https://skydrive.live.com/redir.aspx?ci ... rEzyJjYxS0

nice work so far tho mate!!!
I'll take a look and get that error figured out. All day appointments do show (probably not for you because of the error). You can view next and previous months by clicking skip forward/backward on the remote or ctrl f/b on the keyboard.

milli260876

Posts: 726
Joined: Wed Jun 08, 2011 2:56 pm
Location: Barnsley Sth Yorks

HTPC Specs: Show details

#45

Post by milli260876 » Sat Dec 03, 2011 9:10 pm

sound, the all day events are my shifts for the wife to see... main reason i want it on to be honest!!!
Lee

sccrgoalie1

Posts: 317
Joined: Fri Jul 08, 2011 5:52 pm
Location:

HTPC Specs: Show details

#46

Post by sccrgoalie1 » Sat Dec 03, 2011 9:21 pm

milli260876 wrote:sound, the all day events are my shifts for the wife to see... main reason i want it on to be honest!!!
There is a 1.1.7-beta version on the skydrive now. Uninstall the old, let me know if it works. I don't use google calendar but just tested an all day appointment and appears to be working.

https://skydrive.live.com/#cid=FC502126 ... 22C3%21282

milli260876

Posts: 726
Joined: Wed Jun 08, 2011 2:56 pm
Location: Barnsley Sth Yorks

HTPC Specs: Show details

#47

Post by milli260876 » Sun Dec 04, 2011 1:25 pm

nope, still not working and i can't skip thru months either... i'm going to try import the calendar to windows live...
just got a wp7 and have done my contacts so i'll have a look at the calendar
Lee

milli260876

Posts: 726
Joined: Wed Jun 08, 2011 2:56 pm
Location: Barnsley Sth Yorks

HTPC Specs: Show details

#48

Post by milli260876 » Sun Dec 04, 2011 1:48 pm

set windows live to view gmail thru ical importation and no more issues!!
great work mate!!!
thanks for this
Lee

.Nico

Posts: 111
Joined: Fri Jun 10, 2011 9:59 am
Location: Maarssen - the Netherlands

HTPC Specs: Show details

#49

Post by .Nico » Wed Dec 07, 2011 12:30 pm

sccrgoalie1 wrote:
.Nico wrote:It works! thank you very much. Any chance it is going to work on an Exchange 2007 server with SP1, maybe via the EWS method?

.Nico
Are you currently getting an error trying to use exchange? It should already support Exchange 07 SP1 and up using Exchange Web Services. It requires Autodiscover be setup on the server, but otherwise should be good to go. If you are getting an error please provide it here.
I do get an error, the most part in Dutch ;) about JIT, but the interesting message is: 'Operation must be performed on application thread'

.Nico

sccrgoalie1

Posts: 317
Joined: Fri Jul 08, 2011 5:52 pm
Location:

HTPC Specs: Show details

#50

Post by sccrgoalie1 » Wed Dec 07, 2011 1:36 pm

.Nico wrote:
sccrgoalie1 wrote:
.Nico wrote:It works! thank you very much. Any chance it is going to work on an Exchange 2007 server with SP1, maybe via the EWS method?

.Nico
Are you currently getting an error trying to use exchange? It should already support Exchange 07 SP1 and up using Exchange Web Services. It requires Autodiscover be setup on the server, but otherwise should be good to go. If you are getting an error please provide it here.
I do get an error, the most part in Dutch ;) about JIT, but the interesting message is: 'Operation must be performed on application thread'

.Nico
There is a 1.1.7-beta version on the skydrive now. Uninstall the old, let me know if it works. The error you mention above should be gone, let me know if there is a new one.

.Nico

Posts: 111
Joined: Fri Jun 10, 2011 9:59 am
Location: Maarssen - the Netherlands

HTPC Specs: Show details

#51

Post by .Nico » Wed Dec 07, 2011 4:53 pm

There is a 1.1.7-beta version on the skydrive now. Uninstall the old, let me know if it works. The error you mention above should be gone, let me know if there is a new one.
Sorry,
[img]
http://www.click2record.com/images/MCEcalendar01.png
[/img]

.Nico

sccrgoalie1

Posts: 317
Joined: Fri Jul 08, 2011 5:52 pm
Location:

HTPC Specs: Show details

#52

Post by sccrgoalie1 » Wed Dec 07, 2011 5:14 pm

.Nico wrote:
There is a 1.1.7-beta version on the skydrive now. Uninstall the old, let me know if it works. The error you mention above should be gone, let me know if there is a new one.
Sorry,
[img]
http://www.click2record.com/images/MCEcalendar01.png
[/img]

.Nico
Autodiscover isn't enabled on your server according to that, if you set that up it will work. I'll have to see how much work it would be to allow you to manually add all the settings. Let me know what you think.

sccrgoalie1

Posts: 317
Joined: Fri Jul 08, 2011 5:52 pm
Location:

HTPC Specs: Show details

#53

Post by sccrgoalie1 » Thu Dec 08, 2011 2:32 pm

Version 1.1.8 posted (Available on skydrive and via auto update)

-Windows live now uses the non-beta URL released yesterday by Microsoft (appears holiday's now come from Windows live calendars which is nice)

New Settings
-Month caching for fast month scrolling
-Remove duplicates (If two or more calendars have the same appointment only one will be shown. Criteria used is subject and start date/time)
-Calendar reloading (allows you to set a time for the calendar to reload if you leave the application open for an extended period of time)

Addin Changes
-Backend changes to prepare for possible day and week views
-Subject now word wraps on the appointment details pane (no longer cuts off)
-Location now word wraps on the appointment details pane (no longer cuts off)

bobbob

Posts: 676
Joined: Wed Oct 26, 2011 11:21 am
Location:

HTPC Specs: Show details

#54

Post by bobbob » Sat Dec 10, 2011 10:15 am

great work sccrgoalie

sccrgoalie1

Posts: 317
Joined: Fri Jul 08, 2011 5:52 pm
Location:

HTPC Specs: Show details

#55

Post by sccrgoalie1 » Wed Dec 21, 2011 7:18 pm

Version 1.1.9 released

This is a major change for Google Calendar users. It uses a whole new method of accessing Google Calendar (the latest api from Google). I no longer store your password in any of my settings file in any form encrypted or not. What this means is you will have to re-setup your Google calendar in the settings tool and give my application permission to view your calendars. This also allows you to add multiple google calendars that are under one user account. Since this is brand new, please let me know if you experience issues.

sccrgoalie1

Posts: 317
Joined: Fri Jul 08, 2011 5:52 pm
Location:

HTPC Specs: Show details

#56

Post by sccrgoalie1 » Wed Dec 21, 2011 11:28 pm

If you have trouble launching the settings tool after the upgrade delete your settings file.

C:\ProgramData\MediaCenterCalendarsAddin\Settings.xml

sccrgoalie1

Posts: 317
Joined: Fri Jul 08, 2011 5:52 pm
Location:

HTPC Specs: Show details

#57

Post by sccrgoalie1 » Thu Dec 22, 2011 12:29 am

Version 1.2.0 released

Fixes major bug related to Google calendars
Fixes major bug related to outlook calendars

Please note my previous post still applies regarding the settings tool not loading.

sccrgoalie1

Posts: 317
Joined: Fri Jul 08, 2011 5:52 pm
Location:

HTPC Specs: Show details

#58

Post by sccrgoalie1 » Wed Dec 28, 2011 8:48 pm

Version 1.2.1 released

-Adds the ability to focus on the body of an appointment and scroll. Just click on the appointment and you will be navigated to the body (if there is a body ). Click the back button to be moved back the appointment you clicked on.

-Fixed body of Exchange appointment. Previous bug prevented all body text from appearing.

Crewski

Posts: 31
Joined: Mon Jul 25, 2011 1:17 pm
Location:

HTPC Specs: Show details

#59

Post by Crewski » Tue Jan 10, 2012 4:45 pm

I'm at work so I can't test this out right now....but does this work on extenders?

sccrgoalie1

Posts: 317
Joined: Fri Jul 08, 2011 5:52 pm
Location:

HTPC Specs: Show details

#60

Post by sccrgoalie1 » Tue Jan 10, 2012 4:46 pm

Crewski wrote:I'm at work so I can't test this out right now....but does this work on extenders?
Sure does. I should say as long as you don't use the outlook tab.

Post Reply