mpconverter (WTV --> MKV; MP4) - Kodi & Plex

gary94080

Posts: 194
Joined: Sun Jun 09, 2013 6:30 am
Location: San Francisco Bay Area

HTPC Specs: Show details

Re: mpconverter (WTV --> MKV; MP4) - Kodi & Plex

#21

Post by gary94080 » Thu Dec 15, 2016 5:04 am

I spent a little more time on this and I deleted the metadata that was in the folder.

instead of messing with my Recorded TV folder under my user name, I decided to just copy a few files into the one that MPConvertor created C:/Recorded TV

when I run MPConvertor the tree shows up in the left window, I put one file into the queue and the file was successfully converted.

when I get more free time I will play with the program some more.

good job on the program.

just a suggestion, is it possible to have the program ignore any file beginning with "manual recording"? if not, you may want to add instructions on how to handle the problem.

KirkMix

Posts: 4
Joined: Thu Dec 15, 2016 6:47 pm
Location:

HTPC Specs: Show details

#22

Post by KirkMix » Thu Dec 15, 2016 6:56 pm

Close to getting this working on Windows 10. The scan works fine as does the 'series' recognition. However the copying/encoding never seems to occur. Listed below is the output from manually running the encode.

12/15/2016 10:44:26 AM File: "W:\\Flip or Flop_Home & Garden Television HDTV (West)_2016_09_22_00_00_00.wtv.wtv"
12/15/2016 10:44:26 AM Converting MPEG to MKV/MP4
12/15/2016 10:44:26 AM Converting file "C:\mpcTemp\Flip or Flop_Home & Garden Television HDTV (West)_2016_09_22_00_00_00.wtv.mpg"
12/15/2016 10:44:26 AM Renaming TV Series files
12/15/2016 10:44:26 AM Renaming Movie files
12/15/2016 10:44:26 AM Converting WTV to MPEG
12/15/2016 10:44:26 AM File: "W:\\Flip or Flop_Home & Garden Television HDTV (West)_2016_12_08_00_00_00.wtv.wtv"
12/15/2016 10:44:26 AM Converting MPEG to MKV/MP4
12/15/2016 10:44:26 AM Converting file "C:\mpcTemp\Flip or Flop_Home & Garden Television HDTV (West)_2016_12_08_00_00_00.wtv.mpg"
12/15/2016 10:44:26 AM Renaming TV Series files
12/15/2016 10:44:26 AM Renaming Movie files
12/15/2016 10:44:26 AM ------------------------------
12/15/2016 10:44:26 AM Job Completed

I do not see any files in either my Temp or Output folders. Loading backup the GUI it happily reports the job is done. Any thoughts?

One thing to note is that the above files are automatically culled for adverts using MCEbuddy. That could of course be doing something strange.

Thanks for the neat app - :)

tipitoe

Posts: 16
Joined: Sun Dec 04, 2016 2:49 pm
Location:

HTPC Specs: Show details

#23

Post by tipitoe » Thu Dec 15, 2016 7:03 pm

gary94080 wrote:I spent a little more time on this and I deleted the metadata that was in the folder.

instead of messing with my Recorded TV folder under my user name, I decided to just copy a few files into the one that MPConvertor created C:/Recorded TV

when I run MPConvertor the tree shows up in the left window, I put one file into the queue and the file was successfully converted.

when I get more free time I will play with the program some more.

good job on the program.

just a suggestion, is it possible to have the program ignore any file beginning with "manual recording"? if not, you may want to add instructions on how to handle the problem.
I'm glad you made this work. Ignoring manual recordings seems to be right approach. I will write a post about it too. Thanks


Sent from my iPhone using Tapatalk

tipitoe

Posts: 16
Joined: Sun Dec 04, 2016 2:49 pm
Location:

HTPC Specs: Show details

#24

Post by tipitoe » Thu Dec 15, 2016 7:15 pm

KirkMix wrote:Close to getting this working on Windows 10. The scan works fine as does the 'series' recognition. However the copying/encoding never seems to occur. Listed below is the output from manually running the encode.

12/15/2016 10:44:26 AM File: "W:\\Flip or Flop_Home & Garden Television HDTV (West)_2016_09_22_00_00_00.wtv.wtv"
12/15/2016 10:44:26 AM Converting MPEG to MKV/MP4
12/15/2016 10:44:26 AM Converting file "C:\mpcTemp\Flip or Flop_Home & Garden Television HDTV (West)_2016_09_22_00_00_00.wtv.mpg"
12/15/2016 10:44:26 AM Renaming TV Series files
12/15/2016 10:44:26 AM Renaming Movie files
12/15/2016 10:44:26 AM Converting WTV to MPEG
12/15/2016 10:44:26 AM File: "W:\\Flip or Flop_Home & Garden Television HDTV (West)_2016_12_08_00_00_00.wtv.wtv"
12/15/2016 10:44:26 AM Converting MPEG to MKV/MP4
12/15/2016 10:44:26 AM Converting file "C:\mpcTemp\Flip or Flop_Home & Garden Television HDTV (West)_2016_12_08_00_00_00.wtv.mpg"
12/15/2016 10:44:26 AM Renaming TV Series files
12/15/2016 10:44:26 AM Renaming Movie files
12/15/2016 10:44:26 AM ------------------------------
12/15/2016 10:44:26 AM Job Completed

I do not see any files in either my Temp or Output folders. Loading backup the GUI it happily reports the job is done. Any thoughts?

One thing to note is that the above files are automatically culled for adverts using MCEbuddy. That could of course be doing something strange.

Thanks for the neat app - :)
I noticed that temp and final output files have double extensions like .wtv.mpg.

Intermediate file name must match xml file stored in \metadata folder, otherwise processing will fail. Also when you open that xml file see tag that contains file name and compare it with original recording.

Also, it looks like renaming takes place at the same time as encoding. That would suggest that encoding failed as soon it was initiated.

Do you have enough space on your C:\ drive ?

If encoding fails an you would like to reprocess it again, you have to remove TRUE from completed tag or delete that file from queue and add it again. Otherwise it will be ignored.

Try to change locations of temp and output folder too.


Sent from my iPhone using Tapatalk

KirkMix

Posts: 4
Joined: Thu Dec 15, 2016 6:47 pm
Location:

HTPC Specs: Show details

#25

Post by KirkMix » Thu Dec 15, 2016 8:18 pm

Looks like C has 632GB free so it should be fine.

The original file WMC has just the one extension - Flip or Flop_Home & Garden Television HDTV (West)_2016_07_07_00_00_00.wtv

Checking the xml (Flip or Flop_Home & Garden Television HDTV (West)_2016_07_07_00_00_00.wtv.xml) we look good there as well...

<?xml version="1.0" encoding="utf-8"?>
<recording>
<filename>Flip or Flop_Home & Garden Television HDTV (West)_2016_07_07_00_00_00.wtv</filename>
<showtitle>Flip or Flop</showtitle>
<episodetitle>Fire Sale Flip</episodetitle>
<description>A homeowner in Costa Mesa, Cal., contacts Tarek and Christina about a great deal on a 1960s single-story home in a great neighborhood. But once they start working on the rehab, they immediately run into big-ticket issues that threaten their profits.</description>
<type>WTV File</type>
<channel>746</channel>
<broadcastdate>?7/?7/?2016 ??12:00 AM</broadcastdate>
<recordingtime>?7/?7/?2016 ??9:00 PM</recordingtime>
<stationCallSign>HGTVD</stationCallSign>
<stationName>Home & Garden Television HDTV (West)</stationName>
<genre>Lifestyle;home & garden</genre>
<length>0</length>
<datereleased />
<season />
<dayofweek>Thursday</dayofweek>
<episode />
</recording>

The recording is via a HDHomeRun Cable unit - Xfinity source (possibly x264 rather than mpg?)

I also tried changing the directories (set them to the fileserver). No joy - issue is the same.

tipitoe

Posts: 16
Joined: Sun Dec 04, 2016 2:49 pm
Location:

HTPC Specs: Show details

#26

Post by tipitoe » Thu Dec 15, 2016 8:54 pm

Can you please check again in xml file what do you have in that filename field. It should be filename without extension.

Your one shows name with extension.




Sent from my iPhone using Tapatalk

KirkMix

Posts: 4
Joined: Thu Dec 15, 2016 6:47 pm
Location:

HTPC Specs: Show details

#27

Post by KirkMix » Thu Dec 15, 2016 11:12 pm

Well you were totally correct about the cause. After running the scan I manually went in and removed the .wtv suffix from both the metadata <filename> and the job.queues <filename> entries for the video file and everything worked perfectly.

Now the only question is why are the entries being created like that? As I mentioned before the videos have been run though MCEbuddy to remove adverts. I can disable that on the WMC server and then run the tool again tomorrow to see if that is related.

Thanks for the quick response. Tool is going to be very helpful. :thumbup:

tipitoe

Posts: 16
Joined: Sun Dec 04, 2016 2:49 pm
Location:

HTPC Specs: Show details

#28

Post by tipitoe » Fri Dec 16, 2016 3:01 am

Try to see what is a full name of the wtv file that was processed through MCEbuddy. Go to Folder Options and enable Show extensions. My guess is that MCEbuddy appends new extension to the one that already exists. That's why it looks like file has two extensions.


Sent from my iPhone using Tapatalk

KirkMix

Posts: 4
Joined: Thu Dec 15, 2016 6:47 pm
Location:

HTPC Specs: Show details

#29

Post by KirkMix » Fri Dec 16, 2016 3:40 am

Great minds think alike - :)

I checked that first but the files names are as expected. 'Grey's Anatomy_KGO HDTV_2016_05_19_00_00_00.wtv' for example.

I disabled MCEbuddy but again no difference. This is the metadata file for one of the kids shows tonight...

-<recording>
<filename>Teen Titans Go!_TOONH_2016_12_15_17_00_00.wtv</filename>
<showtitle>Teen Titans Go!</showtitle>
<episodetitle>Oh Yeah!; The Teen Titans Go Easter Holiday Classic</episodetitle>
<description>Cyborg teaches the Titans about real wrestling; the Easter Bunny goes missing and the Titans are tasked with finding him.</description>
<type>WTV File</type>
<channel>766</channel>
<broadcastdate/>
<recordingtime>?12/?15/?2016 ??5:00 PM</recordingtime>
<stationCallSign>TOONH</stationCallSign>
<stationName>Cartoon Network HDTV (West)</stationName>
<genre>action/adventure;Childrens</genre>
<length>19</length>
<datereleased/>
<season/>
<dayofweek>Thursday</dayofweek>
<episode/>
</recording>

I verified that adverts were present in this file so it had not gone through MCEbuddy.

curiouser and curiouser

BTW - Running on Windows 10 and access a Windows 8 WMC server accross the network. The RecordedTV remote drive is mapped as W:

Update - Network seems to have nothing to do with it - I copied three files to the local hard drive and ran everything with the default C: settings. Still includes the .wtv file extension in metadata and jobs.queue

tipitoe

Posts: 16
Joined: Sun Dec 04, 2016 2:49 pm
Location:

HTPC Specs: Show details

#30

Post by tipitoe » Fri Dec 16, 2016 7:21 pm

I have an idea what is causing this behavior. Windows has a strange way of storing certain strings. If you look at the date field, you would also see multiple "?"'characters. They should not be there. In my xml files they do not show up. I know they are there and programs takes care of them later. It would seem that file name also contains this "additional" information that is ".wtv". This additional characters are not visible to "naked" eye. Yet for some reasons showing up in your xmls. I would have to make some adjustments and see if that solves the problem.


Sent from my iPhone using Tapatalk

User avatar
Crash2009

Posts: 4357
Joined: Thu May 17, 2012 12:38 am
Location: Ann Arbor, Michigan

HTPC Specs: Show details

#31

Post by Crash2009 » Sat Dec 17, 2016 12:02 pm

Any of you guys using any other MetaData "grabbers"? Yamm, MyMovies, etc? Are you using Kodi or Plex?

Maybe other software you have installed is conflicting.

gary94080

Posts: 194
Joined: Sun Jun 09, 2013 6:30 am
Location: San Francisco Bay Area

HTPC Specs: Show details

#32

Post by gary94080 » Sun Dec 18, 2016 10:00 am

Crash2009 wrote:Any of you guys using any other MetaData "grabbers"? Yamm, MyMovies, etc? Are you using Kodi or Plex?

Maybe other software you have installed is conflicting.
nope. mine is a very vanilla set up, no add-on's. my error was caused by WMC manual recordings not having meta-data that mpconverter was expecting

tipitoe

Posts: 16
Joined: Sun Dec 04, 2016 2:49 pm
Location:

HTPC Specs: Show details

#33

Post by tipitoe » Mon Dec 19, 2016 3:09 am

mpconverter beta 0.2 was released.

It should address following issues:

- added support for Windows 8
- preventing manual recordings from being processed
- preventing windows media center sample files from being processed
- added logs for queue and encoder
- removed duplicate episode tag in nfo files
- filename tag in xml files was showing full name instead filename without extension

Note: when upgrading remove all xml files from \metadata folder

Initial scan of input folder takes much longer than previously. I recommend monitoring activity in \metadata folder

This issue will be addressed in next release.


Sent from my iPhone using Tapatalk

tipitoe

Posts: 16
Joined: Sun Dec 04, 2016 2:49 pm
Location:

HTPC Specs: Show details

#34

Post by tipitoe » Fri Dec 23, 2016 7:42 pm

This is the last update in this calendar year. It fixes the scanning speed of an input folder. Previous update introduced this issue.

I made some changes to the used method. Originally, we had to know location of a header id number for WTV file. These numbers differed from one operating system to another. Now, we take sample file, map it ourselves by using header name and pass it to the method that extracts metadata. This way we do not need to worry about what Windows version we are using. I tested application on Windows 7 and Windows 10. It should work on Windows 8 too.

Although scanning speed is really fast, you need to consider how many recordings you have in your Recorded TV folder. I have about 3.5 TB of data that takes about 2 minutes to scan over LAN.

Please let me know if you encounter any issues.

Post Reply