ServerWMC

Post Reply
User avatar
lachape_one

Posts: 72
Joined: Fri May 06, 2016 10:54 am
Location: Versailles, France

HTPC Specs: Show details

ServerWMC

#1

Post by lachape_one » Thu Jul 28, 2016 9:24 am

hi
I followed this tuto http://mediaputer.com/featured/2015/06/ ... serverwmc/ and tried to set up ServerWMC to watch live TV through Plex
but ive got an issue when configuring ServerWMC httpService to open port 9080 and enable live tv stream: an error message occurs "unable to run service, stream service not configured"
if someone had succesfully set this up, i ll appreciate some help

Sharks

Posts: 181
Joined: Sun Feb 01, 2015 6:35 pm
Location:

HTPC Specs: Show details

#2

Post by Sharks » Fri Jul 29, 2016 1:40 am

Hello, I have successfully got ServerWMC setup with Plex. That being said I haven't seen that error but I'll try and help.
You said you followed a tutorial did you happen to take a look at the ServerWMC installation instructions? From the sounds of your it seems like the server isn't setup quite right. I would take a look at this and see if your settings line up: http://kodi.wiki/view/PVR/Backend/ServerWMC

Once you verified that ServerWMC is setup correctly I would follow these installation instructions for wmc2plex http://jobbos.com/wmc2plex/doku.php?id=installation

I pulled all these links from here: https://0df317251eddfb99d4fce96eecb40d4 ... index.html

If your still having issues after that feel free to come back and we'll continue trouble shooting. : D

User avatar
lachape_one

Posts: 72
Joined: Fri May 06, 2016 10:54 am
Location: Versailles, France

HTPC Specs: Show details

#3

Post by lachape_one » Fri Jul 29, 2016 5:44 am

Sharks wrote:would take a look at this and see if your settings line up: http://kodi.wiki/view/PVR/Backend/ServerWMC
done but anywhere in the site they talk about Http Service tab in which i have the error message everytime i try to enable the http service host, do you have such tab?

Image

Sharks

Posts: 181
Joined: Sun Feb 01, 2015 6:35 pm
Location:

HTPC Specs: Show details

#4

Post by Sharks » Fri Jul 29, 2016 5:58 pm

Sorry for the dumb question but what version of Windows are you running and can WMC currently watch/record live tv?

User avatar
lachape_one

Posts: 72
Joined: Fri May 06, 2016 10:54 am
Location: Versailles, France

HTPC Specs: Show details

#5

Post by lachape_one » Fri Jul 29, 2016 7:25 pm

youre welcome, the PC is under Windows 7 and Windows Media Center is running with a hauppauge colussus capture card,

Sharks

Posts: 181
Joined: Sun Feb 01, 2015 6:35 pm
Location:

HTPC Specs: Show details

#6

Post by Sharks » Fri Jul 29, 2016 7:43 pm

Hmm, So I just installed it on second computer and it current status is -
"Status: Port 9180 not opened, Service not configured, Stream Service not configured"

When I click the enable button multiple UAC windows pop up of which I click yes to all of them it then gives me the status of my server. Do you see UAC windows pop up when you click the checkbox to enable http?

User avatar
lachape_one

Posts: 72
Joined: Fri May 06, 2016 10:54 am
Location: Versailles, France

HTPC Specs: Show details

#7

Post by lachape_one » Fri Jul 29, 2016 8:14 pm

Sharks wrote:Hmm, So I just installed it on second computer and it current status is -
"Status: Port 9180 not opened, Service not configured, Stream Service not configured"

When I click the enable button multiple UAC windows pop up of which I click yes to all of them it then gives me the status of my server. Do you see UAC windows pop up when you click the checkbox to enable http?
Yes i see the UAC prompt twice and clicked ok each time

and the weird aspect is that you talk about port 9180, it's the port number i've seen too in my ServerWMC log:

2016/07/29 22:11:35.316 StartWcfHost> attempting to aquire acl reservation for: http://+:9180/serverwmc/

i wonder why, because in the general tab, i specified port 9080 as the port to be used :(

Image

Sharks

Posts: 181
Joined: Sun Feb 01, 2015 6:35 pm
Location:

HTPC Specs: Show details

#8

Post by Sharks » Fri Jul 29, 2016 8:27 pm

Weird, so I get 3 distinctly different pop up windows:

Program name: Network Command Shell
Verified Publisher: Microsoft Windows
Program Location: "C:\Windows\System32\netsh.exe"
advfirewall firewall add rule
name= "ServerWMC HTTP Port"
protocol=TCP dir=in localport=9180
action=allow

Program name: Network Command Shell
Verified Publisher: Microsoft Windows
Program Location: "C:\Windows\System32\netsh.exe" http add
urlacl url http://+:9180/serverwmc/
users=Everyone

Program name: Network Command Shell
Verified Publisher: Microsoft Windows
Program Location: "C:\Windows\System32\netsh.exe" http add
urlacl url=http://+:9180/serverwmc.stream/
users=Everyone

So I just checked my firewall settings on my main computer with a working serverwmc/plex:
ServerWMC Private,Public Allow NO Inbound C:\program files (x86)\serverwmc\serverwmc.exe Any Any TCP Any Any Any Any Any Any OK
ServerWMC Private,Public Allow NO Inbound C:\program files (x86)\serverwmc\serverwmc.exe Any Any UDP Any Any Any Any Any Any OK
ServerWMC HTTP PORT All Allow NO Inbound Any Any Any TCP 9180 Any Any Any Any Any OK

Hopefully that helps, also I think the 9080 is for incoming request from plex not the port it sends back out on but I am guessing on that.

User avatar
lachape_one

Posts: 72
Joined: Fri May 06, 2016 10:54 am
Location: Versailles, France

HTPC Specs: Show details

#9

Post by lachape_one » Sun Jul 31, 2016 1:52 pm

thanks for the tip, but i have now a very big issue for the media center guide: each program of my whole 160 channels are now planned to be recorded :shock: !!! i've never seen this before, WMC says there is near 540Gb of TV shows which will be recorded, so freaking :crazy: , and i don't know if its because of what i have tried to resolve this issue, now i made up my mind to reinstall entirely my HTPC because i dont like when things going crazy like that, i'd i'll try installing ServerWMC again, then i 'll tell you ,
a+

Sharks

Posts: 181
Joined: Sun Feb 01, 2015 6:35 pm
Location:

HTPC Specs: Show details

#10

Post by Sharks » Wed Aug 03, 2016 10:57 pm

Sounds good, hopefully that will help in getting plex/serverwmc working as well.

Post Reply