MCS Theme: Some colors won't change

Post Reply
braigo64

Posts: 10
Joined: Sat Apr 18, 2015 1:09 pm
Location:

HTPC Specs: Show details

MCS Theme: Some colors won't change

#1

Post by braigo64 » Sun Jun 19, 2016 1:11 pm

Been using MCS for years to style WMC. Since my backgrounds are darker I made most of the colors white which worked well. Lately, I changed the background image of my theme and when I applied everything it worked except some of the text in WMC now shows as the default pale blue color. No matter how I edit my theme and the color (which has no blue colors anywhere in it) WMC still shows the default text colors in some areas. Any idea how I can get this to go away? This also includes the light blue overlay on recording thumbnails. It's very annoying and I'd like to change it.

User avatar
DavidinCT

Posts: 1527
Joined: Mon Feb 13, 2012 3:45 pm
Location:

HTPC Specs: Show details

#2

Post by DavidinCT » Fri Jun 24, 2016 11:18 pm

braigo64 wrote:Been using MCS for years to style WMC. Since my backgrounds are darker I made most of the colors white which worked well. Lately, I changed the background image of my theme and when I applied everything it worked except some of the text in WMC now shows as the default pale blue color. No matter how I edit my theme and the color (which has no blue colors anywhere in it) WMC still shows the default text colors in some areas. Any idea how I can get this to go away? This also includes the light blue overlay on recording thumbnails. It's very annoying and I'd like to change it.
Odd, no question. I used MCS almost forever. Try to see if you can set WMC to default and then try again.

If you want you can do a SFC /SCANNOW in a admin command line, This will do a file check to confirm all Windows files have not been touched. This will also change the WMC files back and restore the default blue... How MCS works is it edits one of WMC's DLL files and replaces parts of it. The scannow replaces it with the original files.

After you get it back to the default blue, try to apply your theme again.

What is the name of your themes your using ? Just wondering I use MCS too along with the newer themer...
-Dave
Twitter @TheCoolDave

Windows Media Center certified and WMC MVP 2010 - 2012

braigo64

Posts: 10
Joined: Sat Apr 18, 2015 1:09 pm
Location:

HTPC Specs: Show details

#3

Post by braigo64 » Sun Jun 26, 2016 3:31 pm

I ran sfc /scannow and checked the log file. It said ehres.dll was corrupted but couldn't repair it because the source file was also corrupted. Ended up replacing it with a clean copy. WMC loaded up with all its default styling. I then closed WMC and reapplied my theme in MCS. When I opened WMC back up it had the right background image but some of the blue text was still there so it doesn't look like that fixed anything.

I used a pre-existing theme and customized a few things about it like the colors and images. I don't remember which one I based it off of. I also applied several other themes I've found for MCS and no matter which ones I apply the default blue color still exists even though everything else changes.

User avatar
IT Troll

Posts: 830
Joined: Sun Nov 27, 2011 9:42 am
Location: Edinburgh, UK

HTPC Specs: Show details

#4

Post by IT Troll » Wed Jun 29, 2016 10:59 am

Traditional DLL modifying themers are limited in what they can change. You may have more luck with Media Center Themer which substitutes things in memory without modifying the underlying DLL.

http://www.patchou.com/projects/media-center-themer/
Are you a Recorded TV HD user or want to give it a try? Check out the new community-made update; Recorded TV HD v2.1.1

braigo64

Posts: 10
Joined: Sat Apr 18, 2015 1:09 pm
Location:

HTPC Specs: Show details

#5

Post by braigo64 » Sat Jul 02, 2016 1:10 pm

Thanks IT Troll, I was able to change the lingering blue text colors. However, I'm not sure what to add to the xml file to change the blue overlay on the thumbnails of recordings when you open the recordings area. That's the only outstanding theme issue I still have.

Post Reply