Scheduled recordings don't start

Post Reply
mskenny

Posts: 36
Joined: Tue Jun 21, 2011 8:37 pm
Location:

HTPC Specs: Show details

Scheduled recordings don't start

#1

Post by mskenny » Thu Apr 28, 2016 3:00 pm

I've had a new problem in Win 7 WMC since the most recent 2 rounds of Windows Updates. Recordings don't start unless I manually intervene. When the scheduled time comes up, I can look in Recorded TV and see that the program isn't recording. The guide shows the red icon showing the program should be recorded but it doesn't happen. If I turn off the record setting for the program and turn it back on, it starts to record. No mention of the recording appears in the Windows Media Center event log, and if you go to History in Recorded TV there's nothing there. I tried removing my settings and doing Live TV setup over again and it worked the first night but not since. I also tried removing the most recent Windows Updates but haven't wanted to go back further. Can anyone suggest anything else to try short of removing and reinstalling WMC? Thanks.

Space

Posts: 1826
Joined: Sun Jun 02, 2013 9:44 pm
Location:

HTPC Specs: Show details

#2

Post by Space » Thu Apr 28, 2016 3:40 pm

Perhaps a corrupted "StartRecording" entry in the Task Scheduler:
http://www.thegreenbutton.tv/forums/vie ... 11#p102911

mskenny

Posts: 36
Joined: Tue Jun 21, 2011 8:37 pm
Location:

HTPC Specs: Show details

#3

Post by mskenny » Thu Apr 28, 2016 6:04 pm

Indeed the StartRecording task was corrupt. I deleted it and when I started WMC it recreated the task. I've set a recording to start shortly and we'll see what happens. Thanks!

Space

Posts: 1826
Joined: Sun Jun 02, 2013 9:44 pm
Location:

HTPC Specs: Show details

#4

Post by Space » Thu Apr 28, 2016 9:57 pm

Nice, please do report back on the status.

Generally when you have a corrupt StartRecording task, recordings do not start if you don't have WMC running, but will work if WMC is running.

So turning off the record setting and turning it back on itself doesn't fix anything, it is just the fact that WMC was running at the time the recording was supposed to start that caused it to work (programs that are still in progress but were scheduled to start recording before you had WMC running will not start recording automatically when you start up WMC).

nanat

Posts: 11
Joined: Mon Jul 20, 2015 3:19 pm
Location:

HTPC Specs: Show details

#5

Post by nanat » Sun Sep 03, 2017 4:12 pm

Hi. Found this string from over a year ago but it solved our recent problem! Thanks Space!! Symptom/issue: WMC was no longer recording scheduled programs. Solution: Followed the instructions as indicated to find the task which was corrupt. Closed WMC. Deleted task and restarted WMC. StartRecording was recreated and so far (a few days later) scheduled recordings seem to be happening as they should. Thanks again!

Post Reply