Page 1 of 1

Waiting for Channel Map / ERROR: trif[6] Failed to unpack channel_table_rsp message (len 16384)

Posted: Wed Jul 03, 2019 2:32 am
by mls001
Background:
I have two separate WMC systems. WMC-A (the original) has a Ceton PCI-4 and an ETH-6 tuner. WMC-B (the new system) has only an ETH-6. Each tuner has an associated MTR700 Tuning Adapter.

A couple of weeks ago, I noticed that the TA servicing the ETH-6 on WMC-A showed "Waiting for Channel Map." The TA servicing the PCI-4 was still Ready. The TA attached to the tuner on WMC-B was also Ready.

I tried issuing a Reboot to the ETH-6 on WMC-A, but the status went back to "Waiting for Channel Map." I then power cycled both the TA and the ETH-6, but the TA's status went back to "Waiting for Channel Map."

I contacted Spectrum, they didn't see anything wrong but went ahead and reset the TA, and it went back to "Waiting for Channel Map." The Spectrum agent decided that the TA must have gone bad. He suggested that we prove the TA was bad by swapping it with one of the other working TA's. So I swapped the TA's that were servicing the ETH-6 tuner on each WMC.

Unfortunately, then both got stuck at "Waiting for Channel Map." The Spectrum agent then scheduled a service visit.

While waiting for the onsite visit I read through the logs and found the following:

Jan 1 00:22:56 ocur[21]: libcetontrif: trif[6] re requesting channel map
Jan 1 00:22:57 ocur[21]: libcetontrif: WARNING: Check failed
Jan 1 00:22:57 ocur[21]: libcetontrif: WARNING: Check failed
Jan 1 00:22:57 ocur[21]: libcetontrif: WARNING: expected 16450 bytes 962 channels and only got 962 channels
Jan 1 00:22:57 ocur[21]: libcetontrif: WARNING: Check failed
Jan 1 00:22:57 ocur[21]: libcetontrif: ERROR: trif[6] Failed to unpack channel_table_rsp message (len 16384)
Jan 1 00:22:57 ocur[21]: libcetontrif: WARNING: Unhandled trif apdu. (0x58)
Jan 1 00:23:12 ocur[21]: libcetontrif: trif[6] re requesting channel map
Jan 1 00:23:13 ocur[21]: libcetontrif: WARNING: Check failed
Jan 1 00:23:13 ocur[21]: libcetontrif: WARNING: Check failed
Jan 1 00:23:13 ocur[21]: libcetontrif: WARNING: expected 16450 bytes 962 channels and only got 962 channels
Jan 1 00:23:13 ocur[21]: libcetontrif: WARNING: Check failed
Jan 1 00:23:13 ocur[21]: libcetontrif: ERROR: trif[6] Failed to unpack channel_table_rsp message (len 16384)
Jan 1 00:23:13 ocur[21]: libcetontrif: WARNING: Unhandled trif apdu. (0x58)
Jan 1 00:23:28 ocur[21]: libcetontrif: trif[6] re requesting channel map
Jan 1 00:23:29 ocur[21]: libcetontrif: WARNING: Check failed
Jan 1 00:23:29 ocur[21]: libcetontrif: WARNING: Check failed
Jan 1 00:23:29 ocur[21]: libcetontrif: WARNING: expected 16450 bytes 962 channels and only got 962 channels
Jan 1 00:23:29 ocur[21]: libcetontrif: WARNING: Check failed
Jan 1 00:23:29 ocur[21]: libcetontrif: ERROR: trif[6] Failed to unpack channel_table_rsp message (len 16384)
Jan 1 00:23:29 ocur[21]: libcetontrif: WARNING: Unhandled trif apdu. (0x58)
Jan 1 00:23:44 ocur[21]: libcetontrif: trif[6] re requesting channel map
Jan 1 00:23:45 ocur[21]: libcetontrif: WARNING: Check failed
Jan 1 00:23:45 ocur[21]: libcetontrif: WARNING: Check failed
Jan 1 00:23:45 ocur[21]: libcetontrif: WARNING: expected 16450 bytes 962 channels and only got 962 channels
Jan 1 00:23:45 ocur[21]: libcetontrif: WARNING: Check failed
Jan 1 00:23:45 ocur[21]: libcetontrif: ERROR: trif[6] Failed to unpack channel_table_rsp message (len 16384)
Jan 1 00:23:45 ocur[21]: libcetontrif: WARNING: Unhandled trif apdu. (0x58)

...over and over and over.

These errors are NOT occurring on the PCI-4 tuner, but are occurring on the ETH-6 tuner connected to BOTH WMC-A and WMC-B.

When the Spectrum service tech was onsite, the levels were checked, cables were swapped, two tuning adapters and one cable card were replaced, but there was no change in the symptoms.
On WMC-B (the one with just the single ETH-6) I have reset the tuner and gone through channel setup multiple times without any change in the symptoms.

Any suggestions?