Windows 7 WMC 4K desktop oddity

Post Reply
Paul Anderegg

Posts: 110
Joined: Sat Apr 21, 2012 4:39 am
Location:

HTPC Specs: Show details

Windows 7 WMC 4K desktop oddity

#1

Post by Paul Anderegg » Sat Jun 24, 2017 7:59 pm

So, I switched my PC to 2160p 60Hz, and resized my desktop 200% and checked off Windows XP HiDPI mode. Strangely enough, I get 4K desktop sharpness, but when I open WMC, the resolution switches to 1080p 60Hz. When I minimize WMC, the resolution increases back to UHD. If I uncheck Windows XP HiDPI option in scaling, WMC will run to full UHD with the stupid warning. This seems a bit odd, but I like it...I get the benefits of HiDPI desktop smoothness, without the inherent issues of upscaling 1080p content via the GPU instead of the TV's built in and arguably better scaler. WMC can't play 4K content anyway, so this seems like a nice set of settings, especially if you run iGPU, which would not scale well running WMC in UHD, but would be able to produce crisp/smooth desktop in 4K. :-)

Paul

User avatar
Crash2009

Posts: 4357
Joined: Thu May 17, 2012 12:38 am
Location: Ann Arbor, Michigan

HTPC Specs: Show details

#2

Post by Crash2009 » Fri Jul 07, 2017 6:15 am

Do you get different results if you run WMC/Setup Display?

User avatar
DavidinCT

Posts: 1450
Joined: Mon Feb 13, 2012 3:45 pm
Location:

HTPC Specs: Show details

#3

Post by DavidinCT » Fri Jul 07, 2017 12:40 pm

Paul Anderegg wrote:So, I switched my PC to 2160p 60Hz, and resized my desktop 200% and checked off Windows XP HiDPI mode. Strangely enough, I get 4K desktop sharpness, but when I open WMC, the resolution switches to 1080p 60Hz. When I minimize WMC, the resolution increases back to UHD. If I uncheck Windows XP HiDPI option in scaling, WMC will run to full UHD with the stupid warning. This seems a bit odd, but I like it...I get the benefits of HiDPI desktop smoothness, without the inherent issues of upscaling 1080p content via the GPU instead of the TV's built in and arguably better scaler. WMC can't play 4K content anyway, so this seems like a nice set of settings, especially if you run iGPU, which would not scale well running WMC in UHD, but would be able to produce crisp/smooth desktop in 4K. :-)

Paul
Go into TV setup (monitor) in WMC , switch the res of WMC to 4K. Your set to 1080p 60hz. You can change it to 4K, it does scale but, does not get too much better as it was never designed for 4K.

I have WMC going into a 4K tv with WMC set in 4K @ 60hz as a HTPC. It does scale down for TV shows but, with other content like movies and stuff like that, It will scale that to 4K.

I have 6-7 4K movies now in my Movie Library and they look as nice in WMC as they do using a USB drive directly into the tv.
-Dave
Twitter @TheCoolDave

Windows Media Center certified and WMC MVP 2010 - 2012

poit57

Posts: 56
Joined: Mon May 05, 2014 7:02 pm
Location:

HTPC Specs: Show details

#4

Post by poit57 » Sat Oct 21, 2017 8:58 pm

I recently got a 4K TV and changed the resolution on my PC to match. Every time I start WMC, this message pops up in the lower right corner:
Your display is running at very high resolution that may cause performance problems in Windows Media Center. Open the Display Settings Control Panel then reduce the resolution for the primary monitor."
Sometimes, the focus is on this message and I can dismiss it with the MCE remote. Other times, I either have to wait for the message to go away on its own after about 20 seconds or grab a mouse to click the OK button to dismiss the message. Is there any way to disable this message?

Space

Posts: 1826
Joined: Sun Jun 02, 2013 9:44 pm
Location:

HTPC Specs: Show details

#5

Post by Space » Sun Oct 22, 2017 12:43 am

Check this thread for an answer to your issue:

viewtopic.php?f=5&t=8325

User avatar
DavidinCT

Posts: 1450
Joined: Mon Feb 13, 2012 3:45 pm
Location:

HTPC Specs: Show details

#6

Post by DavidinCT » Tue Oct 24, 2017 12:53 pm

poit57 wrote:I recently got a 4K TV and changed the resolution on my PC to match. Every time I start WMC, this message pops up in the lower right corner:
Your display is running at very high resolution that may cause performance problems in Windows Media Center. Open the Display Settings Control Panel then reduce the resolution for the primary monitor."
Sometimes, the focus is on this message and I can dismiss it with the MCE remote. Other times, I either have to wait for the message to go away on its own after about 20 seconds or grab a mouse to click the OK button to dismiss the message. Is there any way to disable this message?
I am the one who ended up getting a work around for it. This only works on Windows 7 and DEPENDING On the VERSION of the files (this is critical). This can be a very tricky one if your not techy in anyway. It requires HEX editing files to make this message hidden in WMC. Then requires special permissions to replace the files

This gives the info...
viewtopic.php?p=116177#p116177

This is the ONLY way to fully get RID of this message. A lot of my trials in the FULL thread above worked for a temp time but, would always come back.
-Dave
Twitter @TheCoolDave

Windows Media Center certified and WMC MVP 2010 - 2012

Post Reply