What version of .NET?

A place for App developers to hang out / post
Post Reply
jachin99

Posts: 1243
Joined: Wed Feb 24, 2016 3:36 pm
Location:

HTPC Specs: Show details

What version of .NET?

#1

Post by jachin99 » Mon Mar 27, 2017 8:00 pm

I haven't been able to obtain an older version of MS Visual Studio but, I do have a full version MSVS 2015, on one machine, and the freeware version of 2017 on another. By default, these use the latest version of .net, and I have been able to change this to .net 2.0 in most cases however, I would rather not have to drill too much into the settings across different versions of visual studio in order to build programs in the correct version of .net so, what versions of .net will be compatible with WMC?

webminster

Posts: 656
Joined: Tue Dec 20, 2011 11:05 pm
Location:

HTPC Specs: Show details

#2

Post by webminster » Tue Mar 28, 2017 3:31 am

Once upon a time long ago, I built an addon for WMC Windows 7... I set the Application target framework to ".NET Framework 3.5". I /think/ (unsure) that Win8 WMC was recompiled for .Net 4.0, but never experimented with Windows 8 MC. Hope this helps.
-Alan

jachin99

Posts: 1243
Joined: Wed Feb 24, 2016 3:36 pm
Location:

HTPC Specs: Show details

#3

Post by jachin99 » Sat Apr 08, 2017 2:42 am

I'm looking at a plugin for win 7. How did you create the plugin? I'm debating between a windows presentation foundation program that uses xaml or something in MCML. I'm new to development so I'm leaning towards WPF because its documented, and still in use. At the same time, I want something that works good with extenders, and behaves in WMC.

jachin99

Posts: 1243
Joined: Wed Feb 24, 2016 3:36 pm
Location:

HTPC Specs: Show details

#4

Post by jachin99 » Tue Oct 17, 2017 8:08 pm

Under visual studio 2008, the WMC samples have a default .net target of 4.0. If you import a WMC sample from the Vista WMC SDK it will convert it to .net 4.0 also.

jachin99

Posts: 1243
Joined: Wed Feb 24, 2016 3:36 pm
Location:

HTPC Specs: Show details

#5

Post by jachin99 » Fri Oct 20, 2017 7:22 pm

Correction, MSVS 2008 uses .net 3.5.

Post Reply